nginx.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730
  1. #
  2. %define nginx_home %{_localstatedir}/cache/nginx
  3. %define nginx_user nginx
  4. %define nginx_group nginx
  5. %define nginx_loggroup adm
  6. BuildRequires: systemd
  7. Requires(post): systemd
  8. Requires(preun): systemd
  9. Requires(postun): systemd
  10. %if 0%{?rhel}
  11. %define _group System Environment/Daemons
  12. %endif
  13. %if (0%{?rhel} == 7) && (0%{?amzn} == 0)
  14. %define epoch 1
  15. Epoch: %{epoch}
  16. Requires(pre): shadow-utils
  17. Requires: openssl >= 1.0.2
  18. Requires: procps-ng
  19. BuildRequires: openssl-devel >= 1.0.2
  20. BuildRequires: perl-IPC-Cmd
  21. %define dist .el7
  22. %endif
  23. %if (0%{?rhel} == 7) && (0%{?amzn} == 2)
  24. %define epoch 1
  25. Epoch: %{epoch}
  26. Requires(pre): shadow-utils
  27. Requires: openssl11 >= 1.1.1
  28. Requires: procps-ng
  29. BuildRequires: openssl11-devel >= 1.1.1
  30. %endif
  31. %if 0%{?rhel} == 8
  32. %define epoch 1
  33. Epoch: %{epoch}
  34. Requires(pre): shadow-utils
  35. Requires: procps-ng
  36. BuildRequires: openssl-devel >= 1.1.1
  37. %define _debugsource_template %{nil}
  38. %endif
  39. %if 0%{?rhel} == 9
  40. %define epoch 1
  41. Epoch: %{epoch}
  42. Requires(pre): shadow-utils
  43. Requires: procps-ng
  44. BuildRequires: openssl-devel
  45. BuildRequires: gcc
  46. %define _debugsource_template %{nil}
  47. %endif
  48. %if 0%{?suse_version} >= 1315
  49. %define _group Productivity/Networking/Web/Servers
  50. %define nginx_loggroup trusted
  51. Requires(pre): shadow
  52. Requires: procps
  53. BuildRequires: libopenssl-devel
  54. %define _debugsource_template %{nil}
  55. %endif
  56. # This also applies to Amazon Linux 2023
  57. %if 0%{?fedora}
  58. %define _debugsource_template %{nil}
  59. %global _hardened_build 1
  60. %define _group System Environment/Daemons
  61. Requires: procps-ng
  62. BuildRequires: openssl-devel
  63. Requires(pre): shadow-utils
  64. %endif
  65. # end of distribution specific definitions
  66. %define openssl_version 3.0.10-quic1
  67. %define base_version 1.25.3
  68. %define base_release 1%{?dist}.ngx
  69. %define bdir %{_builddir}/%{name}-%{base_version}
  70. %define WITH_CC_OPT $(echo %{optflags} $(pcre2-config --cflags)) -fPIC
  71. %define WITH_LD_OPT -Wl,-z,relro -Wl,-z,now -pie
  72. %define BASE_CONFIGURE_ARGS $(echo "--prefix=%{_sysconfdir}/nginx --sbin-path=%{_sbindir}/nginx --modules-path=%{_libdir}/nginx/modules --conf-path=%{_sysconfdir}/nginx/nginx.conf --error-log-path=%{_localstatedir}/log/nginx/error.log --http-log-path=%{_localstatedir}/log/nginx/access.log --pid-path=%{_localstatedir}/run/nginx.pid --lock-path=%{_localstatedir}/run/nginx.lock --http-client-body-temp-path=%{_localstatedir}/cache/nginx/client_temp --http-proxy-temp-path=%{_localstatedir}/cache/nginx/proxy_temp --http-fastcgi-temp-path=%{_localstatedir}/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=%{_localstatedir}/cache/nginx/uwsgi_temp --http-scgi-temp-path=%{_localstatedir}/cache/nginx/scgi_temp --user=%{nginx_user} --group=%{nginx_group} --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module $( if [ 0%{?rhel} -eq 7 ] || [ 0%{?suse_version} -eq 1315 ]; then continue; else echo "--with-http_v3_module"; fi; ) --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module")
  73. Summary: High performance web server
  74. Name: nginx
  75. Version: %{base_version}
  76. Release: %{base_release}
  77. Vendor: NGINX Packaging <nginx-packaging@f5.com>
  78. URL: https://nginx.org/
  79. Group: %{_group}
  80. #!RemoteAsset: sha256:64c5b975ca287939e828303fa857d22f142b251f17808dfe41733512d9cded86
  81. Source0: https://nginx.org/download/%{name}-%{version}.tar.gz
  82. Source1: logrotate
  83. Source2: nginx.conf
  84. Source3: nginx.default.conf
  85. Source4: nginx.service
  86. Source5: nginx.upgrade.sh
  87. Source6: nginx.suse.logrotate
  88. Source7: nginx-debug.service
  89. Source8: nginx.copyright
  90. Source9: nginx.check-reload.sh
  91. #!RemoteAsset: sha256:75a3cbfe414fe7a0d4cfe9919e2a82191e4bc4c4c41b6f0bb18c02a77637d336
  92. Source10: https://github.com/quictls/openssl/archive/refs/tags/openssl-%{openssl_version}.tar.gz
  93. License: 2-clause BSD-like license
  94. BuildRoot: %{_tmppath}/%{name}-%{base_version}-%{base_release}-root
  95. BuildRequires: zlib-devel
  96. BuildRequires: pcre2-devel
  97. BuildRequires: perl
  98. Provides: webserver
  99. Provides: nginx-r%{base_version}
  100. %if !(0%{?rhel} == 7)
  101. Recommends: logrotate
  102. %endif
  103. %description
  104. nginx [engine x] is an HTTP and reverse proxy server, as well as
  105. a mail proxy server.
  106. %if 0%{?suse_version} >= 1315
  107. %debug_package
  108. %endif
  109. %prep
  110. %autosetup -p1
  111. tar -zxf %{SOURCE10}
  112. %build
  113. ./configure %{BASE_CONFIGURE_ARGS} \
  114. --with-openssl=./openssl-openssl-%{openssl_version}/ \
  115. --with-cc-opt="%{WITH_CC_OPT}" \
  116. --with-ld-opt="%{WITH_LD_OPT}" \
  117. --with-debug
  118. make %{?_smp_mflags}
  119. %{__mv} %{bdir}/objs/nginx \
  120. %{bdir}/objs/nginx-debug
  121. ./configure %{BASE_CONFIGURE_ARGS} \
  122. --with-openssl=./openssl-openssl-%{openssl_version}/ \
  123. --with-cc-opt="%{WITH_CC_OPT}" \
  124. --with-ld-opt="%{WITH_LD_OPT}"
  125. make %{?_smp_mflags}
  126. %install
  127. %{__rm} -rf $RPM_BUILD_ROOT
  128. %{__make} DESTDIR=$RPM_BUILD_ROOT INSTALLDIRS=vendor install
  129. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/nginx
  130. %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/html $RPM_BUILD_ROOT%{_datadir}/nginx/
  131. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/*.default
  132. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/fastcgi.conf
  133. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/log/nginx
  134. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/run/nginx
  135. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/cache/nginx
  136. %{__mkdir} -p $RPM_BUILD_ROOT%{_libdir}/nginx/modules
  137. cd $RPM_BUILD_ROOT%{_sysconfdir}/nginx && \
  138. %{__ln_s} ../..%{_libdir}/nginx/modules modules && cd -
  139. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{base_version}
  140. %{__install} -m 644 -p %{SOURCE8} \
  141. $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{base_version}/COPYRIGHT
  142. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d
  143. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  144. %{__install} -m 644 -p %{SOURCE2} \
  145. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  146. %{__install} -m 644 -p %{SOURCE3} \
  147. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d/default.conf
  148. %{__install} -p -D -m 0644 %{bdir}/objs/nginx.8 \
  149. $RPM_BUILD_ROOT%{_mandir}/man8/nginx.8
  150. %{__mkdir} -p $RPM_BUILD_ROOT%{_unitdir}
  151. %{__install} -m644 %SOURCE4 \
  152. $RPM_BUILD_ROOT%{_unitdir}/nginx.service
  153. %{__install} -m644 %SOURCE7 \
  154. $RPM_BUILD_ROOT%{_unitdir}/nginx-debug.service
  155. %{__mkdir} -p $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx
  156. %{__install} -m755 %SOURCE5 \
  157. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/upgrade
  158. %{__install} -m755 %SOURCE9 \
  159. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/check-reload
  160. # install log rotation stuff
  161. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
  162. %if 0%{?suse_version}
  163. %{__install} -m 644 -p %{SOURCE6} \
  164. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  165. %else
  166. %{__install} -m 644 -p %{SOURCE1} \
  167. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  168. %endif
  169. %{__install} -m755 %{bdir}/objs/nginx-debug \
  170. $RPM_BUILD_ROOT%{_sbindir}/nginx-debug
  171. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/koi-utf
  172. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/koi-win
  173. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/win-utf
  174. %check
  175. %{__rm} -rf $RPM_BUILD_ROOT/usr/src
  176. cd %{bdir}
  177. grep -v 'usr/src' debugfiles.list > debugfiles.list.new && mv debugfiles.list.new debugfiles.list
  178. cat /dev/null > debugsources.list
  179. %if 0%{?suse_version} >= 1500
  180. cat /dev/null > debugsourcefiles.list
  181. %endif
  182. %clean
  183. %{__rm} -rf $RPM_BUILD_ROOT
  184. %files
  185. %defattr(-,root,root)
  186. %{_sbindir}/nginx
  187. %{_sbindir}/nginx-debug
  188. %dir %{_sysconfdir}/nginx
  189. %dir %{_sysconfdir}/nginx/conf.d
  190. %{_sysconfdir}/nginx/modules
  191. %config(noreplace) %{_sysconfdir}/nginx/nginx.conf
  192. %config(noreplace) %{_sysconfdir}/nginx/conf.d/default.conf
  193. %config(noreplace) %{_sysconfdir}/nginx/mime.types
  194. %config(noreplace) %{_sysconfdir}/nginx/fastcgi_params
  195. %config(noreplace) %{_sysconfdir}/nginx/scgi_params
  196. %config(noreplace) %{_sysconfdir}/nginx/uwsgi_params
  197. %config(noreplace) %{_sysconfdir}/logrotate.d/nginx
  198. %{_unitdir}/nginx.service
  199. %{_unitdir}/nginx-debug.service
  200. %dir %{_libexecdir}/initscripts/legacy-actions/nginx
  201. %{_libexecdir}/initscripts/legacy-actions/nginx/*
  202. %attr(0755,root,root) %dir %{_libdir}/nginx
  203. %attr(0755,root,root) %dir %{_libdir}/nginx/modules
  204. %dir %{_datadir}/nginx
  205. %dir %{_datadir}/nginx/html
  206. %{_datadir}/nginx/html/*
  207. %attr(0755,root,root) %dir %{_localstatedir}/cache/nginx
  208. %attr(0755,root,root) %dir %{_localstatedir}/log/nginx
  209. %dir %{_datadir}/doc/%{name}-%{base_version}
  210. %doc %{_datadir}/doc/%{name}-%{base_version}/COPYRIGHT
  211. %{_mandir}/man8/nginx.8*
  212. %pre
  213. # Add the "nginx" user
  214. getent group %{nginx_group} >/dev/null || groupadd -r %{nginx_group}
  215. getent passwd %{nginx_user} >/dev/null || \
  216. useradd -r -g %{nginx_group} -s /sbin/nologin \
  217. -d %{nginx_home} -c "nginx user" %{nginx_user}
  218. exit 0
  219. %post
  220. # Register the nginx service
  221. if [ $1 -eq 1 ]; then
  222. /usr/bin/systemctl preset nginx.service >/dev/null 2>&1 ||:
  223. /usr/bin/systemctl preset nginx-debug.service >/dev/null 2>&1 ||:
  224. # print site info
  225. cat <<BANNER
  226. ----------------------------------------------------------------------
  227. Thanks for using nginx!
  228. Please find the official documentation for nginx here:
  229. * https://nginx.org/en/docs/
  230. Please subscribe to nginx-announce mailing list to get
  231. the most important news about nginx:
  232. * https://nginx.org/en/support.html
  233. Commercial subscriptions for nginx are available on:
  234. * https://nginx.com/products/
  235. ----------------------------------------------------------------------
  236. BANNER
  237. # Touch and set permisions on default log files on installation
  238. if [ -d %{_localstatedir}/log/nginx ]; then
  239. if [ ! -e %{_localstatedir}/log/nginx/access.log ]; then
  240. touch %{_localstatedir}/log/nginx/access.log
  241. %{__chmod} 640 %{_localstatedir}/log/nginx/access.log
  242. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/access.log
  243. fi
  244. if [ ! -e %{_localstatedir}/log/nginx/error.log ]; then
  245. touch %{_localstatedir}/log/nginx/error.log
  246. %{__chmod} 640 %{_localstatedir}/log/nginx/error.log
  247. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/error.log
  248. fi
  249. fi
  250. fi
  251. %preun
  252. if [ $1 -eq 0 ]; then
  253. /usr/bin/systemctl --no-reload disable nginx.service >/dev/null 2>&1 ||:
  254. /usr/bin/systemctl stop nginx.service >/dev/null 2>&1 ||:
  255. fi
  256. %postun
  257. /usr/bin/systemctl daemon-reload >/dev/null 2>&1 ||:
  258. if [ $1 -ge 1 ]; then
  259. /sbin/service nginx status >/dev/null 2>&1 || exit 0
  260. /sbin/service nginx upgrade >/dev/null 2>&1 || echo \
  261. "Binary upgrade failed, please check nginx's error.log"
  262. fi
  263. %changelog
  264. * Tue Oct 24 2023 Nginx Packaging <nginx-packaging@f5.com> - 1.25.3-1%{?dist}.ngx
  265. - 1.25.3-1
  266. * Tue Aug 15 2023 Nginx Packaging <nginx-packaging@f5.com> - 1.25.2-1%{?dist}.ngx
  267. - 1.25.2-1
  268. * Tue Jun 13 2023 Nginx Packaging <nginx-packaging@f5.com> - 1.25.1-1%{?dist}.ngx
  269. - 1.25.1-1
  270. * Tue May 23 2023 Nginx Packaging <nginx-packaging@f5.com> - 1.25.0-1%{?dist}.ngx
  271. - 1.25.0-1
  272. * Tue Mar 28 2023 Nginx Packaging <nginx-packaging@f5.com> - 1.23.4-1%{?dist}.ngx
  273. - 1.23.4-1
  274. * Tue Dec 13 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.3-1%{?dist}.ngx
  275. - 1.23.3-1
  276. * Wed Oct 19 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.2-1%{?dist}.ngx
  277. - 1.23.2-1
  278. * Tue Jul 19 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.1-1%{?dist}.ngx
  279. - 1.23.1-1
  280. * Tue Jun 21 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.0-1%{?dist}.ngx
  281. - 1.23.0-1
  282. * Tue Jan 25 2022 Mikhail Isachenkov <mikhail.isachenkov@nginx.com> - 1.21.6-1%{?dist}.ngx
  283. - 1.21.6-1
  284. * Tue Dec 28 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.5-1%{?dist}.ngx
  285. - 1.21.5-1
  286. - built with PCRE2
  287. * Tue Nov 2 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.4-1%{?dist}.ngx
  288. - 1.21.4-1
  289. * Tue Sep 7 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.3-1%{?dist}.ngx
  290. - 1.21.3-1
  291. * Tue Aug 31 2021 Andrei Belov <defan@nginx.com> - 1.21.2-1%{?dist}.ngx
  292. - 1.21.2-1
  293. * Tue Jul 6 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.1-1%{?dist}.ngx
  294. - 1.21.1-1
  295. * Tue May 25 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.0-1%{?dist}.ngx
  296. - 1.21.0-1
  297. * Tue Apr 13 2021 Andrei Belov <defan@nginx.com> - 1.19.10-1%{?dist}.ngx
  298. - 1.19.10-1
  299. * Tue Mar 30 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.9-1%{?dist}.ngx
  300. - 1.19.9-1
  301. * Tue Mar 9 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.8-1%{?dist}.ngx
  302. - 1.19.8-1
  303. * Tue Feb 16 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.7-1%{?dist}.ngx
  304. - 1.19.7-1
  305. * Tue Dec 15 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.6-1%{?dist}.ngx
  306. - 1.19.6-1
  307. * Tue Nov 24 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.5-1%{?dist}.ngx
  308. - 1.19.5-1
  309. * Tue Oct 27 2020 Andrei Belov <defan@nginx.com> - 1.19.4-1%{?dist}.ngx
  310. - 1.19.4-1
  311. * Tue Sep 29 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.3-1%{?dist}.ngx
  312. - 1.19.3
  313. * Tue Aug 11 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.2-1%{?dist}.ngx
  314. - 1.19.2
  315. * Tue Jul 7 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.1-1%{?dist}.ngx
  316. - 1.19.1
  317. * Tue May 26 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.0-1%{?dist}.ngx
  318. - 1.19.0
  319. * Tue Apr 14 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.10-1%{?dist}.ngx
  320. - 1.17.10
  321. * Tue Mar 3 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.9-1%{?dist}.ngx
  322. - 1.17.9
  323. * Tue Jan 21 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.8-1%{?dist}.ngx
  324. - 1.17.8
  325. * Tue Dec 24 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.7-1%{?dist}.ngx
  326. - 1.17.7
  327. * Tue Nov 19 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.6-1%{?dist}.ngx
  328. - 1.17.6
  329. * Tue Oct 22 2019 Andrei Belov <defan@nginx.com> - 1.17.5-1%{?dist}.ngx
  330. - 1.17.5
  331. * Tue Sep 24 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.4-1%{?dist}.ngx
  332. - 1.17.4
  333. * Tue Aug 13 2019 Andrei Belov <defan@nginx.com> - 1.17.3-1%{?dist}.ngx
  334. - 1.17.3
  335. * Tue Jul 23 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.2-1%{?dist}.ngx
  336. - 1.17.2
  337. * Tue Jun 25 2019 Andrei Belov <defan@nginx.com> - 1.17.1-1%{?dist}.ngx
  338. - 1.17.1
  339. * Tue May 21 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.0-1%{?dist}.ngx
  340. - 1.17.0
  341. * Tue Apr 16 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.12-1%{?dist}.ngx
  342. - 1.15.12
  343. * Tue Apr 9 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.11-1%{?dist}.ngx
  344. - 1.15.11
  345. * Tue Mar 26 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.10-1%{?dist}.ngx
  346. - 1.15.10
  347. * Tue Feb 26 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.9-1%{?dist}.ngx
  348. - 1.15.9
  349. * Tue Dec 25 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.8-1%{?dist}.ngx
  350. - 1.15.8
  351. * Tue Nov 27 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.7-1%{?dist}.ngx
  352. - 1.15.7
  353. * Tue Nov 6 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.6-1%{?dist}.ngx
  354. - 1.15.6
  355. - Security: fixes CVE-2018-16843.
  356. - Security: fixes CVE-2018-16844.
  357. - Security: fixes CVE-2018-16845.
  358. * Tue Oct 2 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.5-1%{?dist}.ngx
  359. - 1.15.5
  360. * Tue Sep 25 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.4-1%{?dist}.ngx
  361. - 1.15.4
  362. * Tue Aug 28 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.3-1%{?dist}.ngx
  363. - 1.15.3
  364. * Tue Jul 24 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.2-1%{?dist}.ngx
  365. - 1.15.2
  366. * Tue Jul 3 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.1-1%{?dist}.ngx
  367. - 1.15.1
  368. * Tue Jun 5 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.0-1%{?dist}.ngx
  369. - 1.15.0
  370. * Mon Apr 9 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.12-1%{?dist}.ngx
  371. - 1.13.12
  372. * Tue Apr 3 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.11-1%{?dist}.ngx
  373. - 1.13.11
  374. * Tue Mar 20 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.10-1%{?dist}.ngx
  375. - 1.13.10
  376. * Tue Feb 20 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.9-1%{?dist}.ngx
  377. - 1.13.9
  378. * Tue Dec 26 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.8-1%{?dist}.ngx
  379. - 1.13.8
  380. * Tue Nov 21 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.7-1%{?dist}.ngx
  381. - 1.13.7
  382. * Thu Sep 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.6-1%{?dist}.ngx
  383. - 1.13.6
  384. - Bugfix: in systemd service support
  385. (https://trac.nginx.org/nginx/ticket/1380).
  386. * Thu Sep 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.5-1%{?dist}.ngx
  387. - 1.13.5
  388. * Tue Aug 8 2017 Sergey Budnevitch <sb@nginx.com> - 1.13.4-1%{?dist}.ngx
  389. - 1.13.4
  390. * Tue Jul 11 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.3-1%{?dist}.ngx
  391. - 1.13.3
  392. - Security: fixes CVE-2017-7529.
  393. * Tue Jun 27 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.2-1%{?dist}.ngx
  394. - 1.13.2
  395. * Tue May 30 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.1-1%{?dist}.ngx
  396. - 1.13.1
  397. * Tue Apr 25 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.0-1%{?dist}.ngx
  398. - 1.13.0
  399. * Tue Apr 4 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.13-1%{?dist}.ngx
  400. - 1.11.13
  401. - Made upgrade loops/timeouts configurable via /etc/defaults/nginx.
  402. * Fri Mar 24 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.12-1%{?dist}.ngx
  403. - 1.11.12
  404. * Tue Mar 21 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.11-1%{?dist}.ngx
  405. - 1.11.11
  406. * Tue Feb 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.10-1%{?dist}.ngx
  407. - 1.11.10
  408. * Tue Jan 24 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.9-1%{?dist}.ngx
  409. - 1.11.9
  410. - Extended hardening build flags.
  411. - Added check-reload target to init script / systemd service.
  412. * Tue Dec 27 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.8-1%{?dist}.ngx
  413. - 1.11.8
  414. * Tue Dec 13 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.7-1%{?dist}.ngx
  415. - 1.11.7
  416. * Fri Nov 25 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.6-1%{?dist}.ngx
  417. - 1.11.6
  418. * Mon Oct 10 2016 Andrei Belov <defan@nginx.com> - 1.11.5-1%{?dist}.ngx
  419. - 1.11.5
  420. * Tue Sep 13 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.4-1%{?dist}.ngx
  421. - 1.11.4
  422. - njs updated to 0.1.2.
  423. * Tue Jul 26 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.3-1%{?dist}.ngx
  424. - 1.11.3
  425. - njs updated to 0.1.0.
  426. - njs stream dynamic module added to nginx-module-njs package.
  427. - geoip stream dynamic module added to nginx-module-geoip package.
  428. * Tue Jul 5 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.2-1%{?dist}.ngx
  429. - 1.11.2
  430. - njs updated to ef2b708510b1.
  431. * Tue May 31 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.1-1%{?dist}.ngx
  432. - 1.11.1
  433. * Tue May 24 2016 Sergey Budnevitch <sb@nginx.com> - 1.11.0-1%{?dist}.ngx
  434. - 1.11.0
  435. - Bugfix: fixed logrotate error if nginx is not running.
  436. * Tue Apr 19 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.15-1%{?dist}.ngx
  437. - 1.9.15
  438. - njs updated to 1c50334fbea6.
  439. * Tue Apr 5 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.14-1%{?dist}.ngx
  440. - 1.9.14
  441. * Tue Mar 29 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.13-1%{?dist}.ngx
  442. - 1.9.13
  443. - Fixed modules path
  444. - Added perl and njs dynamic modules subpackages
  445. * Wed Feb 24 2016 Sergey Budnevitch <sb@nginx.com> - 1.9.12-1%{?dist}.ngx
  446. - 1.9.12
  447. - common configure args are now in variable
  448. - xslt, image-filter and geoip dynamic modules added
  449. * Tue Feb 9 2016 Sergey Budnevitch <sb@nginx.com> - 1.9.11-1%{?dist}.ngx
  450. - 1.9.11
  451. - dynamic modules path and symlink in /etc/nginx added
  452. * Tue Jan 26 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.10-1%{?dist}.ngx
  453. - 1.9.10
  454. * Wed Dec 9 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.9-1%{?dist}.ngx
  455. - 1.9.9
  456. * Tue Dec 8 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.8-1%{?dist}.ngx
  457. - 1.9.8
  458. - http_slice module enabled
  459. * Tue Nov 17 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.7-1%{?dist}.ngx
  460. - 1.9.7
  461. * Tue Oct 27 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.6-1%{?dist}.ngx
  462. - 1.9.6
  463. * Tue Sep 22 2015 Andrei Belov <defan@nginx.com> - 1.9.5-1%{?dist}.ngx
  464. - 1.9.5
  465. - http_spdy module replaced with http_v2 module
  466. * Tue Aug 18 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.4-1%{?dist}.ngx
  467. - 1.9.4
  468. * Tue Jul 14 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.3-1%{?dist}.ngx
  469. - 1.9.3
  470. * Tue Jun 16 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.2-1%{?dist}.ngx
  471. - 1.9.2
  472. * Tue May 26 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.1-1%{?dist}.ngx
  473. - 1.9.1
  474. * Tue Apr 28 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.0-1%{?dist}.ngx
  475. - 1.9.0
  476. - thread pool support added
  477. - stream module added
  478. - example_ssl.conf removed
  479. * Tue Apr 7 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.12-1%{?dist}.ngx
  480. - 1.7.12
  481. * Tue Mar 24 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.11-1%{?dist}.ngx
  482. - 1.7.11
  483. * Tue Feb 10 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.10-1%{?dist}.ngx
  484. - 1.7.10
  485. * Tue Dec 23 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.9-1%{?dist}.ngx
  486. - 1.7.9
  487. - init-script now sends signal only to the PID derived from pidfile
  488. * Tue Dec 2 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.8-1%{?dist}.ngx
  489. - 1.7.8
  490. - package with debug symbols added
  491. * Tue Oct 28 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.7-1%{?dist}.ngx
  492. - 1.7.7
  493. * Tue Sep 30 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.6-1%{?dist}.ngx
  494. - 1.7.6
  495. * Tue Sep 16 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.5-1%{?dist}.ngx
  496. - 1.7.5
  497. * Tue Aug 5 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.4-1%{?dist}.ngx
  498. - 1.7.4
  499. - init-script now returns 0 on stop command if nginx is not running
  500. * Tue Jul 8 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.3-1%{?dist}.ngx
  501. - 1.7.3
  502. * Tue Jun 17 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.2-1%{?dist}.ngx
  503. - 1.7.2
  504. * Tue May 27 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.1-1%{?dist}.ngx
  505. - 1.7.1
  506. * Thu Apr 24 2014 Konstantin Pavlov <thresh@nginx.com> - 1.7.0-1%{?dist}.ngx
  507. - 1.7.0
  508. * Tue Apr 8 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.13-1%{?dist}.ngx
  509. - 1.5.13
  510. * Tue Mar 18 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.12-1%{?dist}.ngx
  511. - 1.5.12
  512. - warning added when binary upgrade returns non-zero exit code
  513. * Tue Mar 4 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.11-1%{?dist}.ngx
  514. - 1.5.11
  515. * Tue Feb 4 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.10-1%{?dist}.ngx
  516. - 1.5.10
  517. * Wed Jan 22 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.9-1%{?dist}.ngx
  518. - 1.5.9
  519. * Tue Dec 17 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.8-1%{?dist}.ngx
  520. - 1.5.8
  521. * Fri Nov 29 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.7-1%{?dist}.ngx
  522. - 1.5.7
  523. - init script now honours additional options sourced from /etc/default/nginx
  524. * Tue Oct 1 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.6-1%{?dist}.ngx
  525. - 1.5.6
  526. * Tue Sep 17 2013 Andrei Belov <defan@nginx.com> - 1.5.5-1%{?dist}.ngx
  527. - 1.5.5
  528. * Tue Aug 27 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.4-1%{?dist}.ngx
  529. - 1.5.4
  530. - auth request module added
  531. * Tue Jul 30 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.3-1%{?dist}.ngx
  532. - 1.5.3
  533. * Tue Jul 2 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.2-1%{?dist}.ngx
  534. - 1.5.2
  535. * Tue Jun 4 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.1-1%{?dist}.ngx
  536. - 1.5.1
  537. - dpkg-buildflags options now passed by --with-{cc,ld}-opt
  538. * Mon May 6 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.0-1%{?dist}.ngx
  539. - 1.5.0
  540. - fixed openssl version detection with dash as /bin/sh
  541. * Tue Apr 16 2013 Sergey Budnevitch <sb@nginx.com> - 1.3.16-1%{?dist}.ngx
  542. - 1.3.16
  543. * Tue Mar 26 2013 Sergey Budnevitch <sb@nginx.com> - 1.3.15-1%{?dist}.ngx
  544. - 1.3.15
  545. - gunzip module added
  546. - spdy module added if openssl version >= 1.0.1
  547. - set permissions on default log files at installation