nginx.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720
  1. #
  2. %define nginx_home %{_localstatedir}/cache/nginx
  3. %define nginx_user nginx
  4. %define nginx_group nginx
  5. %define nginx_loggroup adm
  6. # distribution specific definitions
  7. %define use_systemd (0%{?rhel} >= 7 || 0%{?fedora} >= 19 || 0%{?suse_version} >= 1315 || 0%{?amzn} >= 2)
  8. %if %{use_systemd}
  9. BuildRequires: systemd
  10. Requires(post): systemd
  11. Requires(preun): systemd
  12. Requires(postun): systemd
  13. %endif
  14. %if 0%{?rhel}
  15. %define _group System Environment/Daemons
  16. %endif
  17. %if 0%{?rhel} == 6
  18. Requires(pre): shadow-utils
  19. Requires: initscripts >= 8.36
  20. Requires(post): chkconfig
  21. Requires: openssl >= 1.0.1
  22. BuildRequires: openssl-devel >= 1.0.1
  23. %endif
  24. %if 0%{?rhel} == 7
  25. %define epoch 1
  26. Epoch: %{epoch}
  27. Requires(pre): shadow-utils
  28. Requires: openssl >= 1.0.2
  29. BuildRequires: openssl-devel >= 1.0.2
  30. %define dist .el7
  31. %endif
  32. %if 0%{?rhel} == 8
  33. %define epoch 1
  34. Epoch: %{epoch}
  35. Requires(pre): shadow-utils
  36. BuildRequires: openssl-devel >= 1.1.1
  37. %define _debugsource_template %{nil}
  38. %endif
  39. %if 0%{?suse_version} >= 1315
  40. %define _group Productivity/Networking/Web/Servers
  41. %define nginx_loggroup trusted
  42. Requires(pre): shadow
  43. BuildRequires: libopenssl-devel
  44. %define _debugsource_template %{nil}
  45. %endif
  46. # end of distribution specific definitions
  47. %define main_version 1.17.9
  48. %define main_release 1%{?dist}.ngx
  49. %define bdir %{_builddir}/%{name}-%{main_version}
  50. %define WITH_CC_OPT $(echo %{optflags} $(pcre-config --cflags)) -fPIC
  51. %define WITH_LD_OPT -Wl,-z,relro -Wl,-z,now -pie
  52. %define BASE_CONFIGURE_ARGS $(echo "--prefix=%{_sysconfdir}/nginx --sbin-path=%{_sbindir}/nginx --modules-path=%{_libdir}/nginx/modules --conf-path=%{_sysconfdir}/nginx/nginx.conf --error-log-path=%{_localstatedir}/log/nginx/error.log --http-log-path=%{_localstatedir}/log/nginx/access.log --pid-path=%{_localstatedir}/run/nginx.pid --lock-path=%{_localstatedir}/run/nginx.lock --http-client-body-temp-path=%{_localstatedir}/cache/nginx/client_temp --http-proxy-temp-path=%{_localstatedir}/cache/nginx/proxy_temp --http-fastcgi-temp-path=%{_localstatedir}/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=%{_localstatedir}/cache/nginx/uwsgi_temp --http-scgi-temp-path=%{_localstatedir}/cache/nginx/scgi_temp --user=%{nginx_user} --group=%{nginx_group} --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module")
  53. Summary: High performance web server
  54. Name: nginx
  55. Version: %{main_version}
  56. Release: %{main_release}
  57. Vendor: Nginx, Inc.
  58. URL: http://nginx.org/
  59. Group: %{_group}
  60. Source0: https://nginx.org/download/%{name}-%{version}.tar.gz
  61. Source1: logrotate
  62. Source2: nginx.init.in
  63. Source3: nginx.sysconf
  64. Source4: nginx.conf
  65. Source5: nginx.vh.default.conf
  66. Source7: nginx-debug.sysconf
  67. Source8: nginx.service
  68. Source9: nginx.upgrade.sh
  69. Source10: nginx.suse.logrotate
  70. Source11: nginx-debug.service
  71. Source12: COPYRIGHT
  72. Source13: nginx.check-reload.sh
  73. Source14: https://www.openssl.org/source/openssl-1.1.1f.tar.gz
  74. License: 2-clause BSD-like license
  75. BuildRoot: %{_tmppath}/%{name}-%{main_version}-%{main_release}-root
  76. BuildRequires: zlib-devel
  77. BuildRequires: pcre-devel
  78. Provides: webserver
  79. %description
  80. nginx [engine x] is an HTTP and reverse proxy server, as well as
  81. a mail proxy server.
  82. %if 0%{?suse_version} >= 1315
  83. %debug_package
  84. %endif
  85. %prep
  86. %setup -q
  87. cp %{SOURCE2} .
  88. sed -e 's|%%DEFAULTSTART%%|2 3 4 5|g' -e 's|%%DEFAULTSTOP%%|0 1 6|g' \
  89. -e 's|%%PROVIDES%%|nginx|g' < %{SOURCE2} > nginx.init
  90. sed -e 's|%%DEFAULTSTART%%||g' -e 's|%%DEFAULTSTOP%%|0 1 2 3 4 5 6|g' \
  91. -e 's|%%PROVIDES%%|nginx-debug|g' < %{SOURCE2} > nginx-debug.init
  92. tar -zxf %{SOURCE14}
  93. %build
  94. ./configure %{BASE_CONFIGURE_ARGS} \
  95. --with-openssl=./openssl-1.1.1f/ \
  96. --with-cc-opt="%{WITH_CC_OPT}" \
  97. --with-ld-opt="%{WITH_LD_OPT}" \
  98. --with-debug
  99. make %{?_smp_mflags}
  100. %{__mv} %{bdir}/objs/nginx \
  101. %{bdir}/objs/nginx-debug
  102. ./configure %{BASE_CONFIGURE_ARGS} \
  103. --with-openssl=./openssl-1.1.1f/ \
  104. --with-cc-opt="%{WITH_CC_OPT}" \
  105. --with-ld-opt="%{WITH_LD_OPT}"
  106. make %{?_smp_mflags}
  107. %install
  108. %{__rm} -rf $RPM_BUILD_ROOT
  109. %{__make} DESTDIR=$RPM_BUILD_ROOT INSTALLDIRS=vendor install
  110. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/nginx
  111. %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/html $RPM_BUILD_ROOT%{_datadir}/nginx/
  112. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/*.default
  113. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/fastcgi.conf
  114. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/log/nginx
  115. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/run/nginx
  116. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/cache/nginx
  117. %{__mkdir} -p $RPM_BUILD_ROOT%{_libdir}/nginx/modules
  118. cd $RPM_BUILD_ROOT%{_sysconfdir}/nginx && \
  119. %{__ln_s} ../..%{_libdir}/nginx/modules modules && cd -
  120. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{main_version}
  121. %{__install} -m 644 -p %{SOURCE12} \
  122. $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{main_version}/
  123. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d
  124. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  125. %{__install} -m 644 -p %{SOURCE4} \
  126. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  127. %{__install} -m 644 -p %{SOURCE5} \
  128. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d/default.conf
  129. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  130. %{__install} -m 644 -p %{SOURCE3} \
  131. $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/nginx
  132. %{__install} -m 644 -p %{SOURCE7} \
  133. $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/nginx-debug
  134. %{__install} -p -D -m 0644 %{bdir}/objs/nginx.8 \
  135. $RPM_BUILD_ROOT%{_mandir}/man8/nginx.8
  136. %if %{use_systemd}
  137. # install systemd-specific files
  138. %{__mkdir} -p $RPM_BUILD_ROOT%{_unitdir}
  139. %{__install} -m644 %SOURCE8 \
  140. $RPM_BUILD_ROOT%{_unitdir}/nginx.service
  141. %{__install} -m644 %SOURCE11 \
  142. $RPM_BUILD_ROOT%{_unitdir}/nginx-debug.service
  143. %{__mkdir} -p $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx
  144. %{__install} -m755 %SOURCE9 \
  145. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/upgrade
  146. %{__install} -m755 %SOURCE13 \
  147. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/check-reload
  148. %else
  149. # install SYSV init stuff
  150. %{__mkdir} -p $RPM_BUILD_ROOT%{_initrddir}
  151. %{__install} -m755 nginx.init $RPM_BUILD_ROOT%{_initrddir}/nginx
  152. %{__install} -m755 nginx-debug.init $RPM_BUILD_ROOT%{_initrddir}/nginx-debug
  153. %endif
  154. # install log rotation stuff
  155. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
  156. %if 0%{?suse_version}
  157. %{__install} -m 644 -p %{SOURCE10} \
  158. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  159. %else
  160. %{__install} -m 644 -p %{SOURCE1} \
  161. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  162. %endif
  163. %{__install} -m755 %{bdir}/objs/nginx-debug \
  164. $RPM_BUILD_ROOT%{_sbindir}/nginx-debug
  165. %check
  166. %{__rm} -rf $RPM_BUILD_ROOT/usr/src
  167. cd %{bdir}
  168. grep -v 'usr/src' debugfiles.list > debugfiles.list.new && mv debugfiles.list.new debugfiles.list
  169. cat /dev/null > debugsources.list
  170. %if 0%{?suse_version} >= 1500
  171. cat /dev/null > debugsourcefiles.list
  172. %endif
  173. %clean
  174. %{__rm} -rf $RPM_BUILD_ROOT
  175. %files
  176. %defattr(-,root,root)
  177. %{_sbindir}/nginx
  178. %{_sbindir}/nginx-debug
  179. %dir %{_sysconfdir}/nginx
  180. %dir %{_sysconfdir}/nginx/conf.d
  181. %{_sysconfdir}/nginx/modules
  182. %config(noreplace) %{_sysconfdir}/nginx/nginx.conf
  183. %config(noreplace) %{_sysconfdir}/nginx/conf.d/default.conf
  184. %config(noreplace) %{_sysconfdir}/nginx/mime.types
  185. %config(noreplace) %{_sysconfdir}/nginx/fastcgi_params
  186. %config(noreplace) %{_sysconfdir}/nginx/scgi_params
  187. %config(noreplace) %{_sysconfdir}/nginx/uwsgi_params
  188. %config(noreplace) %{_sysconfdir}/nginx/koi-utf
  189. %config(noreplace) %{_sysconfdir}/nginx/koi-win
  190. %config(noreplace) %{_sysconfdir}/nginx/win-utf
  191. %config(noreplace) %{_sysconfdir}/logrotate.d/nginx
  192. %config(noreplace) %{_sysconfdir}/sysconfig/nginx
  193. %config(noreplace) %{_sysconfdir}/sysconfig/nginx-debug
  194. %if %{use_systemd}
  195. %{_unitdir}/nginx.service
  196. %{_unitdir}/nginx-debug.service
  197. %dir %{_libexecdir}/initscripts/legacy-actions/nginx
  198. %{_libexecdir}/initscripts/legacy-actions/nginx/*
  199. %else
  200. %{_initrddir}/nginx
  201. %{_initrddir}/nginx-debug
  202. %endif
  203. %attr(0755,root,root) %dir %{_libdir}/nginx
  204. %attr(0755,root,root) %dir %{_libdir}/nginx/modules
  205. %dir %{_datadir}/nginx
  206. %dir %{_datadir}/nginx/html
  207. %{_datadir}/nginx/html/*
  208. %attr(0755,root,root) %dir %{_localstatedir}/cache/nginx
  209. %attr(0755,root,root) %dir %{_localstatedir}/log/nginx
  210. %dir %{_datadir}/doc/%{name}-%{main_version}
  211. %doc %{_datadir}/doc/%{name}-%{main_version}/COPYRIGHT
  212. %{_mandir}/man8/nginx.8*
  213. %pre
  214. # Add the "nginx" user
  215. getent group %{nginx_group} >/dev/null || groupadd -r %{nginx_group}
  216. getent passwd %{nginx_user} >/dev/null || \
  217. useradd -r -g %{nginx_group} -s /sbin/nologin \
  218. -d %{nginx_home} -c "nginx user" %{nginx_user}
  219. exit 0
  220. %post
  221. # Register the nginx service
  222. if [ $1 -eq 1 ]; then
  223. %if %{use_systemd}
  224. /usr/bin/systemctl preset nginx.service >/dev/null 2>&1 ||:
  225. /usr/bin/systemctl preset nginx-debug.service >/dev/null 2>&1 ||:
  226. %else
  227. /sbin/chkconfig --add nginx
  228. /sbin/chkconfig --add nginx-debug
  229. %endif
  230. # print site info
  231. cat <<BANNER
  232. ----------------------------------------------------------------------
  233. Thanks for using nginx!
  234. Please find the official documentation for nginx here:
  235. * http://nginx.org/en/docs/
  236. Please subscribe to nginx-announce mailing list to get
  237. the most important news about nginx:
  238. * http://nginx.org/en/support.html
  239. Commercial subscriptions for nginx are available on:
  240. * http://nginx.com/products/
  241. ----------------------------------------------------------------------
  242. BANNER
  243. # Touch and set permisions on default log files on installation
  244. if [ -d %{_localstatedir}/log/nginx ]; then
  245. if [ ! -e %{_localstatedir}/log/nginx/access.log ]; then
  246. touch %{_localstatedir}/log/nginx/access.log
  247. %{__chmod} 640 %{_localstatedir}/log/nginx/access.log
  248. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/access.log
  249. fi
  250. if [ ! -e %{_localstatedir}/log/nginx/error.log ]; then
  251. touch %{_localstatedir}/log/nginx/error.log
  252. %{__chmod} 640 %{_localstatedir}/log/nginx/error.log
  253. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/error.log
  254. fi
  255. fi
  256. fi
  257. %preun
  258. if [ $1 -eq 0 ]; then
  259. %if %use_systemd
  260. /usr/bin/systemctl --no-reload disable nginx.service >/dev/null 2>&1 ||:
  261. /usr/bin/systemctl stop nginx.service >/dev/null 2>&1 ||:
  262. %else
  263. /sbin/service nginx stop > /dev/null 2>&1
  264. /sbin/chkconfig --del nginx
  265. /sbin/chkconfig --del nginx-debug
  266. %endif
  267. fi
  268. %postun
  269. %if %use_systemd
  270. /usr/bin/systemctl daemon-reload >/dev/null 2>&1 ||:
  271. %endif
  272. if [ $1 -ge 1 ]; then
  273. /sbin/service nginx status >/dev/null 2>&1 || exit 0
  274. /sbin/service nginx upgrade >/dev/null 2>&1 || echo \
  275. "Binary upgrade failed, please check nginx's error.log"
  276. fi
  277. %changelog
  278. * Tue Mar 03 2020 Konstantin Pavlov <thresh@nginx.com>
  279. - 1.17.9
  280. * Tue Jan 21 2020 Konstantin Pavlov <thresh@nginx.com>
  281. - 1.17.8
  282. * Tue Dec 24 2019 Konstantin Pavlov <thresh@nginx.com>
  283. - 1.17.7
  284. * Tue Nov 19 2019 Konstantin Pavlov <thresh@nginx.com>
  285. - 1.17.6
  286. * Tue Oct 22 2019 Andrei Belov <defan@nginx.com>
  287. - 1.17.5
  288. * Tue Sep 24 2019 Konstantin Pavlov <thresh@nginx.com>
  289. - 1.17.4
  290. * Tue Aug 13 2019 Andrei Belov <defan@nginx.com>
  291. - 1.17.3
  292. * Tue Jul 23 2019 Konstantin Pavlov <thresh@nginx.com>
  293. - 1.17.2
  294. * Tue Jun 25 2019 Andrei Belov <defan@nginx.com>
  295. - 1.17.1
  296. * Tue May 21 2019 Konstantin Pavlov <thresh@nginx.com>
  297. - 1.17.0
  298. * Tue Apr 16 2019 Konstantin Pavlov <thresh@nginx.com>
  299. - 1.15.12
  300. * Tue Apr 09 2019 Konstantin Pavlov <thresh@nginx.com>
  301. - 1.15.11
  302. * Tue Mar 26 2019 Konstantin Pavlov <thresh@nginx.com>
  303. - 1.15.10
  304. * Tue Feb 26 2019 Konstantin Pavlov <thresh@nginx.com>
  305. - 1.15.9
  306. * Tue Dec 25 2018 Konstantin Pavlov <thresh@nginx.com>
  307. - 1.15.8
  308. * Tue Nov 27 2018 Konstantin Pavlov <thresh@nginx.com>
  309. - 1.15.7
  310. * Tue Nov 06 2018 Konstantin Pavlov <thresh@nginx.com>
  311. - 1.15.6
  312. - Fixes CVE-2018-16843
  313. - Fixes CVE-2018-16844
  314. - Fixes CVE-2018-16845
  315. * Tue Oct 02 2018 Konstantin Pavlov <thresh@nginx.com>
  316. - 1.15.5
  317. * Tue Sep 25 2018 Konstantin Pavlov <thresh@nginx.com>
  318. - 1.15.4
  319. * Tue Aug 28 2018 Konstantin Pavlov <thresh@nginx.com>
  320. - 1.15.3
  321. * Tue Jul 24 2018 Konstantin Pavlov <thresh@nginx.com>
  322. - 1.15.2
  323. * Tue Jul 03 2018 Konstantin Pavlov <thresh@nginx.com>
  324. - 1.15.1
  325. * Tue Jun 05 2018 Konstantin Pavlov <thresh@nginx.com>
  326. - 1.15.0
  327. * Mon Apr 09 2018 Konstantin Pavlov <thresh@nginx.com>
  328. - 1.13.12
  329. * Tue Apr 03 2018 Konstantin Pavlov <thresh@nginx.com>
  330. - 1.13.11
  331. * Tue Mar 20 2018 Konstantin Pavlov <thresh@nginx.com>
  332. - 1.13.10
  333. * Tue Feb 20 2018 Konstantin Pavlov <thresh@nginx.com>
  334. - 1.13.9
  335. * Tue Dec 26 2017 Konstantin Pavlov <thresh@nginx.com>
  336. - 1.13.8
  337. * Tue Nov 21 2017 Konstantin Pavlov <thresh@nginx.com>
  338. - 1.13.7
  339. * Tue Oct 10 2017 Konstantin Pavlov <thresh@nginx.com>
  340. - 1.13.6
  341. * Tue Sep 5 2017 Konstantin Pavlov <thresh@nginx.com>
  342. - 1.13.5
  343. * Tue Aug 8 2017 Sergey Budnevitch <sb@nginx.com>
  344. - 1.13.4
  345. * Tue Jul 11 2017 Konstantin Pavlov <thresh@nginx.com>
  346. - 1.13.3
  347. - Fixes CVE-2017-7529
  348. * Tue Jun 27 2017 Konstantin Pavlov <thresh@nginx.com>
  349. - 1.13.2
  350. * Tue May 30 2017 Konstantin Pavlov <thresh@nginx.com>
  351. - 1.13.1
  352. * Tue Apr 25 2017 Konstantin Pavlov <thresh@nginx.com>
  353. - 1.13.0
  354. * Tue Apr 4 2017 Konstantin Pavlov <thresh@nginx.com>
  355. - 1.11.13
  356. - CentOS7/RHEL7: made upgrade loops/timeouts configurable via
  357. /etc/sysconfig/nginx.
  358. - Bumped upgrade defaults to five loops one second each.
  359. * Fri Mar 24 2017 Konstantin Pavlov <thresh@nginx.com>
  360. - 1.11.12
  361. * Tue Mar 21 2017 Konstantin Pavlov <thresh@nginx.com>
  362. - 1.11.11
  363. * Tue Feb 14 2017 Konstantin Pavlov <thresh@nginx.com>
  364. - 1.11.10
  365. * Tue Jan 24 2017 Konstantin Pavlov <thresh@nginx.com>
  366. - 1.11.9
  367. - Extended hardening build flags.
  368. - Added check-reload target to init script / systemd service.
  369. * Tue Dec 27 2016 Konstantin Pavlov <thresh@nginx.com>
  370. - 1.11.8
  371. * Tue Dec 13 2016 Konstantin Pavlov <thresh@nginx.com>
  372. - 1.11.7
  373. * Tue Nov 15 2016 Konstantin Pavlov <thresh@nginx.com>
  374. - 1.11.6
  375. * Mon Oct 10 2016 Andrei Belov <defan@nginx.com>
  376. - 1.11.5
  377. * Tue Sep 13 2016 Konstantin Pavlov <thresh@nginx.com>
  378. - 1.11.4.
  379. - njs updated to 0.1.2.
  380. * Tue Jul 26 2016 Konstantin Pavlov <thresh@nginx.com>
  381. - 1.11.3.
  382. - njs updated to 0.1.0.
  383. - njs stream dynamic module added to nginx-module-njs package.
  384. - geoip stream dynamic module added to nginx-module-geoip package.
  385. * Tue Jul 5 2016 Konstantin Pavlov <thresh@nginx.com>
  386. - 1.11.2
  387. - njs updated to ef2b708510b1.
  388. * Tue May 31 2016 Konstantin Pavlov <thresh@nginx.com>
  389. - 1.11.1
  390. * Tue May 24 2016 Sergey Budnevitch <sb@nginx.com>
  391. - Fixed logrotate error if nginx is not running
  392. - 1.11.0
  393. * Tue Apr 19 2016 Konstantin Pavlov <thresh@nginx.com>
  394. - 1.9.15
  395. - njs updated to 1c50334fbea6.
  396. * Tue Apr 5 2016 Konstantin Pavlov <thresh@nginx.com>
  397. - 1.9.14
  398. * Tue Mar 29 2016 Konstantin Pavlov <thresh@nginx.com>
  399. - 1.9.13
  400. - Added perl and njs dynamic modules
  401. - Fixed Requires section for dynamic modules on CentOS7/RHEL7
  402. * Wed Feb 24 2016 Sergey Budnevitch <sb@nginx.com>
  403. - common configure args are now in macros
  404. - xslt, image-filter and geoip dynamic modules added
  405. - 1.9.12
  406. * Tue Feb 9 2016 Sergey Budnevitch <sb@nginx.com>
  407. - dynamic modules path and symlink in %{_sysconfdir}/nginx added
  408. - 1.9.11
  409. * Tue Jan 26 2016 Konstantin Pavlov <thresh@nginx.com>
  410. - 1.9.10
  411. * Wed Dec 9 2015 Konstantin Pavlov <thresh@nginx.com>
  412. - 1.9.9
  413. * Tue Dec 8 2015 Konstantin Pavlov <thresh@nginx.com>
  414. - 1.9.8
  415. - http_slice module enabled
  416. * Tue Nov 17 2015 Konstantin Pavlov <thresh@nginx.com>
  417. - 1.9.7
  418. * Tue Oct 27 2015 Sergey Budnevitch <sb@nginx.com>
  419. - 1.9.6
  420. * Tue Sep 22 2015 Andrei Belov <defan@nginx.com>
  421. - 1.9.5
  422. - http_spdy module replaced with http_v2 module
  423. * Tue Aug 18 2015 Konstantin Pavlov <thresh@nginx.com>
  424. - 1.9.4
  425. * Tue Jul 14 2015 Sergey Budnevitch <sb@nginx.com>
  426. - 1.9.3
  427. * Tue May 26 2015 Sergey Budnevitch <sb@nginx.com>
  428. - 1.9.1
  429. * Tue Apr 28 2015 Sergey Budnevitch <sb@nginx.com>
  430. - 1.9.0
  431. - thread pool support added
  432. - stream module added
  433. - example_ssl.conf removed
  434. * Tue Apr 7 2015 Sergey Budnevitch <sb@nginx.com>
  435. - 1.7.12
  436. * Tue Mar 24 2015 Sergey Budnevitch <sb@nginx.com>
  437. - 1.7.11
  438. * Tue Feb 10 2015 Sergey Budnevitch <sb@nginx.com>
  439. - 1.7.10
  440. * Tue Dec 23 2014 Sergey Budnevitch <sb@nginx.com>
  441. - 1.7.9
  442. * Tue Dec 2 2014 Sergey Budnevitch <sb@nginx.com>
  443. - 1.7.8
  444. * Tue Sep 30 2014 Sergey Budnevitch <sb@nginx.com>
  445. - 1.7.6
  446. * Tue Sep 16 2014 Sergey Budnevitch <sb@nginx.com>
  447. - epoch added to the EPEL7/CentOS7 spec to override EPEL one
  448. - 1.7.5
  449. * Tue Aug 5 2014 Sergey Budnevitch <sb@nginx.com>
  450. - 1.7.4
  451. * Tue Jul 8 2014 Sergey Budnevitch <sb@nginx.com>
  452. - 1.7.3
  453. * Tue Jun 17 2014 Sergey Budnevitch <sb@nginx.com>
  454. - 1.7.2
  455. * Tue May 27 2014 Sergey Budnevitch <sb@nginx.com>
  456. - 1.7.1
  457. - incorrect sysconfig filename finding in the initscript fixed
  458. * Thu Apr 24 2014 Konstantin Pavlov <thresh@nginx.com>
  459. - 1.7.0
  460. * Tue Apr 8 2014 Sergey Budnevitch <sb@nginx.com>
  461. - 1.5.13
  462. - built spdy module on rhel/centos 6
  463. * Tue Mar 18 2014 Sergey Budnevitch <sb@nginx.com>
  464. - 1.5.12
  465. - spec cleanup
  466. - openssl version dependence added
  467. - upgrade() function in the init script improved
  468. - warning added when binary upgrade returns non-zero exit code
  469. * Tue Mar 4 2014 Sergey Budnevitch <sb@nginx.com>
  470. - 1.5.11
  471. * Tue Feb 4 2014 Sergey Budnevitch <sb@nginx.com>
  472. - 1.5.10
  473. * Wed Jan 22 2014 Sergey Budnevitch <sb@nginx.com>
  474. - 1.5.9
  475. * Tue Dec 17 2013 Sergey Budnevitch <sb@nginx.com>
  476. - 1.5.8
  477. - fixed invalid week days in the changelog
  478. * Tue Nov 19 2013 Sergey Budnevitch <sb@nginx.com>
  479. - 1.5.7
  480. * Tue Oct 1 2013 Sergey Budnevitch <sb@nginx.com>
  481. - 1.5.6
  482. * Tue Sep 17 2013 Andrei Belov <defan@nginx.com>
  483. - 1.5.5
  484. * Tue Aug 27 2013 Sergey Budnevitch <sb@nginx.com>
  485. - 1.5.4
  486. - auth request module added
  487. * Tue Jul 30 2013 Sergey Budnevitch <sb@nginx.com>
  488. - 1.5.3
  489. * Tue Jul 2 2013 Sergey Budnevitch <sb@nginx.com>
  490. - 1.5.2
  491. * Tue Jun 4 2013 Sergey Budnevitch <sb@nginx.com>
  492. - 1.5.1
  493. * Mon May 6 2013 Sergey Budnevitch <sb@nginx.com>
  494. - 1.5.0
  495. * Tue Apr 16 2013 Sergey Budnevitch <sb@nginx.com>
  496. - 1.3.16
  497. * Tue Mar 26 2013 Sergey Budnevitch <sb@nginx.com>
  498. - 1.3.15
  499. - gunzip module added
  500. - set permissions on default log files at installation
  501. * Tue Feb 12 2013 Sergey Budnevitch <sb@nginx.com>
  502. - excess slash removed from --prefix
  503. - 1.2.7
  504. * Tue Dec 11 2012 Sergey Budnevitch <sb@nginx.com>
  505. - 1.2.6
  506. * Tue Nov 13 2012 Sergey Budnevitch <sb@nginx.com>
  507. - 1.2.5
  508. * Tue Sep 25 2012 Sergey Budnevitch <sb@nginx.com>
  509. - 1.2.4
  510. * Tue Aug 7 2012 Sergey Budnevitch <sb@nginx.com>
  511. - 1.2.3
  512. - nginx-debug package now actually contains non stripped binary
  513. * Tue Jul 3 2012 Sergey Budnevitch <sb@nginx.com>
  514. - 1.2.2
  515. * Tue Jun 5 2012 Sergey Budnevitch <sb@nginx.com>
  516. - 1.2.1
  517. * Mon Apr 23 2012 Sergey Budnevitch <sb@nginx.com>
  518. - 1.2.0
  519. * Thu Apr 12 2012 Sergey Budnevitch <sb@nginx.com>
  520. - 1.0.15
  521. * Thu Mar 15 2012 Sergey Budnevitch <sb@nginx.com>
  522. - 1.0.14
  523. - OpenSUSE init script and SuSE specific changes to spec file added
  524. * Mon Mar 5 2012 Sergey Budnevitch <sb@nginx.com>
  525. - 1.0.13
  526. * Mon Feb 6 2012 Sergey Budnevitch <sb@nginx.com>
  527. - 1.0.12
  528. - banner added to install script
  529. * Thu Dec 15 2011 Sergey Budnevitch <sb@nginx.com>
  530. - 1.0.11
  531. - init script enhancements (thanks to Gena Makhomed)
  532. - one second sleep during upgrade replaced with 0.1 sec usleep
  533. * Tue Nov 15 2011 Sergey Budnevitch <sb@nginx.com>
  534. - 1.0.10
  535. * Tue Nov 1 2011 Sergey Budnevitch <sb@nginx.com>
  536. - 1.0.9
  537. - nginx-debug package added
  538. * Tue Oct 11 2011 Sergey Budnevitch <sb@nginx.com>
  539. - spec file cleanup (thanks to Yury V. Zaytsev)
  540. - log dir permitions fixed
  541. - logrotate creates new logfiles with nginx owner
  542. - "upgrade" argument to init-script added (based on fedora one)
  543. * Sat Oct 1 2011 Sergey Budnevitch <sb@nginx.com>
  544. - 1.0.8
  545. - built with mp4 module
  546. * Fri Sep 30 2011 Sergey Budnevitch <sb@nginx.com>
  547. - 1.0.7
  548. * Tue Aug 30 2011 Sergey Budnevitch <sb@nginx.com>
  549. - 1.0.6
  550. - replace "conf.d/*" config include with "conf.d/*.conf" in default nginx.conf
  551. * Wed Aug 10 2011 Sergey Budnevitch
  552. - Initial release