nginx.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702
  1. #
  2. %define nginx_home %{_localstatedir}/cache/nginx
  3. %define nginx_user nginx
  4. %define nginx_group nginx
  5. %define nginx_loggroup adm
  6. BuildRequires: systemd
  7. Requires(post): systemd
  8. Requires(preun): systemd
  9. Requires(postun): systemd
  10. %if 0%{?rhel}
  11. %define _group System Environment/Daemons
  12. %endif
  13. %if (0%{?rhel} == 7) && (0%{?amzn} == 0)
  14. %define epoch 1
  15. Epoch: %{epoch}
  16. Requires(pre): shadow-utils
  17. Requires: openssl >= 1.0.2
  18. Requires: procps-ng
  19. BuildRequires: openssl-devel >= 1.0.2
  20. %define dist .el7
  21. %endif
  22. %if (0%{?rhel} == 7) && (0%{?amzn} == 2)
  23. %define epoch 1
  24. Epoch: %{epoch}
  25. Requires(pre): shadow-utils
  26. Requires: openssl11 >= 1.1.1
  27. Requires: procps-ng
  28. BuildRequires: openssl11-devel >= 1.1.1
  29. %endif
  30. %if 0%{?rhel} == 8
  31. %define epoch 1
  32. Epoch: %{epoch}
  33. Requires(pre): shadow-utils
  34. Requires: procps-ng
  35. BuildRequires: openssl-devel >= 1.1.1
  36. %define _debugsource_template %{nil}
  37. %endif
  38. %if 0%{?rhel} == 9
  39. %define epoch 1
  40. Epoch: %{epoch}
  41. Requires(pre): shadow-utils
  42. Requires: procps-ng
  43. BuildRequires: openssl-devel
  44. %define _debugsource_template %{nil}
  45. %endif
  46. %if 0%{?suse_version} >= 1315
  47. %define _group Productivity/Networking/Web/Servers
  48. %define nginx_loggroup trusted
  49. Requires(pre): shadow
  50. Requires: procps
  51. BuildRequires: libopenssl-devel
  52. %define _debugsource_template %{nil}
  53. %endif
  54. %if 0%{?fedora}
  55. %define _debugsource_template %{nil}
  56. %global _hardened_build 1
  57. %define _group System Environment/Daemons
  58. Requires: procps-ng
  59. BuildRequires: openssl-devel
  60. Requires(pre): shadow-utils
  61. %endif
  62. # end of distribution specific definitions
  63. %define openssl_version 1.1.1q
  64. %define base_version 1.23.2
  65. %define base_release 1%{?dist}.ngx
  66. %define bdir %{_builddir}/%{name}-%{base_version}
  67. %define WITH_CC_OPT $(echo %{optflags} $(pcre2-config --cflags)) -fPIC
  68. %define WITH_LD_OPT -Wl,-z,relro -Wl,-z,now -pie
  69. %define BASE_CONFIGURE_ARGS $(echo "--prefix=%{_sysconfdir}/nginx --sbin-path=%{_sbindir}/nginx --modules-path=%{_libdir}/nginx/modules --conf-path=%{_sysconfdir}/nginx/nginx.conf --error-log-path=%{_localstatedir}/log/nginx/error.log --http-log-path=%{_localstatedir}/log/nginx/access.log --pid-path=%{_localstatedir}/run/nginx.pid --lock-path=%{_localstatedir}/run/nginx.lock --http-client-body-temp-path=%{_localstatedir}/cache/nginx/client_temp --http-proxy-temp-path=%{_localstatedir}/cache/nginx/proxy_temp --http-fastcgi-temp-path=%{_localstatedir}/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=%{_localstatedir}/cache/nginx/uwsgi_temp --http-scgi-temp-path=%{_localstatedir}/cache/nginx/scgi_temp --user=%{nginx_user} --group=%{nginx_group} --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module")
  70. Summary: High performance web server
  71. Name: nginx
  72. Version: %{base_version}
  73. Release: %{base_release}
  74. Vendor: NGINX Packaging <nginx-packaging@f5.com>
  75. URL: https://nginx.org/
  76. Group: %{_group}
  77. Source0: https://nginx.org/download/%{name}-%{version}.tar.gz
  78. Source1: logrotate
  79. Source2: nginx.conf
  80. Source3: nginx.default.conf
  81. Source4: nginx.service
  82. Source5: nginx.upgrade.sh
  83. Source6: nginx.suse.logrotate
  84. Source7: nginx-debug.service
  85. Source8: nginx.copyright
  86. Source9: nginx.check-reload.sh
  87. Source10: https://www.openssl.org/source/openssl-%{openssl_version}.tar.gz
  88. License: 2-clause BSD-like license
  89. BuildRoot: %{_tmppath}/%{name}-%{base_version}-%{base_release}-root
  90. BuildRequires: zlib-devel
  91. BuildRequires: pcre2-devel
  92. Provides: webserver
  93. Provides: nginx-r%{base_version}
  94. %description
  95. nginx [engine x] is an HTTP and reverse proxy server, as well as
  96. a mail proxy server.
  97. %if 0%{?suse_version} >= 1315
  98. %debug_package
  99. %endif
  100. %prep
  101. %autosetup -p1
  102. tar -zxf %{SOURCE10}
  103. %build
  104. ./configure %{BASE_CONFIGURE_ARGS} \
  105. --with-openssl=./openssl-%{openssl_version}/ \
  106. --with-cc-opt="%{WITH_CC_OPT}" \
  107. --with-ld-opt="%{WITH_LD_OPT}" \
  108. --with-debug
  109. make %{?_smp_mflags}
  110. %{__mv} %{bdir}/objs/nginx \
  111. %{bdir}/objs/nginx-debug
  112. ./configure %{BASE_CONFIGURE_ARGS} \
  113. --with-openssl=./openssl-%{openssl_version}/ \
  114. --with-cc-opt="%{WITH_CC_OPT}" \
  115. --with-ld-opt="%{WITH_LD_OPT}"
  116. make %{?_smp_mflags}
  117. %install
  118. %{__rm} -rf $RPM_BUILD_ROOT
  119. %{__make} DESTDIR=$RPM_BUILD_ROOT INSTALLDIRS=vendor install
  120. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/nginx
  121. %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/html $RPM_BUILD_ROOT%{_datadir}/nginx/
  122. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/*.default
  123. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/fastcgi.conf
  124. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/log/nginx
  125. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/run/nginx
  126. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/cache/nginx
  127. %{__mkdir} -p $RPM_BUILD_ROOT%{_libdir}/nginx/modules
  128. cd $RPM_BUILD_ROOT%{_sysconfdir}/nginx && \
  129. %{__ln_s} ../..%{_libdir}/nginx/modules modules && cd -
  130. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{base_version}
  131. %{__install} -m 644 -p %{SOURCE8} \
  132. $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{base_version}/COPYRIGHT
  133. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d
  134. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  135. %{__install} -m 644 -p %{SOURCE2} \
  136. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  137. %{__install} -m 644 -p %{SOURCE3} \
  138. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d/default.conf
  139. %{__install} -p -D -m 0644 %{bdir}/objs/nginx.8 \
  140. $RPM_BUILD_ROOT%{_mandir}/man8/nginx.8
  141. %{__mkdir} -p $RPM_BUILD_ROOT%{_unitdir}
  142. %{__install} -m644 %SOURCE4 \
  143. $RPM_BUILD_ROOT%{_unitdir}/nginx.service
  144. %{__install} -m644 %SOURCE7 \
  145. $RPM_BUILD_ROOT%{_unitdir}/nginx-debug.service
  146. %{__mkdir} -p $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx
  147. %{__install} -m755 %SOURCE5 \
  148. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/upgrade
  149. %{__install} -m755 %SOURCE9 \
  150. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/check-reload
  151. # install log rotation stuff
  152. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
  153. %if 0%{?suse_version}
  154. %{__install} -m 644 -p %{SOURCE6} \
  155. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  156. %else
  157. %{__install} -m 644 -p %{SOURCE1} \
  158. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  159. %endif
  160. %{__install} -m755 %{bdir}/objs/nginx-debug \
  161. $RPM_BUILD_ROOT%{_sbindir}/nginx-debug
  162. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/koi-utf
  163. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/koi-win
  164. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/win-utf
  165. %check
  166. %{__rm} -rf $RPM_BUILD_ROOT/usr/src
  167. cd %{bdir}
  168. grep -v 'usr/src' debugfiles.list > debugfiles.list.new && mv debugfiles.list.new debugfiles.list
  169. cat /dev/null > debugsources.list
  170. %if 0%{?suse_version} >= 1500
  171. cat /dev/null > debugsourcefiles.list
  172. %endif
  173. %clean
  174. %{__rm} -rf $RPM_BUILD_ROOT
  175. %files
  176. %defattr(-,root,root)
  177. %{_sbindir}/nginx
  178. %{_sbindir}/nginx-debug
  179. %dir %{_sysconfdir}/nginx
  180. %dir %{_sysconfdir}/nginx/conf.d
  181. %{_sysconfdir}/nginx/modules
  182. %config(noreplace) %{_sysconfdir}/nginx/nginx.conf
  183. %config(noreplace) %{_sysconfdir}/nginx/conf.d/default.conf
  184. %config(noreplace) %{_sysconfdir}/nginx/mime.types
  185. %config(noreplace) %{_sysconfdir}/nginx/fastcgi_params
  186. %config(noreplace) %{_sysconfdir}/nginx/scgi_params
  187. %config(noreplace) %{_sysconfdir}/nginx/uwsgi_params
  188. %config(noreplace) %{_sysconfdir}/logrotate.d/nginx
  189. %{_unitdir}/nginx.service
  190. %{_unitdir}/nginx-debug.service
  191. %dir %{_libexecdir}/initscripts/legacy-actions/nginx
  192. %{_libexecdir}/initscripts/legacy-actions/nginx/*
  193. %attr(0755,root,root) %dir %{_libdir}/nginx
  194. %attr(0755,root,root) %dir %{_libdir}/nginx/modules
  195. %dir %{_datadir}/nginx
  196. %dir %{_datadir}/nginx/html
  197. %{_datadir}/nginx/html/*
  198. %attr(0755,root,root) %dir %{_localstatedir}/cache/nginx
  199. %attr(0755,root,root) %dir %{_localstatedir}/log/nginx
  200. %dir %{_datadir}/doc/%{name}-%{base_version}
  201. %doc %{_datadir}/doc/%{name}-%{base_version}/COPYRIGHT
  202. %{_mandir}/man8/nginx.8*
  203. %pre
  204. # Add the "nginx" user
  205. getent group %{nginx_group} >/dev/null || groupadd -r %{nginx_group}
  206. getent passwd %{nginx_user} >/dev/null || \
  207. useradd -r -g %{nginx_group} -s /sbin/nologin \
  208. -d %{nginx_home} -c "nginx user" %{nginx_user}
  209. exit 0
  210. %post
  211. # Register the nginx service
  212. if [ $1 -eq 1 ]; then
  213. /usr/bin/systemctl preset nginx.service >/dev/null 2>&1 ||:
  214. /usr/bin/systemctl preset nginx-debug.service >/dev/null 2>&1 ||:
  215. # print site info
  216. cat <<BANNER
  217. ----------------------------------------------------------------------
  218. Thanks for using nginx!
  219. Please find the official documentation for nginx here:
  220. * https://nginx.org/en/docs/
  221. Please subscribe to nginx-announce mailing list to get
  222. the most important news about nginx:
  223. * https://nginx.org/en/support.html
  224. Commercial subscriptions for nginx are available on:
  225. * https://nginx.com/products/
  226. ----------------------------------------------------------------------
  227. BANNER
  228. # Touch and set permisions on default log files on installation
  229. if [ -d %{_localstatedir}/log/nginx ]; then
  230. if [ ! -e %{_localstatedir}/log/nginx/access.log ]; then
  231. touch %{_localstatedir}/log/nginx/access.log
  232. %{__chmod} 640 %{_localstatedir}/log/nginx/access.log
  233. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/access.log
  234. fi
  235. if [ ! -e %{_localstatedir}/log/nginx/error.log ]; then
  236. touch %{_localstatedir}/log/nginx/error.log
  237. %{__chmod} 640 %{_localstatedir}/log/nginx/error.log
  238. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/error.log
  239. fi
  240. fi
  241. fi
  242. %preun
  243. if [ $1 -eq 0 ]; then
  244. /usr/bin/systemctl --no-reload disable nginx.service >/dev/null 2>&1 ||:
  245. /usr/bin/systemctl stop nginx.service >/dev/null 2>&1 ||:
  246. fi
  247. %postun
  248. /usr/bin/systemctl daemon-reload >/dev/null 2>&1 ||:
  249. if [ $1 -ge 1 ]; then
  250. /sbin/service nginx status >/dev/null 2>&1 || exit 0
  251. /sbin/service nginx upgrade >/dev/null 2>&1 || echo \
  252. "Binary upgrade failed, please check nginx's error.log"
  253. fi
  254. %changelog
  255. * Wed Oct 19 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.2-1%{?dist}.ngx
  256. - 1.23.2-1
  257. * Tue Jul 19 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.1-1%{?dist}.ngx
  258. - 1.23.1-1
  259. * Tue Jun 21 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.0-1%{?dist}.ngx
  260. - 1.23.0-1
  261. * Tue Jan 25 2022 Mikhail Isachenkov <mikhail.isachenkov@nginx.com> - 1.21.6-1%{?dist}.ngx
  262. - 1.21.6-1
  263. * Tue Dec 28 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.5-1%{?dist}.ngx
  264. - 1.21.5-1
  265. - built with PCRE2
  266. * Tue Nov 2 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.4-1%{?dist}.ngx
  267. - 1.21.4-1
  268. * Tue Sep 7 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.3-1%{?dist}.ngx
  269. - 1.21.3-1
  270. * Tue Aug 31 2021 Andrei Belov <defan@nginx.com> - 1.21.2-1%{?dist}.ngx
  271. - 1.21.2-1
  272. * Tue Jul 6 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.1-1%{?dist}.ngx
  273. - 1.21.1-1
  274. * Tue May 25 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.0-1%{?dist}.ngx
  275. - 1.21.0-1
  276. * Tue Apr 13 2021 Andrei Belov <defan@nginx.com> - 1.19.10-1%{?dist}.ngx
  277. - 1.19.10-1
  278. * Tue Mar 30 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.9-1%{?dist}.ngx
  279. - 1.19.9-1
  280. * Tue Mar 9 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.8-1%{?dist}.ngx
  281. - 1.19.8-1
  282. * Tue Feb 16 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.7-1%{?dist}.ngx
  283. - 1.19.7-1
  284. * Tue Dec 15 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.6-1%{?dist}.ngx
  285. - 1.19.6-1
  286. * Tue Nov 24 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.5-1%{?dist}.ngx
  287. - 1.19.5-1
  288. * Tue Oct 27 2020 Andrei Belov <defan@nginx.com> - 1.19.4-1%{?dist}.ngx
  289. - 1.19.4-1
  290. * Tue Sep 29 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.3-1%{?dist}.ngx
  291. - 1.19.3
  292. * Tue Aug 11 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.2-1%{?dist}.ngx
  293. - 1.19.2
  294. * Tue Jul 7 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.1-1%{?dist}.ngx
  295. - 1.19.1
  296. * Tue May 26 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.0-1%{?dist}.ngx
  297. - 1.19.0
  298. * Tue Apr 14 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.10-1%{?dist}.ngx
  299. - 1.17.10
  300. * Tue Mar 3 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.9-1%{?dist}.ngx
  301. - 1.17.9
  302. * Tue Jan 21 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.8-1%{?dist}.ngx
  303. - 1.17.8
  304. * Tue Dec 24 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.7-1%{?dist}.ngx
  305. - 1.17.7
  306. * Tue Nov 19 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.6-1%{?dist}.ngx
  307. - 1.17.6
  308. * Tue Oct 22 2019 Andrei Belov <defan@nginx.com> - 1.17.5-1%{?dist}.ngx
  309. - 1.17.5
  310. * Tue Sep 24 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.4-1%{?dist}.ngx
  311. - 1.17.4
  312. * Tue Aug 13 2019 Andrei Belov <defan@nginx.com> - 1.17.3-1%{?dist}.ngx
  313. - 1.17.3
  314. * Tue Jul 23 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.2-1%{?dist}.ngx
  315. - 1.17.2
  316. * Tue Jun 25 2019 Andrei Belov <defan@nginx.com> - 1.17.1-1%{?dist}.ngx
  317. - 1.17.1
  318. * Tue May 21 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.0-1%{?dist}.ngx
  319. - 1.17.0
  320. * Tue Apr 16 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.12-1%{?dist}.ngx
  321. - 1.15.12
  322. * Tue Apr 9 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.11-1%{?dist}.ngx
  323. - 1.15.11
  324. * Tue Mar 26 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.10-1%{?dist}.ngx
  325. - 1.15.10
  326. * Tue Feb 26 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.9-1%{?dist}.ngx
  327. - 1.15.9
  328. * Tue Dec 25 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.8-1%{?dist}.ngx
  329. - 1.15.8
  330. * Tue Nov 27 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.7-1%{?dist}.ngx
  331. - 1.15.7
  332. * Tue Nov 6 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.6-1%{?dist}.ngx
  333. - 1.15.6
  334. - Security: fixes CVE-2018-16843.
  335. - Security: fixes CVE-2018-16844.
  336. - Security: fixes CVE-2018-16845.
  337. * Tue Oct 2 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.5-1%{?dist}.ngx
  338. - 1.15.5
  339. * Tue Sep 25 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.4-1%{?dist}.ngx
  340. - 1.15.4
  341. * Tue Aug 28 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.3-1%{?dist}.ngx
  342. - 1.15.3
  343. * Tue Jul 24 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.2-1%{?dist}.ngx
  344. - 1.15.2
  345. * Tue Jul 3 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.1-1%{?dist}.ngx
  346. - 1.15.1
  347. * Tue Jun 5 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.0-1%{?dist}.ngx
  348. - 1.15.0
  349. * Mon Apr 9 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.12-1%{?dist}.ngx
  350. - 1.13.12
  351. * Tue Apr 3 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.11-1%{?dist}.ngx
  352. - 1.13.11
  353. * Tue Mar 20 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.10-1%{?dist}.ngx
  354. - 1.13.10
  355. * Tue Feb 20 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.9-1%{?dist}.ngx
  356. - 1.13.9
  357. * Tue Dec 26 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.8-1%{?dist}.ngx
  358. - 1.13.8
  359. * Tue Nov 21 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.7-1%{?dist}.ngx
  360. - 1.13.7
  361. * Thu Sep 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.6-1%{?dist}.ngx
  362. - 1.13.6
  363. - Bugfix: in systemd service support
  364. (https://trac.nginx.org/nginx/ticket/1380).
  365. * Thu Sep 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.5-1%{?dist}.ngx
  366. - 1.13.5
  367. * Tue Aug 8 2017 Sergey Budnevitch <sb@nginx.com> - 1.13.4-1%{?dist}.ngx
  368. - 1.13.4
  369. * Tue Jul 11 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.3-1%{?dist}.ngx
  370. - 1.13.3
  371. - Security: fixes CVE-2017-7529.
  372. * Tue Jun 27 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.2-1%{?dist}.ngx
  373. - 1.13.2
  374. * Tue May 30 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.1-1%{?dist}.ngx
  375. - 1.13.1
  376. * Tue Apr 25 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.0-1%{?dist}.ngx
  377. - 1.13.0
  378. * Tue Apr 4 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.13-1%{?dist}.ngx
  379. - 1.11.13
  380. - Made upgrade loops/timeouts configurable via /etc/defaults/nginx.
  381. * Fri Mar 24 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.12-1%{?dist}.ngx
  382. - 1.11.12
  383. * Tue Mar 21 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.11-1%{?dist}.ngx
  384. - 1.11.11
  385. * Tue Feb 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.10-1%{?dist}.ngx
  386. - 1.11.10
  387. * Tue Jan 24 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.9-1%{?dist}.ngx
  388. - 1.11.9
  389. - Extended hardening build flags.
  390. - Added check-reload target to init script / systemd service.
  391. * Tue Dec 27 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.8-1%{?dist}.ngx
  392. - 1.11.8
  393. * Tue Dec 13 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.7-1%{?dist}.ngx
  394. - 1.11.7
  395. * Fri Nov 25 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.6-1%{?dist}.ngx
  396. - 1.11.6
  397. * Mon Oct 10 2016 Andrei Belov <defan@nginx.com> - 1.11.5-1%{?dist}.ngx
  398. - 1.11.5
  399. * Tue Sep 13 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.4-1%{?dist}.ngx
  400. - 1.11.4
  401. - njs updated to 0.1.2.
  402. * Tue Jul 26 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.3-1%{?dist}.ngx
  403. - 1.11.3
  404. - njs updated to 0.1.0.
  405. - njs stream dynamic module added to nginx-module-njs package.
  406. - geoip stream dynamic module added to nginx-module-geoip package.
  407. * Tue Jul 5 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.2-1%{?dist}.ngx
  408. - 1.11.2
  409. - njs updated to ef2b708510b1.
  410. * Tue May 31 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.1-1%{?dist}.ngx
  411. - 1.11.1
  412. * Tue May 24 2016 Sergey Budnevitch <sb@nginx.com> - 1.11.0-1%{?dist}.ngx
  413. - 1.11.0
  414. - Bugfix: fixed logrotate error if nginx is not running.
  415. * Tue Apr 19 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.15-1%{?dist}.ngx
  416. - 1.9.15
  417. - njs updated to 1c50334fbea6.
  418. * Tue Apr 5 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.14-1%{?dist}.ngx
  419. - 1.9.14
  420. * Tue Mar 29 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.13-1%{?dist}.ngx
  421. - 1.9.13
  422. - Fixed modules path
  423. - Added perl and njs dynamic modules subpackages
  424. * Wed Feb 24 2016 Sergey Budnevitch <sb@nginx.com> - 1.9.12-1%{?dist}.ngx
  425. - 1.9.12
  426. - common configure args are now in variable
  427. - xslt, image-filter and geoip dynamic modules added
  428. * Tue Feb 9 2016 Sergey Budnevitch <sb@nginx.com> - 1.9.11-1%{?dist}.ngx
  429. - 1.9.11
  430. - dynamic modules path and symlink in /etc/nginx added
  431. * Tue Jan 26 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.10-1%{?dist}.ngx
  432. - 1.9.10
  433. * Wed Dec 9 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.9-1%{?dist}.ngx
  434. - 1.9.9
  435. * Tue Dec 8 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.8-1%{?dist}.ngx
  436. - 1.9.8
  437. - http_slice module enabled
  438. * Tue Nov 17 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.7-1%{?dist}.ngx
  439. - 1.9.7
  440. * Tue Oct 27 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.6-1%{?dist}.ngx
  441. - 1.9.6
  442. * Tue Sep 22 2015 Andrei Belov <defan@nginx.com> - 1.9.5-1%{?dist}.ngx
  443. - 1.9.5
  444. - http_spdy module replaced with http_v2 module
  445. * Tue Aug 18 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.4-1%{?dist}.ngx
  446. - 1.9.4
  447. * Tue Jul 14 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.3-1%{?dist}.ngx
  448. - 1.9.3
  449. * Tue Jun 16 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.2-1%{?dist}.ngx
  450. - 1.9.2
  451. * Tue May 26 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.1-1%{?dist}.ngx
  452. - 1.9.1
  453. * Tue Apr 28 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.0-1%{?dist}.ngx
  454. - 1.9.0
  455. - thread pool support added
  456. - stream module added
  457. - example_ssl.conf removed
  458. * Tue Apr 7 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.12-1%{?dist}.ngx
  459. - 1.7.12
  460. * Tue Mar 24 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.11-1%{?dist}.ngx
  461. - 1.7.11
  462. * Tue Feb 10 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.10-1%{?dist}.ngx
  463. - 1.7.10
  464. * Tue Dec 23 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.9-1%{?dist}.ngx
  465. - 1.7.9
  466. - init-script now sends signal only to the PID derived from pidfile
  467. * Tue Dec 2 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.8-1%{?dist}.ngx
  468. - 1.7.8
  469. - package with debug symbols added
  470. * Tue Oct 28 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.7-1%{?dist}.ngx
  471. - 1.7.7
  472. * Tue Sep 30 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.6-1%{?dist}.ngx
  473. - 1.7.6
  474. * Tue Sep 16 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.5-1%{?dist}.ngx
  475. - 1.7.5
  476. * Tue Aug 5 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.4-1%{?dist}.ngx
  477. - 1.7.4
  478. - init-script now returns 0 on stop command if nginx is not running
  479. * Tue Jul 8 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.3-1%{?dist}.ngx
  480. - 1.7.3
  481. * Tue Jun 17 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.2-1%{?dist}.ngx
  482. - 1.7.2
  483. * Tue May 27 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.1-1%{?dist}.ngx
  484. - 1.7.1
  485. * Thu Apr 24 2014 Konstantin Pavlov <thresh@nginx.com> - 1.7.0-1%{?dist}.ngx
  486. - 1.7.0
  487. * Tue Apr 8 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.13-1%{?dist}.ngx
  488. - 1.5.13
  489. * Tue Mar 18 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.12-1%{?dist}.ngx
  490. - 1.5.12
  491. - warning added when binary upgrade returns non-zero exit code
  492. * Tue Mar 4 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.11-1%{?dist}.ngx
  493. - 1.5.11
  494. * Tue Feb 4 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.10-1%{?dist}.ngx
  495. - 1.5.10
  496. * Wed Jan 22 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.9-1%{?dist}.ngx
  497. - 1.5.9
  498. * Tue Dec 17 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.8-1%{?dist}.ngx
  499. - 1.5.8
  500. * Fri Nov 29 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.7-1%{?dist}.ngx
  501. - 1.5.7
  502. - init script now honours additional options sourced from /etc/default/nginx
  503. * Tue Oct 1 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.6-1%{?dist}.ngx
  504. - 1.5.6
  505. * Tue Sep 17 2013 Andrei Belov <defan@nginx.com> - 1.5.5-1%{?dist}.ngx
  506. - 1.5.5
  507. * Tue Aug 27 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.4-1%{?dist}.ngx
  508. - 1.5.4
  509. - auth request module added
  510. * Tue Jul 30 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.3-1%{?dist}.ngx
  511. - 1.5.3
  512. * Tue Jul 2 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.2-1%{?dist}.ngx
  513. - 1.5.2
  514. * Tue Jun 4 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.1-1%{?dist}.ngx
  515. - 1.5.1
  516. - dpkg-buildflags options now passed by --with-{cc,ld}-opt
  517. * Mon May 6 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.0-1%{?dist}.ngx
  518. - 1.5.0
  519. - fixed openssl version detection with dash as /bin/sh
  520. * Tue Apr 16 2013 Sergey Budnevitch <sb@nginx.com> - 1.3.16-1%{?dist}.ngx
  521. - 1.3.16
  522. * Tue Mar 26 2013 Sergey Budnevitch <sb@nginx.com> - 1.3.15-1%{?dist}.ngx
  523. - 1.3.15
  524. - gunzip module added
  525. - spdy module added if openssl version >= 1.0.1
  526. - set permissions on default log files at installation