nginx.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717
  1. #
  2. %define nginx_home %{_localstatedir}/cache/nginx
  3. %define nginx_user nginx
  4. %define nginx_group nginx
  5. %define nginx_loggroup adm
  6. BuildRequires: systemd
  7. Requires(post): systemd
  8. Requires(preun): systemd
  9. Requires(postun): systemd
  10. %if 0%{?rhel}
  11. %define _group System Environment/Daemons
  12. %endif
  13. %if (0%{?rhel} == 7) && (0%{?amzn} == 0)
  14. %define epoch 1
  15. Epoch: %{epoch}
  16. Requires(pre): shadow-utils
  17. Requires: openssl >= 1.0.2
  18. Requires: procps-ng
  19. BuildRequires: openssl-devel >= 1.0.2
  20. BuildRequires: perl-IPC-Cmd
  21. %define dist .el7
  22. %endif
  23. %if (0%{?rhel} == 7) && (0%{?amzn} == 2)
  24. %define epoch 1
  25. Epoch: %{epoch}
  26. Requires(pre): shadow-utils
  27. Requires: openssl11 >= 1.1.1
  28. Requires: procps-ng
  29. BuildRequires: openssl11-devel >= 1.1.1
  30. %endif
  31. %if 0%{?rhel} == 8
  32. %define epoch 1
  33. Epoch: %{epoch}
  34. Requires(pre): shadow-utils
  35. Requires: procps-ng
  36. BuildRequires: openssl-devel >= 1.1.1
  37. %define _debugsource_template %{nil}
  38. %endif
  39. %if 0%{?rhel} == 9
  40. %define epoch 1
  41. Epoch: %{epoch}
  42. Requires(pre): shadow-utils
  43. Requires: procps-ng
  44. BuildRequires: openssl-devel
  45. BuildRequires: gcc
  46. %define _debugsource_template %{nil}
  47. %endif
  48. %if 0%{?suse_version} >= 1315
  49. %define _group Productivity/Networking/Web/Servers
  50. %define nginx_loggroup trusted
  51. Requires(pre): shadow
  52. Requires: procps
  53. BuildRequires: libopenssl-devel
  54. %define _debugsource_template %{nil}
  55. %endif
  56. %if 0%{?fedora}
  57. %define _debugsource_template %{nil}
  58. %global _hardened_build 1
  59. %define _group System Environment/Daemons
  60. Requires: procps-ng
  61. BuildRequires: openssl-devel
  62. Requires(pre): shadow-utils
  63. %endif
  64. # end of distribution specific definitions
  65. %define openssl_version 3.0.9-quic1
  66. %define base_version 1.25.1
  67. %define base_release 1%{?dist}.ngx
  68. %define bdir %{_builddir}/%{name}-%{base_version}
  69. %define WITH_CC_OPT $(echo %{optflags} $(pcre2-config --cflags)) -fPIC
  70. %define WITH_LD_OPT -Wl,-z,relro -Wl,-z,now -pie
  71. %define BASE_CONFIGURE_ARGS $(echo "--prefix=%{_sysconfdir}/nginx --sbin-path=%{_sbindir}/nginx --modules-path=%{_libdir}/nginx/modules --conf-path=%{_sysconfdir}/nginx/nginx.conf --error-log-path=%{_localstatedir}/log/nginx/error.log --http-log-path=%{_localstatedir}/log/nginx/access.log --pid-path=%{_localstatedir}/run/nginx.pid --lock-path=%{_localstatedir}/run/nginx.lock --http-client-body-temp-path=%{_localstatedir}/cache/nginx/client_temp --http-proxy-temp-path=%{_localstatedir}/cache/nginx/proxy_temp --http-fastcgi-temp-path=%{_localstatedir}/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=%{_localstatedir}/cache/nginx/uwsgi_temp --http-scgi-temp-path=%{_localstatedir}/cache/nginx/scgi_temp --user=%{nginx_user} --group=%{nginx_group} --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module $( if [ 0%{?rhel} -eq 7 ] || [ 0%{?suse_version} -eq 1315 ]; then continue; else echo "--with-http_v3_module"; fi; ) --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module")
  72. Summary: High performance web server
  73. Name: nginx
  74. Version: %{base_version}
  75. Release: %{base_release}
  76. Vendor: NGINX Packaging <nginx-packaging@f5.com>
  77. URL: https://nginx.org/
  78. Group: %{_group}
  79. Source0: https://nginx.org/download/%{name}-%{version}.tar.gz
  80. Source1: logrotate
  81. Source2: nginx.conf
  82. Source3: nginx.default.conf
  83. Source4: nginx.service
  84. Source5: nginx.upgrade.sh
  85. Source6: nginx.suse.logrotate
  86. Source7: nginx-debug.service
  87. Source8: nginx.copyright
  88. Source9: nginx.check-reload.sh
  89. Source10: https://github.com/quictls/openssl/archive/refs/tags/openssl-%{openssl_version}.tar.gz
  90. License: 2-clause BSD-like license
  91. BuildRoot: %{_tmppath}/%{name}-%{base_version}-%{base_release}-root
  92. BuildRequires: zlib-devel
  93. BuildRequires: pcre2-devel
  94. BuildRequires: perl
  95. Provides: webserver
  96. Provides: nginx-r%{base_version}
  97. %description
  98. nginx [engine x] is an HTTP and reverse proxy server, as well as
  99. a mail proxy server.
  100. %if 0%{?suse_version} >= 1315
  101. %debug_package
  102. %endif
  103. %prep
  104. %autosetup -p1
  105. tar -zxf %{SOURCE10}
  106. %build
  107. ./configure %{BASE_CONFIGURE_ARGS} \
  108. --with-openssl=./openssl-openssl-%{openssl_version}/ \
  109. --with-cc-opt="%{WITH_CC_OPT}" \
  110. --with-ld-opt="%{WITH_LD_OPT}" \
  111. --with-debug
  112. make %{?_smp_mflags}
  113. %{__mv} %{bdir}/objs/nginx \
  114. %{bdir}/objs/nginx-debug
  115. ./configure %{BASE_CONFIGURE_ARGS} \
  116. --with-openssl=./openssl-openssl-%{openssl_version}/ \
  117. --with-cc-opt="%{WITH_CC_OPT}" \
  118. --with-ld-opt="%{WITH_LD_OPT}"
  119. make %{?_smp_mflags}
  120. %install
  121. %{__rm} -rf $RPM_BUILD_ROOT
  122. %{__make} DESTDIR=$RPM_BUILD_ROOT INSTALLDIRS=vendor install
  123. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/nginx
  124. %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/html $RPM_BUILD_ROOT%{_datadir}/nginx/
  125. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/*.default
  126. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/fastcgi.conf
  127. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/log/nginx
  128. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/run/nginx
  129. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/cache/nginx
  130. %{__mkdir} -p $RPM_BUILD_ROOT%{_libdir}/nginx/modules
  131. cd $RPM_BUILD_ROOT%{_sysconfdir}/nginx && \
  132. %{__ln_s} ../..%{_libdir}/nginx/modules modules && cd -
  133. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{base_version}
  134. %{__install} -m 644 -p %{SOURCE8} \
  135. $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{base_version}/COPYRIGHT
  136. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d
  137. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  138. %{__install} -m 644 -p %{SOURCE2} \
  139. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  140. %{__install} -m 644 -p %{SOURCE3} \
  141. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d/default.conf
  142. %{__install} -p -D -m 0644 %{bdir}/objs/nginx.8 \
  143. $RPM_BUILD_ROOT%{_mandir}/man8/nginx.8
  144. %{__mkdir} -p $RPM_BUILD_ROOT%{_unitdir}
  145. %{__install} -m644 %SOURCE4 \
  146. $RPM_BUILD_ROOT%{_unitdir}/nginx.service
  147. %{__install} -m644 %SOURCE7 \
  148. $RPM_BUILD_ROOT%{_unitdir}/nginx-debug.service
  149. %{__mkdir} -p $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx
  150. %{__install} -m755 %SOURCE5 \
  151. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/upgrade
  152. %{__install} -m755 %SOURCE9 \
  153. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/check-reload
  154. # install log rotation stuff
  155. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
  156. %if 0%{?suse_version}
  157. %{__install} -m 644 -p %{SOURCE6} \
  158. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  159. %else
  160. %{__install} -m 644 -p %{SOURCE1} \
  161. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  162. %endif
  163. %{__install} -m755 %{bdir}/objs/nginx-debug \
  164. $RPM_BUILD_ROOT%{_sbindir}/nginx-debug
  165. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/koi-utf
  166. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/koi-win
  167. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/win-utf
  168. %check
  169. %{__rm} -rf $RPM_BUILD_ROOT/usr/src
  170. cd %{bdir}
  171. grep -v 'usr/src' debugfiles.list > debugfiles.list.new && mv debugfiles.list.new debugfiles.list
  172. cat /dev/null > debugsources.list
  173. %if 0%{?suse_version} >= 1500
  174. cat /dev/null > debugsourcefiles.list
  175. %endif
  176. %clean
  177. %{__rm} -rf $RPM_BUILD_ROOT
  178. %files
  179. %defattr(-,root,root)
  180. %{_sbindir}/nginx
  181. %{_sbindir}/nginx-debug
  182. %dir %{_sysconfdir}/nginx
  183. %dir %{_sysconfdir}/nginx/conf.d
  184. %{_sysconfdir}/nginx/modules
  185. %config(noreplace) %{_sysconfdir}/nginx/nginx.conf
  186. %config(noreplace) %{_sysconfdir}/nginx/conf.d/default.conf
  187. %config(noreplace) %{_sysconfdir}/nginx/mime.types
  188. %config(noreplace) %{_sysconfdir}/nginx/fastcgi_params
  189. %config(noreplace) %{_sysconfdir}/nginx/scgi_params
  190. %config(noreplace) %{_sysconfdir}/nginx/uwsgi_params
  191. %config(noreplace) %{_sysconfdir}/logrotate.d/nginx
  192. %{_unitdir}/nginx.service
  193. %{_unitdir}/nginx-debug.service
  194. %dir %{_libexecdir}/initscripts/legacy-actions/nginx
  195. %{_libexecdir}/initscripts/legacy-actions/nginx/*
  196. %attr(0755,root,root) %dir %{_libdir}/nginx
  197. %attr(0755,root,root) %dir %{_libdir}/nginx/modules
  198. %dir %{_datadir}/nginx
  199. %dir %{_datadir}/nginx/html
  200. %{_datadir}/nginx/html/*
  201. %attr(0755,root,root) %dir %{_localstatedir}/cache/nginx
  202. %attr(0755,root,root) %dir %{_localstatedir}/log/nginx
  203. %dir %{_datadir}/doc/%{name}-%{base_version}
  204. %doc %{_datadir}/doc/%{name}-%{base_version}/COPYRIGHT
  205. %{_mandir}/man8/nginx.8*
  206. %pre
  207. # Add the "nginx" user
  208. getent group %{nginx_group} >/dev/null || groupadd -r %{nginx_group}
  209. getent passwd %{nginx_user} >/dev/null || \
  210. useradd -r -g %{nginx_group} -s /sbin/nologin \
  211. -d %{nginx_home} -c "nginx user" %{nginx_user}
  212. exit 0
  213. %post
  214. # Register the nginx service
  215. if [ $1 -eq 1 ]; then
  216. /usr/bin/systemctl preset nginx.service >/dev/null 2>&1 ||:
  217. /usr/bin/systemctl preset nginx-debug.service >/dev/null 2>&1 ||:
  218. # print site info
  219. cat <<BANNER
  220. ----------------------------------------------------------------------
  221. Thanks for using nginx!
  222. Please find the official documentation for nginx here:
  223. * https://nginx.org/en/docs/
  224. Please subscribe to nginx-announce mailing list to get
  225. the most important news about nginx:
  226. * https://nginx.org/en/support.html
  227. Commercial subscriptions for nginx are available on:
  228. * https://nginx.com/products/
  229. ----------------------------------------------------------------------
  230. BANNER
  231. # Touch and set permisions on default log files on installation
  232. if [ -d %{_localstatedir}/log/nginx ]; then
  233. if [ ! -e %{_localstatedir}/log/nginx/access.log ]; then
  234. touch %{_localstatedir}/log/nginx/access.log
  235. %{__chmod} 640 %{_localstatedir}/log/nginx/access.log
  236. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/access.log
  237. fi
  238. if [ ! -e %{_localstatedir}/log/nginx/error.log ]; then
  239. touch %{_localstatedir}/log/nginx/error.log
  240. %{__chmod} 640 %{_localstatedir}/log/nginx/error.log
  241. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/error.log
  242. fi
  243. fi
  244. fi
  245. %preun
  246. if [ $1 -eq 0 ]; then
  247. /usr/bin/systemctl --no-reload disable nginx.service >/dev/null 2>&1 ||:
  248. /usr/bin/systemctl stop nginx.service >/dev/null 2>&1 ||:
  249. fi
  250. %postun
  251. /usr/bin/systemctl daemon-reload >/dev/null 2>&1 ||:
  252. if [ $1 -ge 1 ]; then
  253. /sbin/service nginx status >/dev/null 2>&1 || exit 0
  254. /sbin/service nginx upgrade >/dev/null 2>&1 || echo \
  255. "Binary upgrade failed, please check nginx's error.log"
  256. fi
  257. %changelog
  258. * Tue Jun 13 2023 Nginx Packaging <nginx-packaging@f5.com> - 1.25.1-1%{?dist}.ngx
  259. - 1.25.1-1
  260. * Tue May 23 2023 Nginx Packaging <nginx-packaging@f5.com> - 1.25.0-1%{?dist}.ngx
  261. - 1.25.0-1
  262. * Tue Mar 28 2023 Nginx Packaging <nginx-packaging@f5.com> - 1.23.4-1%{?dist}.ngx
  263. - 1.23.4-1
  264. * Tue Dec 13 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.3-1%{?dist}.ngx
  265. - 1.23.3-1
  266. * Wed Oct 19 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.2-1%{?dist}.ngx
  267. - 1.23.2-1
  268. * Tue Jul 19 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.1-1%{?dist}.ngx
  269. - 1.23.1-1
  270. * Tue Jun 21 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.0-1%{?dist}.ngx
  271. - 1.23.0-1
  272. * Tue Jan 25 2022 Mikhail Isachenkov <mikhail.isachenkov@nginx.com> - 1.21.6-1%{?dist}.ngx
  273. - 1.21.6-1
  274. * Tue Dec 28 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.5-1%{?dist}.ngx
  275. - 1.21.5-1
  276. - built with PCRE2
  277. * Tue Nov 2 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.4-1%{?dist}.ngx
  278. - 1.21.4-1
  279. * Tue Sep 7 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.3-1%{?dist}.ngx
  280. - 1.21.3-1
  281. * Tue Aug 31 2021 Andrei Belov <defan@nginx.com> - 1.21.2-1%{?dist}.ngx
  282. - 1.21.2-1
  283. * Tue Jul 6 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.1-1%{?dist}.ngx
  284. - 1.21.1-1
  285. * Tue May 25 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.0-1%{?dist}.ngx
  286. - 1.21.0-1
  287. * Tue Apr 13 2021 Andrei Belov <defan@nginx.com> - 1.19.10-1%{?dist}.ngx
  288. - 1.19.10-1
  289. * Tue Mar 30 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.9-1%{?dist}.ngx
  290. - 1.19.9-1
  291. * Tue Mar 9 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.8-1%{?dist}.ngx
  292. - 1.19.8-1
  293. * Tue Feb 16 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.7-1%{?dist}.ngx
  294. - 1.19.7-1
  295. * Tue Dec 15 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.6-1%{?dist}.ngx
  296. - 1.19.6-1
  297. * Tue Nov 24 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.5-1%{?dist}.ngx
  298. - 1.19.5-1
  299. * Tue Oct 27 2020 Andrei Belov <defan@nginx.com> - 1.19.4-1%{?dist}.ngx
  300. - 1.19.4-1
  301. * Tue Sep 29 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.3-1%{?dist}.ngx
  302. - 1.19.3
  303. * Tue Aug 11 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.2-1%{?dist}.ngx
  304. - 1.19.2
  305. * Tue Jul 7 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.1-1%{?dist}.ngx
  306. - 1.19.1
  307. * Tue May 26 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.0-1%{?dist}.ngx
  308. - 1.19.0
  309. * Tue Apr 14 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.10-1%{?dist}.ngx
  310. - 1.17.10
  311. * Tue Mar 3 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.9-1%{?dist}.ngx
  312. - 1.17.9
  313. * Tue Jan 21 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.8-1%{?dist}.ngx
  314. - 1.17.8
  315. * Tue Dec 24 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.7-1%{?dist}.ngx
  316. - 1.17.7
  317. * Tue Nov 19 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.6-1%{?dist}.ngx
  318. - 1.17.6
  319. * Tue Oct 22 2019 Andrei Belov <defan@nginx.com> - 1.17.5-1%{?dist}.ngx
  320. - 1.17.5
  321. * Tue Sep 24 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.4-1%{?dist}.ngx
  322. - 1.17.4
  323. * Tue Aug 13 2019 Andrei Belov <defan@nginx.com> - 1.17.3-1%{?dist}.ngx
  324. - 1.17.3
  325. * Tue Jul 23 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.2-1%{?dist}.ngx
  326. - 1.17.2
  327. * Tue Jun 25 2019 Andrei Belov <defan@nginx.com> - 1.17.1-1%{?dist}.ngx
  328. - 1.17.1
  329. * Tue May 21 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.0-1%{?dist}.ngx
  330. - 1.17.0
  331. * Tue Apr 16 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.12-1%{?dist}.ngx
  332. - 1.15.12
  333. * Tue Apr 9 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.11-1%{?dist}.ngx
  334. - 1.15.11
  335. * Tue Mar 26 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.10-1%{?dist}.ngx
  336. - 1.15.10
  337. * Tue Feb 26 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.9-1%{?dist}.ngx
  338. - 1.15.9
  339. * Tue Dec 25 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.8-1%{?dist}.ngx
  340. - 1.15.8
  341. * Tue Nov 27 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.7-1%{?dist}.ngx
  342. - 1.15.7
  343. * Tue Nov 6 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.6-1%{?dist}.ngx
  344. - 1.15.6
  345. - Security: fixes CVE-2018-16843.
  346. - Security: fixes CVE-2018-16844.
  347. - Security: fixes CVE-2018-16845.
  348. * Tue Oct 2 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.5-1%{?dist}.ngx
  349. - 1.15.5
  350. * Tue Sep 25 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.4-1%{?dist}.ngx
  351. - 1.15.4
  352. * Tue Aug 28 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.3-1%{?dist}.ngx
  353. - 1.15.3
  354. * Tue Jul 24 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.2-1%{?dist}.ngx
  355. - 1.15.2
  356. * Tue Jul 3 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.1-1%{?dist}.ngx
  357. - 1.15.1
  358. * Tue Jun 5 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.0-1%{?dist}.ngx
  359. - 1.15.0
  360. * Mon Apr 9 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.12-1%{?dist}.ngx
  361. - 1.13.12
  362. * Tue Apr 3 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.11-1%{?dist}.ngx
  363. - 1.13.11
  364. * Tue Mar 20 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.10-1%{?dist}.ngx
  365. - 1.13.10
  366. * Tue Feb 20 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.9-1%{?dist}.ngx
  367. - 1.13.9
  368. * Tue Dec 26 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.8-1%{?dist}.ngx
  369. - 1.13.8
  370. * Tue Nov 21 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.7-1%{?dist}.ngx
  371. - 1.13.7
  372. * Thu Sep 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.6-1%{?dist}.ngx
  373. - 1.13.6
  374. - Bugfix: in systemd service support
  375. (https://trac.nginx.org/nginx/ticket/1380).
  376. * Thu Sep 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.5-1%{?dist}.ngx
  377. - 1.13.5
  378. * Tue Aug 8 2017 Sergey Budnevitch <sb@nginx.com> - 1.13.4-1%{?dist}.ngx
  379. - 1.13.4
  380. * Tue Jul 11 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.3-1%{?dist}.ngx
  381. - 1.13.3
  382. - Security: fixes CVE-2017-7529.
  383. * Tue Jun 27 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.2-1%{?dist}.ngx
  384. - 1.13.2
  385. * Tue May 30 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.1-1%{?dist}.ngx
  386. - 1.13.1
  387. * Tue Apr 25 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.0-1%{?dist}.ngx
  388. - 1.13.0
  389. * Tue Apr 4 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.13-1%{?dist}.ngx
  390. - 1.11.13
  391. - Made upgrade loops/timeouts configurable via /etc/defaults/nginx.
  392. * Fri Mar 24 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.12-1%{?dist}.ngx
  393. - 1.11.12
  394. * Tue Mar 21 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.11-1%{?dist}.ngx
  395. - 1.11.11
  396. * Tue Feb 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.10-1%{?dist}.ngx
  397. - 1.11.10
  398. * Tue Jan 24 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.9-1%{?dist}.ngx
  399. - 1.11.9
  400. - Extended hardening build flags.
  401. - Added check-reload target to init script / systemd service.
  402. * Tue Dec 27 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.8-1%{?dist}.ngx
  403. - 1.11.8
  404. * Tue Dec 13 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.7-1%{?dist}.ngx
  405. - 1.11.7
  406. * Fri Nov 25 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.6-1%{?dist}.ngx
  407. - 1.11.6
  408. * Mon Oct 10 2016 Andrei Belov <defan@nginx.com> - 1.11.5-1%{?dist}.ngx
  409. - 1.11.5
  410. * Tue Sep 13 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.4-1%{?dist}.ngx
  411. - 1.11.4
  412. - njs updated to 0.1.2.
  413. * Tue Jul 26 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.3-1%{?dist}.ngx
  414. - 1.11.3
  415. - njs updated to 0.1.0.
  416. - njs stream dynamic module added to nginx-module-njs package.
  417. - geoip stream dynamic module added to nginx-module-geoip package.
  418. * Tue Jul 5 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.2-1%{?dist}.ngx
  419. - 1.11.2
  420. - njs updated to ef2b708510b1.
  421. * Tue May 31 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.1-1%{?dist}.ngx
  422. - 1.11.1
  423. * Tue May 24 2016 Sergey Budnevitch <sb@nginx.com> - 1.11.0-1%{?dist}.ngx
  424. - 1.11.0
  425. - Bugfix: fixed logrotate error if nginx is not running.
  426. * Tue Apr 19 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.15-1%{?dist}.ngx
  427. - 1.9.15
  428. - njs updated to 1c50334fbea6.
  429. * Tue Apr 5 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.14-1%{?dist}.ngx
  430. - 1.9.14
  431. * Tue Mar 29 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.13-1%{?dist}.ngx
  432. - 1.9.13
  433. - Fixed modules path
  434. - Added perl and njs dynamic modules subpackages
  435. * Wed Feb 24 2016 Sergey Budnevitch <sb@nginx.com> - 1.9.12-1%{?dist}.ngx
  436. - 1.9.12
  437. - common configure args are now in variable
  438. - xslt, image-filter and geoip dynamic modules added
  439. * Tue Feb 9 2016 Sergey Budnevitch <sb@nginx.com> - 1.9.11-1%{?dist}.ngx
  440. - 1.9.11
  441. - dynamic modules path and symlink in /etc/nginx added
  442. * Tue Jan 26 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.10-1%{?dist}.ngx
  443. - 1.9.10
  444. * Wed Dec 9 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.9-1%{?dist}.ngx
  445. - 1.9.9
  446. * Tue Dec 8 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.8-1%{?dist}.ngx
  447. - 1.9.8
  448. - http_slice module enabled
  449. * Tue Nov 17 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.7-1%{?dist}.ngx
  450. - 1.9.7
  451. * Tue Oct 27 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.6-1%{?dist}.ngx
  452. - 1.9.6
  453. * Tue Sep 22 2015 Andrei Belov <defan@nginx.com> - 1.9.5-1%{?dist}.ngx
  454. - 1.9.5
  455. - http_spdy module replaced with http_v2 module
  456. * Tue Aug 18 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.4-1%{?dist}.ngx
  457. - 1.9.4
  458. * Tue Jul 14 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.3-1%{?dist}.ngx
  459. - 1.9.3
  460. * Tue Jun 16 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.2-1%{?dist}.ngx
  461. - 1.9.2
  462. * Tue May 26 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.1-1%{?dist}.ngx
  463. - 1.9.1
  464. * Tue Apr 28 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.0-1%{?dist}.ngx
  465. - 1.9.0
  466. - thread pool support added
  467. - stream module added
  468. - example_ssl.conf removed
  469. * Tue Apr 7 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.12-1%{?dist}.ngx
  470. - 1.7.12
  471. * Tue Mar 24 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.11-1%{?dist}.ngx
  472. - 1.7.11
  473. * Tue Feb 10 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.10-1%{?dist}.ngx
  474. - 1.7.10
  475. * Tue Dec 23 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.9-1%{?dist}.ngx
  476. - 1.7.9
  477. - init-script now sends signal only to the PID derived from pidfile
  478. * Tue Dec 2 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.8-1%{?dist}.ngx
  479. - 1.7.8
  480. - package with debug symbols added
  481. * Tue Oct 28 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.7-1%{?dist}.ngx
  482. - 1.7.7
  483. * Tue Sep 30 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.6-1%{?dist}.ngx
  484. - 1.7.6
  485. * Tue Sep 16 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.5-1%{?dist}.ngx
  486. - 1.7.5
  487. * Tue Aug 5 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.4-1%{?dist}.ngx
  488. - 1.7.4
  489. - init-script now returns 0 on stop command if nginx is not running
  490. * Tue Jul 8 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.3-1%{?dist}.ngx
  491. - 1.7.3
  492. * Tue Jun 17 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.2-1%{?dist}.ngx
  493. - 1.7.2
  494. * Tue May 27 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.1-1%{?dist}.ngx
  495. - 1.7.1
  496. * Thu Apr 24 2014 Konstantin Pavlov <thresh@nginx.com> - 1.7.0-1%{?dist}.ngx
  497. - 1.7.0
  498. * Tue Apr 8 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.13-1%{?dist}.ngx
  499. - 1.5.13
  500. * Tue Mar 18 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.12-1%{?dist}.ngx
  501. - 1.5.12
  502. - warning added when binary upgrade returns non-zero exit code
  503. * Tue Mar 4 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.11-1%{?dist}.ngx
  504. - 1.5.11
  505. * Tue Feb 4 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.10-1%{?dist}.ngx
  506. - 1.5.10
  507. * Wed Jan 22 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.9-1%{?dist}.ngx
  508. - 1.5.9
  509. * Tue Dec 17 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.8-1%{?dist}.ngx
  510. - 1.5.8
  511. * Fri Nov 29 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.7-1%{?dist}.ngx
  512. - 1.5.7
  513. - init script now honours additional options sourced from /etc/default/nginx
  514. * Tue Oct 1 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.6-1%{?dist}.ngx
  515. - 1.5.6
  516. * Tue Sep 17 2013 Andrei Belov <defan@nginx.com> - 1.5.5-1%{?dist}.ngx
  517. - 1.5.5
  518. * Tue Aug 27 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.4-1%{?dist}.ngx
  519. - 1.5.4
  520. - auth request module added
  521. * Tue Jul 30 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.3-1%{?dist}.ngx
  522. - 1.5.3
  523. * Tue Jul 2 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.2-1%{?dist}.ngx
  524. - 1.5.2
  525. * Tue Jun 4 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.1-1%{?dist}.ngx
  526. - 1.5.1
  527. - dpkg-buildflags options now passed by --with-{cc,ld}-opt
  528. * Mon May 6 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.0-1%{?dist}.ngx
  529. - 1.5.0
  530. - fixed openssl version detection with dash as /bin/sh
  531. * Tue Apr 16 2013 Sergey Budnevitch <sb@nginx.com> - 1.3.16-1%{?dist}.ngx
  532. - 1.3.16
  533. * Tue Mar 26 2013 Sergey Budnevitch <sb@nginx.com> - 1.3.15-1%{?dist}.ngx
  534. - 1.3.15
  535. - gunzip module added
  536. - spdy module added if openssl version >= 1.0.1
  537. - set permissions on default log files at installation