nginx.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710
  1. #
  2. %define nginx_home %{_localstatedir}/cache/nginx
  3. %define nginx_user nginx
  4. %define nginx_group nginx
  5. %define nginx_loggroup adm
  6. # distribution specific definitions
  7. %define use_systemd (0%{?rhel} >= 7 || 0%{?fedora} >= 19 || 0%{?suse_version} >= 1315 || 0%{?amzn} >= 2)
  8. %if %{use_systemd}
  9. BuildRequires: systemd
  10. Requires(post): systemd
  11. Requires(preun): systemd
  12. Requires(postun): systemd
  13. %endif
  14. %if 0%{?rhel}
  15. %define _group System Environment/Daemons
  16. %endif
  17. %if 0%{?rhel} == 6
  18. Requires(pre): shadow-utils
  19. Requires: initscripts >= 8.36
  20. Requires(post): chkconfig
  21. Requires: openssl >= 1.0.1
  22. BuildRequires: openssl-devel >= 1.0.1
  23. %endif
  24. %if 0%{?rhel} == 7
  25. %define epoch 1
  26. Epoch: %{epoch}
  27. Requires(pre): shadow-utils
  28. Requires: openssl >= 1.0.2
  29. BuildRequires: openssl-devel >= 1.0.2
  30. %define dist .el7
  31. %endif
  32. %if 0%{?rhel} == 8
  33. %define epoch 1
  34. Epoch: %{epoch}
  35. Requires(pre): shadow-utils
  36. BuildRequires: openssl-devel >= 1.1.1
  37. %define _debugsource_template %{nil}
  38. %endif
  39. %if 0%{?suse_version} >= 1315
  40. %define _group Productivity/Networking/Web/Servers
  41. %define nginx_loggroup trusted
  42. Requires(pre): shadow
  43. BuildRequires: libopenssl-devel
  44. %define _debugsource_template %{nil}
  45. %endif
  46. # end of distribution specific definitions
  47. %define main_version 1.17.6
  48. %define main_release 1%{?dist}.ngx
  49. %define bdir %{_builddir}/%{name}-%{main_version}
  50. %define WITH_CC_OPT $(echo %{optflags} $(pcre-config --cflags)) -fPIC
  51. %define WITH_LD_OPT -Wl,-z,relro -Wl,-z,now -pie
  52. %define BASE_CONFIGURE_ARGS $(echo "--prefix=%{_sysconfdir}/nginx --sbin-path=%{_sbindir}/nginx --modules-path=%{_libdir}/nginx/modules --conf-path=%{_sysconfdir}/nginx/nginx.conf --error-log-path=%{_localstatedir}/log/nginx/error.log --http-log-path=%{_localstatedir}/log/nginx/access.log --pid-path=%{_localstatedir}/run/nginx.pid --lock-path=%{_localstatedir}/run/nginx.lock --http-client-body-temp-path=%{_localstatedir}/cache/nginx/client_temp --http-proxy-temp-path=%{_localstatedir}/cache/nginx/proxy_temp --http-fastcgi-temp-path=%{_localstatedir}/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=%{_localstatedir}/cache/nginx/uwsgi_temp --http-scgi-temp-path=%{_localstatedir}/cache/nginx/scgi_temp --user=%{nginx_user} --group=%{nginx_group} --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module")
  53. Summary: High performance web server
  54. Name: nginx
  55. Version: %{main_version}
  56. Release: %{main_release}
  57. Vendor: Nginx, Inc.
  58. URL: http://nginx.org/
  59. Group: %{_group}
  60. Source0: https://nginx.org/download/%{name}-%{version}.tar.gz
  61. Source1: logrotate
  62. Source2: nginx.init.in
  63. Source3: nginx.sysconf
  64. Source4: nginx.conf
  65. Source5: nginx.vh.default.conf
  66. Source7: nginx-debug.sysconf
  67. Source8: nginx.service
  68. Source9: nginx.upgrade.sh
  69. Source10: nginx.suse.logrotate
  70. Source11: nginx-debug.service
  71. Source12: COPYRIGHT
  72. Source13: nginx.check-reload.sh
  73. Source14: https://github.com/openssl/openssl/archive/OpenSSL_1_1_1d.tar.gz
  74. License: 2-clause BSD-like license
  75. BuildRoot: %{_tmppath}/%{name}-%{main_version}-%{main_release}-root
  76. BuildRequires: zlib-devel
  77. BuildRequires: pcre-devel
  78. Provides: webserver
  79. %description
  80. nginx [engine x] is an HTTP and reverse proxy server, as well as
  81. a mail proxy server.
  82. %if 0%{?suse_version} >= 1315
  83. %debug_package
  84. %endif
  85. %prep
  86. %setup -q
  87. cp %{SOURCE2} .
  88. sed -e 's|%%DEFAULTSTART%%|2 3 4 5|g' -e 's|%%DEFAULTSTOP%%|0 1 6|g' \
  89. -e 's|%%PROVIDES%%|nginx|g' < %{SOURCE2} > nginx.init
  90. sed -e 's|%%DEFAULTSTART%%||g' -e 's|%%DEFAULTSTOP%%|0 1 2 3 4 5 6|g' \
  91. -e 's|%%PROVIDES%%|nginx-debug|g' < %{SOURCE2} > nginx-debug.init
  92. tar -zxf %{SOURCE14}
  93. %build
  94. ./configure %{BASE_CONFIGURE_ARGS} \
  95. --with-openssl=./openssl-OpenSSL_1_1_1d/ \
  96. --with-cc-opt="%{WITH_CC_OPT}" \
  97. --with-ld-opt="%{WITH_LD_OPT}" \
  98. --with-debug
  99. make %{?_smp_mflags}
  100. %{__mv} %{bdir}/objs/nginx \
  101. %{bdir}/objs/nginx-debug
  102. ./configure %{BASE_CONFIGURE_ARGS} \
  103. --with-cc-opt="%{WITH_CC_OPT}" \
  104. --with-ld-opt="%{WITH_LD_OPT}"
  105. make %{?_smp_mflags}
  106. %install
  107. %{__rm} -rf $RPM_BUILD_ROOT
  108. %{__make} DESTDIR=$RPM_BUILD_ROOT INSTALLDIRS=vendor install
  109. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/nginx
  110. %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/html $RPM_BUILD_ROOT%{_datadir}/nginx/
  111. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/*.default
  112. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/fastcgi.conf
  113. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/log/nginx
  114. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/run/nginx
  115. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/cache/nginx
  116. %{__mkdir} -p $RPM_BUILD_ROOT%{_libdir}/nginx/modules
  117. cd $RPM_BUILD_ROOT%{_sysconfdir}/nginx && \
  118. %{__ln_s} ../..%{_libdir}/nginx/modules modules && cd -
  119. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{main_version}
  120. %{__install} -m 644 -p %{SOURCE12} \
  121. $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{main_version}/
  122. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d
  123. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  124. %{__install} -m 644 -p %{SOURCE4} \
  125. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  126. %{__install} -m 644 -p %{SOURCE5} \
  127. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d/default.conf
  128. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  129. %{__install} -m 644 -p %{SOURCE3} \
  130. $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/nginx
  131. %{__install} -m 644 -p %{SOURCE7} \
  132. $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/nginx-debug
  133. %{__install} -p -D -m 0644 %{bdir}/objs/nginx.8 \
  134. $RPM_BUILD_ROOT%{_mandir}/man8/nginx.8
  135. %if %{use_systemd}
  136. # install systemd-specific files
  137. %{__mkdir} -p $RPM_BUILD_ROOT%{_unitdir}
  138. %{__install} -m644 %SOURCE8 \
  139. $RPM_BUILD_ROOT%{_unitdir}/nginx.service
  140. %{__install} -m644 %SOURCE11 \
  141. $RPM_BUILD_ROOT%{_unitdir}/nginx-debug.service
  142. %{__mkdir} -p $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx
  143. %{__install} -m755 %SOURCE9 \
  144. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/upgrade
  145. %{__install} -m755 %SOURCE13 \
  146. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/check-reload
  147. %else
  148. # install SYSV init stuff
  149. %{__mkdir} -p $RPM_BUILD_ROOT%{_initrddir}
  150. %{__install} -m755 nginx.init $RPM_BUILD_ROOT%{_initrddir}/nginx
  151. %{__install} -m755 nginx-debug.init $RPM_BUILD_ROOT%{_initrddir}/nginx-debug
  152. %endif
  153. # install log rotation stuff
  154. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
  155. %if 0%{?suse_version}
  156. %{__install} -m 644 -p %{SOURCE10} \
  157. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  158. %else
  159. %{__install} -m 644 -p %{SOURCE1} \
  160. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  161. %endif
  162. %{__install} -m755 %{bdir}/objs/nginx-debug \
  163. $RPM_BUILD_ROOT%{_sbindir}/nginx-debug
  164. %check
  165. %{__rm} -rf $RPM_BUILD_ROOT/usr/src
  166. cd %{bdir}
  167. grep -v 'usr/src' debugfiles.list > debugfiles.list.new && mv debugfiles.list.new debugfiles.list
  168. cat /dev/null > debugsources.list
  169. %if 0%{?suse_version} >= 1500
  170. cat /dev/null > debugsourcefiles.list
  171. %endif
  172. %clean
  173. %{__rm} -rf $RPM_BUILD_ROOT
  174. %files
  175. %defattr(-,root,root)
  176. %{_sbindir}/nginx
  177. %{_sbindir}/nginx-debug
  178. %dir %{_sysconfdir}/nginx
  179. %dir %{_sysconfdir}/nginx/conf.d
  180. %{_sysconfdir}/nginx/modules
  181. %config(noreplace) %{_sysconfdir}/nginx/nginx.conf
  182. %config(noreplace) %{_sysconfdir}/nginx/conf.d/default.conf
  183. %config(noreplace) %{_sysconfdir}/nginx/mime.types
  184. %config(noreplace) %{_sysconfdir}/nginx/fastcgi_params
  185. %config(noreplace) %{_sysconfdir}/nginx/scgi_params
  186. %config(noreplace) %{_sysconfdir}/nginx/uwsgi_params
  187. %config(noreplace) %{_sysconfdir}/nginx/koi-utf
  188. %config(noreplace) %{_sysconfdir}/nginx/koi-win
  189. %config(noreplace) %{_sysconfdir}/nginx/win-utf
  190. %config(noreplace) %{_sysconfdir}/logrotate.d/nginx
  191. %config(noreplace) %{_sysconfdir}/sysconfig/nginx
  192. %config(noreplace) %{_sysconfdir}/sysconfig/nginx-debug
  193. %if %{use_systemd}
  194. %{_unitdir}/nginx.service
  195. %{_unitdir}/nginx-debug.service
  196. %dir %{_libexecdir}/initscripts/legacy-actions/nginx
  197. %{_libexecdir}/initscripts/legacy-actions/nginx/*
  198. %else
  199. %{_initrddir}/nginx
  200. %{_initrddir}/nginx-debug
  201. %endif
  202. %attr(0755,root,root) %dir %{_libdir}/nginx
  203. %attr(0755,root,root) %dir %{_libdir}/nginx/modules
  204. %dir %{_datadir}/nginx
  205. %dir %{_datadir}/nginx/html
  206. %{_datadir}/nginx/html/*
  207. %attr(0755,root,root) %dir %{_localstatedir}/cache/nginx
  208. %attr(0755,root,root) %dir %{_localstatedir}/log/nginx
  209. %dir %{_datadir}/doc/%{name}-%{main_version}
  210. %doc %{_datadir}/doc/%{name}-%{main_version}/COPYRIGHT
  211. %{_mandir}/man8/nginx.8*
  212. %pre
  213. # Add the "nginx" user
  214. getent group %{nginx_group} >/dev/null || groupadd -r %{nginx_group}
  215. getent passwd %{nginx_user} >/dev/null || \
  216. useradd -r -g %{nginx_group} -s /sbin/nologin \
  217. -d %{nginx_home} -c "nginx user" %{nginx_user}
  218. exit 0
  219. %post
  220. # Register the nginx service
  221. if [ $1 -eq 1 ]; then
  222. %if %{use_systemd}
  223. /usr/bin/systemctl preset nginx.service >/dev/null 2>&1 ||:
  224. /usr/bin/systemctl preset nginx-debug.service >/dev/null 2>&1 ||:
  225. %else
  226. /sbin/chkconfig --add nginx
  227. /sbin/chkconfig --add nginx-debug
  228. %endif
  229. # print site info
  230. cat <<BANNER
  231. ----------------------------------------------------------------------
  232. Thanks for using nginx!
  233. Please find the official documentation for nginx here:
  234. * http://nginx.org/en/docs/
  235. Please subscribe to nginx-announce mailing list to get
  236. the most important news about nginx:
  237. * http://nginx.org/en/support.html
  238. Commercial subscriptions for nginx are available on:
  239. * http://nginx.com/products/
  240. ----------------------------------------------------------------------
  241. BANNER
  242. # Touch and set permisions on default log files on installation
  243. if [ -d %{_localstatedir}/log/nginx ]; then
  244. if [ ! -e %{_localstatedir}/log/nginx/access.log ]; then
  245. touch %{_localstatedir}/log/nginx/access.log
  246. %{__chmod} 640 %{_localstatedir}/log/nginx/access.log
  247. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/access.log
  248. fi
  249. if [ ! -e %{_localstatedir}/log/nginx/error.log ]; then
  250. touch %{_localstatedir}/log/nginx/error.log
  251. %{__chmod} 640 %{_localstatedir}/log/nginx/error.log
  252. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/error.log
  253. fi
  254. fi
  255. fi
  256. %preun
  257. if [ $1 -eq 0 ]; then
  258. %if %use_systemd
  259. /usr/bin/systemctl --no-reload disable nginx.service >/dev/null 2>&1 ||:
  260. /usr/bin/systemctl stop nginx.service >/dev/null 2>&1 ||:
  261. %else
  262. /sbin/service nginx stop > /dev/null 2>&1
  263. /sbin/chkconfig --del nginx
  264. /sbin/chkconfig --del nginx-debug
  265. %endif
  266. fi
  267. %postun
  268. %if %use_systemd
  269. /usr/bin/systemctl daemon-reload >/dev/null 2>&1 ||:
  270. %endif
  271. if [ $1 -ge 1 ]; then
  272. /sbin/service nginx status >/dev/null 2>&1 || exit 0
  273. /sbin/service nginx upgrade >/dev/null 2>&1 || echo \
  274. "Binary upgrade failed, please check nginx's error.log"
  275. fi
  276. %changelog
  277. * Tue Nov 19 2019 Konstantin Pavlov <thresh@nginx.com>
  278. - 1.17.6
  279. * Tue Oct 22 2019 Andrei Belov <defan@nginx.com>
  280. - 1.17.5
  281. * Tue Sep 24 2019 Konstantin Pavlov <thresh@nginx.com>
  282. - 1.17.4
  283. * Tue Aug 13 2019 Andrei Belov <defan@nginx.com>
  284. - 1.17.3
  285. * Tue Jul 23 2019 Konstantin Pavlov <thresh@nginx.com>
  286. - 1.17.2
  287. * Tue Jun 25 2019 Andrei Belov <defan@nginx.com>
  288. - 1.17.1
  289. * Tue May 21 2019 Konstantin Pavlov <thresh@nginx.com>
  290. - 1.17.0
  291. * Tue Apr 16 2019 Konstantin Pavlov <thresh@nginx.com>
  292. - 1.15.12
  293. * Tue Apr 09 2019 Konstantin Pavlov <thresh@nginx.com>
  294. - 1.15.11
  295. * Tue Mar 26 2019 Konstantin Pavlov <thresh@nginx.com>
  296. - 1.15.10
  297. * Tue Feb 26 2019 Konstantin Pavlov <thresh@nginx.com>
  298. - 1.15.9
  299. * Tue Dec 25 2018 Konstantin Pavlov <thresh@nginx.com>
  300. - 1.15.8
  301. * Tue Nov 27 2018 Konstantin Pavlov <thresh@nginx.com>
  302. - 1.15.7
  303. * Tue Nov 06 2018 Konstantin Pavlov <thresh@nginx.com>
  304. - 1.15.6
  305. - Fixes CVE-2018-16843
  306. - Fixes CVE-2018-16844
  307. - Fixes CVE-2018-16845
  308. * Tue Oct 02 2018 Konstantin Pavlov <thresh@nginx.com>
  309. - 1.15.5
  310. * Tue Sep 25 2018 Konstantin Pavlov <thresh@nginx.com>
  311. - 1.15.4
  312. * Tue Aug 28 2018 Konstantin Pavlov <thresh@nginx.com>
  313. - 1.15.3
  314. * Tue Jul 24 2018 Konstantin Pavlov <thresh@nginx.com>
  315. - 1.15.2
  316. * Tue Jul 03 2018 Konstantin Pavlov <thresh@nginx.com>
  317. - 1.15.1
  318. * Tue Jun 05 2018 Konstantin Pavlov <thresh@nginx.com>
  319. - 1.15.0
  320. * Mon Apr 09 2018 Konstantin Pavlov <thresh@nginx.com>
  321. - 1.13.12
  322. * Tue Apr 03 2018 Konstantin Pavlov <thresh@nginx.com>
  323. - 1.13.11
  324. * Tue Mar 20 2018 Konstantin Pavlov <thresh@nginx.com>
  325. - 1.13.10
  326. * Tue Feb 20 2018 Konstantin Pavlov <thresh@nginx.com>
  327. - 1.13.9
  328. * Tue Dec 26 2017 Konstantin Pavlov <thresh@nginx.com>
  329. - 1.13.8
  330. * Tue Nov 21 2017 Konstantin Pavlov <thresh@nginx.com>
  331. - 1.13.7
  332. * Tue Oct 10 2017 Konstantin Pavlov <thresh@nginx.com>
  333. - 1.13.6
  334. * Tue Sep 5 2017 Konstantin Pavlov <thresh@nginx.com>
  335. - 1.13.5
  336. * Tue Aug 8 2017 Sergey Budnevitch <sb@nginx.com>
  337. - 1.13.4
  338. * Tue Jul 11 2017 Konstantin Pavlov <thresh@nginx.com>
  339. - 1.13.3
  340. - Fixes CVE-2017-7529
  341. * Tue Jun 27 2017 Konstantin Pavlov <thresh@nginx.com>
  342. - 1.13.2
  343. * Tue May 30 2017 Konstantin Pavlov <thresh@nginx.com>
  344. - 1.13.1
  345. * Tue Apr 25 2017 Konstantin Pavlov <thresh@nginx.com>
  346. - 1.13.0
  347. * Tue Apr 4 2017 Konstantin Pavlov <thresh@nginx.com>
  348. - 1.11.13
  349. - CentOS7/RHEL7: made upgrade loops/timeouts configurable via
  350. /etc/sysconfig/nginx.
  351. - Bumped upgrade defaults to five loops one second each.
  352. * Fri Mar 24 2017 Konstantin Pavlov <thresh@nginx.com>
  353. - 1.11.12
  354. * Tue Mar 21 2017 Konstantin Pavlov <thresh@nginx.com>
  355. - 1.11.11
  356. * Tue Feb 14 2017 Konstantin Pavlov <thresh@nginx.com>
  357. - 1.11.10
  358. * Tue Jan 24 2017 Konstantin Pavlov <thresh@nginx.com>
  359. - 1.11.9
  360. - Extended hardening build flags.
  361. - Added check-reload target to init script / systemd service.
  362. * Tue Dec 27 2016 Konstantin Pavlov <thresh@nginx.com>
  363. - 1.11.8
  364. * Tue Dec 13 2016 Konstantin Pavlov <thresh@nginx.com>
  365. - 1.11.7
  366. * Tue Nov 15 2016 Konstantin Pavlov <thresh@nginx.com>
  367. - 1.11.6
  368. * Mon Oct 10 2016 Andrei Belov <defan@nginx.com>
  369. - 1.11.5
  370. * Tue Sep 13 2016 Konstantin Pavlov <thresh@nginx.com>
  371. - 1.11.4.
  372. - njs updated to 0.1.2.
  373. * Tue Jul 26 2016 Konstantin Pavlov <thresh@nginx.com>
  374. - 1.11.3.
  375. - njs updated to 0.1.0.
  376. - njs stream dynamic module added to nginx-module-njs package.
  377. - geoip stream dynamic module added to nginx-module-geoip package.
  378. * Tue Jul 5 2016 Konstantin Pavlov <thresh@nginx.com>
  379. - 1.11.2
  380. - njs updated to ef2b708510b1.
  381. * Tue May 31 2016 Konstantin Pavlov <thresh@nginx.com>
  382. - 1.11.1
  383. * Tue May 24 2016 Sergey Budnevitch <sb@nginx.com>
  384. - Fixed logrotate error if nginx is not running
  385. - 1.11.0
  386. * Tue Apr 19 2016 Konstantin Pavlov <thresh@nginx.com>
  387. - 1.9.15
  388. - njs updated to 1c50334fbea6.
  389. * Tue Apr 5 2016 Konstantin Pavlov <thresh@nginx.com>
  390. - 1.9.14
  391. * Tue Mar 29 2016 Konstantin Pavlov <thresh@nginx.com>
  392. - 1.9.13
  393. - Added perl and njs dynamic modules
  394. - Fixed Requires section for dynamic modules on CentOS7/RHEL7
  395. * Wed Feb 24 2016 Sergey Budnevitch <sb@nginx.com>
  396. - common configure args are now in macros
  397. - xslt, image-filter and geoip dynamic modules added
  398. - 1.9.12
  399. * Tue Feb 9 2016 Sergey Budnevitch <sb@nginx.com>
  400. - dynamic modules path and symlink in %{_sysconfdir}/nginx added
  401. - 1.9.11
  402. * Tue Jan 26 2016 Konstantin Pavlov <thresh@nginx.com>
  403. - 1.9.10
  404. * Wed Dec 9 2015 Konstantin Pavlov <thresh@nginx.com>
  405. - 1.9.9
  406. * Tue Dec 8 2015 Konstantin Pavlov <thresh@nginx.com>
  407. - 1.9.8
  408. - http_slice module enabled
  409. * Tue Nov 17 2015 Konstantin Pavlov <thresh@nginx.com>
  410. - 1.9.7
  411. * Tue Oct 27 2015 Sergey Budnevitch <sb@nginx.com>
  412. - 1.9.6
  413. * Tue Sep 22 2015 Andrei Belov <defan@nginx.com>
  414. - 1.9.5
  415. - http_spdy module replaced with http_v2 module
  416. * Tue Aug 18 2015 Konstantin Pavlov <thresh@nginx.com>
  417. - 1.9.4
  418. * Tue Jul 14 2015 Sergey Budnevitch <sb@nginx.com>
  419. - 1.9.3
  420. * Tue May 26 2015 Sergey Budnevitch <sb@nginx.com>
  421. - 1.9.1
  422. * Tue Apr 28 2015 Sergey Budnevitch <sb@nginx.com>
  423. - 1.9.0
  424. - thread pool support added
  425. - stream module added
  426. - example_ssl.conf removed
  427. * Tue Apr 7 2015 Sergey Budnevitch <sb@nginx.com>
  428. - 1.7.12
  429. * Tue Mar 24 2015 Sergey Budnevitch <sb@nginx.com>
  430. - 1.7.11
  431. * Tue Feb 10 2015 Sergey Budnevitch <sb@nginx.com>
  432. - 1.7.10
  433. * Tue Dec 23 2014 Sergey Budnevitch <sb@nginx.com>
  434. - 1.7.9
  435. * Tue Dec 2 2014 Sergey Budnevitch <sb@nginx.com>
  436. - 1.7.8
  437. * Tue Sep 30 2014 Sergey Budnevitch <sb@nginx.com>
  438. - 1.7.6
  439. * Tue Sep 16 2014 Sergey Budnevitch <sb@nginx.com>
  440. - epoch added to the EPEL7/CentOS7 spec to override EPEL one
  441. - 1.7.5
  442. * Tue Aug 5 2014 Sergey Budnevitch <sb@nginx.com>
  443. - 1.7.4
  444. * Tue Jul 8 2014 Sergey Budnevitch <sb@nginx.com>
  445. - 1.7.3
  446. * Tue Jun 17 2014 Sergey Budnevitch <sb@nginx.com>
  447. - 1.7.2
  448. * Tue May 27 2014 Sergey Budnevitch <sb@nginx.com>
  449. - 1.7.1
  450. - incorrect sysconfig filename finding in the initscript fixed
  451. * Thu Apr 24 2014 Konstantin Pavlov <thresh@nginx.com>
  452. - 1.7.0
  453. * Tue Apr 8 2014 Sergey Budnevitch <sb@nginx.com>
  454. - 1.5.13
  455. - built spdy module on rhel/centos 6
  456. * Tue Mar 18 2014 Sergey Budnevitch <sb@nginx.com>
  457. - 1.5.12
  458. - spec cleanup
  459. - openssl version dependence added
  460. - upgrade() function in the init script improved
  461. - warning added when binary upgrade returns non-zero exit code
  462. * Tue Mar 4 2014 Sergey Budnevitch <sb@nginx.com>
  463. - 1.5.11
  464. * Tue Feb 4 2014 Sergey Budnevitch <sb@nginx.com>
  465. - 1.5.10
  466. * Wed Jan 22 2014 Sergey Budnevitch <sb@nginx.com>
  467. - 1.5.9
  468. * Tue Dec 17 2013 Sergey Budnevitch <sb@nginx.com>
  469. - 1.5.8
  470. - fixed invalid week days in the changelog
  471. * Tue Nov 19 2013 Sergey Budnevitch <sb@nginx.com>
  472. - 1.5.7
  473. * Tue Oct 1 2013 Sergey Budnevitch <sb@nginx.com>
  474. - 1.5.6
  475. * Tue Sep 17 2013 Andrei Belov <defan@nginx.com>
  476. - 1.5.5
  477. * Tue Aug 27 2013 Sergey Budnevitch <sb@nginx.com>
  478. - 1.5.4
  479. - auth request module added
  480. * Tue Jul 30 2013 Sergey Budnevitch <sb@nginx.com>
  481. - 1.5.3
  482. * Tue Jul 2 2013 Sergey Budnevitch <sb@nginx.com>
  483. - 1.5.2
  484. * Tue Jun 4 2013 Sergey Budnevitch <sb@nginx.com>
  485. - 1.5.1
  486. * Mon May 6 2013 Sergey Budnevitch <sb@nginx.com>
  487. - 1.5.0
  488. * Tue Apr 16 2013 Sergey Budnevitch <sb@nginx.com>
  489. - 1.3.16
  490. * Tue Mar 26 2013 Sergey Budnevitch <sb@nginx.com>
  491. - 1.3.15
  492. - gunzip module added
  493. - set permissions on default log files at installation
  494. * Tue Feb 12 2013 Sergey Budnevitch <sb@nginx.com>
  495. - excess slash removed from --prefix
  496. - 1.2.7
  497. * Tue Dec 11 2012 Sergey Budnevitch <sb@nginx.com>
  498. - 1.2.6
  499. * Tue Nov 13 2012 Sergey Budnevitch <sb@nginx.com>
  500. - 1.2.5
  501. * Tue Sep 25 2012 Sergey Budnevitch <sb@nginx.com>
  502. - 1.2.4
  503. * Tue Aug 7 2012 Sergey Budnevitch <sb@nginx.com>
  504. - 1.2.3
  505. - nginx-debug package now actually contains non stripped binary
  506. * Tue Jul 3 2012 Sergey Budnevitch <sb@nginx.com>
  507. - 1.2.2
  508. * Tue Jun 5 2012 Sergey Budnevitch <sb@nginx.com>
  509. - 1.2.1
  510. * Mon Apr 23 2012 Sergey Budnevitch <sb@nginx.com>
  511. - 1.2.0
  512. * Thu Apr 12 2012 Sergey Budnevitch <sb@nginx.com>
  513. - 1.0.15
  514. * Thu Mar 15 2012 Sergey Budnevitch <sb@nginx.com>
  515. - 1.0.14
  516. - OpenSUSE init script and SuSE specific changes to spec file added
  517. * Mon Mar 5 2012 Sergey Budnevitch <sb@nginx.com>
  518. - 1.0.13
  519. * Mon Feb 6 2012 Sergey Budnevitch <sb@nginx.com>
  520. - 1.0.12
  521. - banner added to install script
  522. * Thu Dec 15 2011 Sergey Budnevitch <sb@nginx.com>
  523. - 1.0.11
  524. - init script enhancements (thanks to Gena Makhomed)
  525. - one second sleep during upgrade replaced with 0.1 sec usleep
  526. * Tue Nov 15 2011 Sergey Budnevitch <sb@nginx.com>
  527. - 1.0.10
  528. * Tue Nov 1 2011 Sergey Budnevitch <sb@nginx.com>
  529. - 1.0.9
  530. - nginx-debug package added
  531. * Tue Oct 11 2011 Sergey Budnevitch <sb@nginx.com>
  532. - spec file cleanup (thanks to Yury V. Zaytsev)
  533. - log dir permitions fixed
  534. - logrotate creates new logfiles with nginx owner
  535. - "upgrade" argument to init-script added (based on fedora one)
  536. * Sat Oct 1 2011 Sergey Budnevitch <sb@nginx.com>
  537. - 1.0.8
  538. - built with mp4 module
  539. * Fri Sep 30 2011 Sergey Budnevitch <sb@nginx.com>
  540. - 1.0.7
  541. * Tue Aug 30 2011 Sergey Budnevitch <sb@nginx.com>
  542. - 1.0.6
  543. - replace "conf.d/*" config include with "conf.d/*.conf" in default nginx.conf
  544. * Wed Aug 10 2011 Sergey Budnevitch
  545. - Initial release