nginx.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660
  1. #
  2. %define nginx_home %{_localstatedir}/cache/nginx
  3. %define nginx_user nginx
  4. %define nginx_group nginx
  5. %define nginx_loggroup adm
  6. BuildRequires: systemd
  7. Requires(post): systemd
  8. Requires(preun): systemd
  9. Requires(postun): systemd
  10. %if 0%{?rhel}
  11. %define _group System Environment/Daemons
  12. %endif
  13. %if (0%{?rhel} == 7) && (0%{?amzn} == 0)
  14. %define epoch 1
  15. Epoch: %{epoch}
  16. Requires(pre): shadow-utils
  17. Requires: openssl >= 1.0.2
  18. BuildRequires: openssl-devel >= 1.0.2
  19. %define dist .el7
  20. %endif
  21. %if (0%{?rhel} == 7) && (0%{?amzn} == 2)
  22. %define epoch 1
  23. Epoch: %{epoch}
  24. Requires(pre): shadow-utils
  25. Requires: openssl11 >= 1.1.1
  26. BuildRequires: openssl11-devel >= 1.1.1
  27. %endif
  28. %if 0%{?rhel} == 8
  29. %define epoch 1
  30. Epoch: %{epoch}
  31. Requires(pre): shadow-utils
  32. BuildRequires: openssl-devel >= 1.1.1
  33. %define _debugsource_template %{nil}
  34. %endif
  35. %if 0%{?suse_version} >= 1315
  36. %define _group Productivity/Networking/Web/Servers
  37. %define nginx_loggroup trusted
  38. Requires(pre): shadow
  39. BuildRequires: libopenssl-devel
  40. %define _debugsource_template %{nil}
  41. %endif
  42. %if 0%{?fedora}
  43. %define _debugsource_template %{nil}
  44. %global _hardened_build 1
  45. %define _group System Environment/Daemons
  46. BuildRequires: openssl-devel
  47. Requires(pre): shadow-utils
  48. %endif
  49. # end of distribution specific definitions
  50. %define openssl_version 1.1.1k
  51. %define base_version 1.21.0
  52. %define base_release 1%{?dist}.ngx
  53. %define bdir %{_builddir}/%{name}-%{base_version}
  54. %define WITH_CC_OPT $(echo %{optflags} $(pcre-config --cflags)) -fPIC
  55. %define WITH_LD_OPT -Wl,-z,relro -Wl,-z,now -pie
  56. %define BASE_CONFIGURE_ARGS $(echo "--prefix=%{_sysconfdir}/nginx --sbin-path=%{_sbindir}/nginx --modules-path=%{_libdir}/nginx/modules --conf-path=%{_sysconfdir}/nginx/nginx.conf --error-log-path=%{_localstatedir}/log/nginx/error.log --http-log-path=%{_localstatedir}/log/nginx/access.log --pid-path=%{_localstatedir}/run/nginx.pid --lock-path=%{_localstatedir}/run/nginx.lock --http-client-body-temp-path=%{_localstatedir}/cache/nginx/client_temp --http-proxy-temp-path=%{_localstatedir}/cache/nginx/proxy_temp --http-fastcgi-temp-path=%{_localstatedir}/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=%{_localstatedir}/cache/nginx/uwsgi_temp --http-scgi-temp-path=%{_localstatedir}/cache/nginx/scgi_temp --user=%{nginx_user} --group=%{nginx_group} --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module")
  57. Summary: High performance web server
  58. Name: nginx
  59. Version: %{base_version}
  60. Release: %{base_release}
  61. Vendor: NGINX Packaging <nginx-packaging@f5.com>
  62. URL: https://nginx.org/
  63. Group: %{_group}
  64. Source0: https://nginx.org/download/%{name}-%{version}.tar.gz
  65. Source1: logrotate
  66. Source2: nginx.conf
  67. Source3: nginx.default.conf
  68. Source4: nginx.service
  69. Source5: nginx.upgrade.sh
  70. Source6: nginx.suse.logrotate
  71. Source7: nginx-debug.service
  72. Source8: nginx.copyright
  73. Source9: nginx.check-reload.sh
  74. Source10: https://www.openssl.org/source/openssl-%{openssl_version}.tar.gz
  75. License: 2-clause BSD-like license
  76. BuildRoot: %{_tmppath}/%{name}-%{base_version}-%{base_release}-root
  77. BuildRequires: zlib-devel
  78. BuildRequires: pcre-devel
  79. Provides: webserver
  80. Provides: nginx-r%{base_version}
  81. %description
  82. nginx [engine x] is an HTTP and reverse proxy server, as well as
  83. a mail proxy server.
  84. %if 0%{?suse_version} >= 1315
  85. %debug_package
  86. %endif
  87. %prep
  88. %autosetup -p1
  89. tar -zxf %{SOURCE10}
  90. %build
  91. ./configure %{BASE_CONFIGURE_ARGS} \
  92. --with-openssl=./openssl-%{openssl_version}/ \
  93. --with-cc-opt="%{WITH_CC_OPT}" \
  94. --with-ld-opt="%{WITH_LD_OPT}" \
  95. --with-debug
  96. make %{?_smp_mflags}
  97. %{__mv} %{bdir}/objs/nginx \
  98. %{bdir}/objs/nginx-debug
  99. ./configure %{BASE_CONFIGURE_ARGS} \
  100. --with-openssl=./openssl-%{openssl_version}/ \
  101. --with-cc-opt="%{WITH_CC_OPT}" \
  102. --with-ld-opt="%{WITH_LD_OPT}"
  103. make %{?_smp_mflags}
  104. %install
  105. %{__rm} -rf $RPM_BUILD_ROOT
  106. %{__make} DESTDIR=$RPM_BUILD_ROOT INSTALLDIRS=vendor install
  107. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/nginx
  108. %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/html $RPM_BUILD_ROOT%{_datadir}/nginx/
  109. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/*.default
  110. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/fastcgi.conf
  111. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/log/nginx
  112. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/run/nginx
  113. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/cache/nginx
  114. %{__mkdir} -p $RPM_BUILD_ROOT%{_libdir}/nginx/modules
  115. cd $RPM_BUILD_ROOT%{_sysconfdir}/nginx && \
  116. %{__ln_s} ../..%{_libdir}/nginx/modules modules && cd -
  117. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{base_version}
  118. %{__install} -m 644 -p %{SOURCE8} \
  119. $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{base_version}/COPYRIGHT
  120. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d
  121. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  122. %{__install} -m 644 -p %{SOURCE2} \
  123. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  124. %{__install} -m 644 -p %{SOURCE3} \
  125. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d/default.conf
  126. %{__install} -p -D -m 0644 %{bdir}/objs/nginx.8 \
  127. $RPM_BUILD_ROOT%{_mandir}/man8/nginx.8
  128. %{__mkdir} -p $RPM_BUILD_ROOT%{_unitdir}
  129. %{__install} -m644 %SOURCE4 \
  130. $RPM_BUILD_ROOT%{_unitdir}/nginx.service
  131. %{__install} -m644 %SOURCE7 \
  132. $RPM_BUILD_ROOT%{_unitdir}/nginx-debug.service
  133. %{__mkdir} -p $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx
  134. %{__install} -m755 %SOURCE5 \
  135. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/upgrade
  136. %{__install} -m755 %SOURCE9 \
  137. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/check-reload
  138. # install log rotation stuff
  139. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
  140. %if 0%{?suse_version}
  141. %{__install} -m 644 -p %{SOURCE6} \
  142. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  143. %else
  144. %{__install} -m 644 -p %{SOURCE1} \
  145. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  146. %endif
  147. %{__install} -m755 %{bdir}/objs/nginx-debug \
  148. $RPM_BUILD_ROOT%{_sbindir}/nginx-debug
  149. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/koi-utf
  150. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/koi-win
  151. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/win-utf
  152. %check
  153. %{__rm} -rf $RPM_BUILD_ROOT/usr/src
  154. cd %{bdir}
  155. grep -v 'usr/src' debugfiles.list > debugfiles.list.new && mv debugfiles.list.new debugfiles.list
  156. cat /dev/null > debugsources.list
  157. %if 0%{?suse_version} >= 1500
  158. cat /dev/null > debugsourcefiles.list
  159. %endif
  160. %clean
  161. %{__rm} -rf $RPM_BUILD_ROOT
  162. %files
  163. %defattr(-,root,root)
  164. %{_sbindir}/nginx
  165. %{_sbindir}/nginx-debug
  166. %dir %{_sysconfdir}/nginx
  167. %dir %{_sysconfdir}/nginx/conf.d
  168. %{_sysconfdir}/nginx/modules
  169. %config(noreplace) %{_sysconfdir}/nginx/nginx.conf
  170. %config(noreplace) %{_sysconfdir}/nginx/conf.d/default.conf
  171. %config(noreplace) %{_sysconfdir}/nginx/mime.types
  172. %config(noreplace) %{_sysconfdir}/nginx/fastcgi_params
  173. %config(noreplace) %{_sysconfdir}/nginx/scgi_params
  174. %config(noreplace) %{_sysconfdir}/nginx/uwsgi_params
  175. %config(noreplace) %{_sysconfdir}/logrotate.d/nginx
  176. %{_unitdir}/nginx.service
  177. %{_unitdir}/nginx-debug.service
  178. %dir %{_libexecdir}/initscripts/legacy-actions/nginx
  179. %{_libexecdir}/initscripts/legacy-actions/nginx/*
  180. %attr(0755,root,root) %dir %{_libdir}/nginx
  181. %attr(0755,root,root) %dir %{_libdir}/nginx/modules
  182. %dir %{_datadir}/nginx
  183. %dir %{_datadir}/nginx/html
  184. %{_datadir}/nginx/html/*
  185. %attr(0755,root,root) %dir %{_localstatedir}/cache/nginx
  186. %attr(0755,root,root) %dir %{_localstatedir}/log/nginx
  187. %dir %{_datadir}/doc/%{name}-%{base_version}
  188. %doc %{_datadir}/doc/%{name}-%{base_version}/COPYRIGHT
  189. %{_mandir}/man8/nginx.8*
  190. %pre
  191. # Add the "nginx" user
  192. getent group %{nginx_group} >/dev/null || groupadd -r %{nginx_group}
  193. getent passwd %{nginx_user} >/dev/null || \
  194. useradd -r -g %{nginx_group} -s /sbin/nologin \
  195. -d %{nginx_home} -c "nginx user" %{nginx_user}
  196. exit 0
  197. %post
  198. # Register the nginx service
  199. if [ $1 -eq 1 ]; then
  200. /usr/bin/systemctl preset nginx.service >/dev/null 2>&1 ||:
  201. /usr/bin/systemctl preset nginx-debug.service >/dev/null 2>&1 ||:
  202. # print site info
  203. cat <<BANNER
  204. ----------------------------------------------------------------------
  205. Thanks for using nginx!
  206. Please find the official documentation for nginx here:
  207. * https://nginx.org/en/docs/
  208. Please subscribe to nginx-announce mailing list to get
  209. the most important news about nginx:
  210. * https://nginx.org/en/support.html
  211. Commercial subscriptions for nginx are available on:
  212. * https://nginx.com/products/
  213. ----------------------------------------------------------------------
  214. BANNER
  215. # Touch and set permisions on default log files on installation
  216. if [ -d %{_localstatedir}/log/nginx ]; then
  217. if [ ! -e %{_localstatedir}/log/nginx/access.log ]; then
  218. touch %{_localstatedir}/log/nginx/access.log
  219. %{__chmod} 640 %{_localstatedir}/log/nginx/access.log
  220. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/access.log
  221. fi
  222. if [ ! -e %{_localstatedir}/log/nginx/error.log ]; then
  223. touch %{_localstatedir}/log/nginx/error.log
  224. %{__chmod} 640 %{_localstatedir}/log/nginx/error.log
  225. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/error.log
  226. fi
  227. fi
  228. fi
  229. %preun
  230. if [ $1 -eq 0 ]; then
  231. /usr/bin/systemctl --no-reload disable nginx.service >/dev/null 2>&1 ||:
  232. /usr/bin/systemctl stop nginx.service >/dev/null 2>&1 ||:
  233. fi
  234. %postun
  235. /usr/bin/systemctl daemon-reload >/dev/null 2>&1 ||:
  236. if [ $1 -ge 1 ]; then
  237. /sbin/service nginx status >/dev/null 2>&1 || exit 0
  238. /sbin/service nginx upgrade >/dev/null 2>&1 || echo \
  239. "Binary upgrade failed, please check nginx's error.log"
  240. fi
  241. %changelog
  242. * Tue May 25 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.0-1%{?dist}.ngx
  243. - 1.21.0-1
  244. * Tue Apr 13 2021 Andrei Belov <defan@nginx.com> - 1.19.10-1%{?dist}.ngx
  245. - 1.19.10-1
  246. * Tue Mar 30 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.9-1%{?dist}.ngx
  247. - 1.19.9-1
  248. * Tue Mar 9 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.8-1%{?dist}.ngx
  249. - 1.19.8-1
  250. * Tue Feb 16 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.7-1%{?dist}.ngx
  251. - 1.19.7-1
  252. * Tue Dec 15 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.6-1%{?dist}.ngx
  253. - 1.19.6-1
  254. * Tue Nov 24 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.5-1%{?dist}.ngx
  255. - 1.19.5-1
  256. * Tue Oct 27 2020 Andrei Belov <defan@nginx.com> - 1.19.4-1%{?dist}.ngx
  257. - 1.19.4-1
  258. * Tue Sep 29 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.3-1%{?dist}.ngx
  259. - 1.19.3
  260. * Tue Aug 11 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.2-1%{?dist}.ngx
  261. - 1.19.2
  262. * Tue Jul 7 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.1-1%{?dist}.ngx
  263. - 1.19.1
  264. * Tue May 26 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.0-1%{?dist}.ngx
  265. - 1.19.0
  266. * Tue Apr 14 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.10-1%{?dist}.ngx
  267. - 1.17.10
  268. * Tue Mar 3 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.9-1%{?dist}.ngx
  269. - 1.17.9
  270. * Tue Jan 21 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.8-1%{?dist}.ngx
  271. - 1.17.8
  272. * Tue Dec 24 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.7-1%{?dist}.ngx
  273. - 1.17.7
  274. * Tue Nov 19 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.6-1%{?dist}.ngx
  275. - 1.17.6
  276. * Tue Oct 22 2019 Andrei Belov <defan@nginx.com> - 1.17.5-1%{?dist}.ngx
  277. - 1.17.5
  278. * Tue Sep 24 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.4-1%{?dist}.ngx
  279. - 1.17.4
  280. * Tue Aug 13 2019 Andrei Belov <defan@nginx.com> - 1.17.3-1%{?dist}.ngx
  281. - 1.17.3
  282. * Tue Jul 23 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.2-1%{?dist}.ngx
  283. - 1.17.2
  284. * Tue Jun 25 2019 Andrei Belov <defan@nginx.com> - 1.17.1-1%{?dist}.ngx
  285. - 1.17.1
  286. * Tue May 21 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.0-1%{?dist}.ngx
  287. - 1.17.0
  288. * Tue Apr 16 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.12-1%{?dist}.ngx
  289. - 1.15.12
  290. * Tue Apr 9 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.11-1%{?dist}.ngx
  291. - 1.15.11
  292. * Tue Mar 26 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.10-1%{?dist}.ngx
  293. - 1.15.10
  294. * Tue Feb 26 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.9-1%{?dist}.ngx
  295. - 1.15.9
  296. * Tue Dec 25 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.8-1%{?dist}.ngx
  297. - 1.15.8
  298. * Tue Nov 27 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.7-1%{?dist}.ngx
  299. - 1.15.7
  300. * Tue Nov 6 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.6-1%{?dist}.ngx
  301. - 1.15.6
  302. - Security: fixes CVE-2018-16843.
  303. - Security: fixes CVE-2018-16844.
  304. - Security: fixes CVE-2018-16845.
  305. * Tue Oct 2 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.5-1%{?dist}.ngx
  306. - 1.15.5
  307. * Tue Sep 25 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.4-1%{?dist}.ngx
  308. - 1.15.4
  309. * Tue Aug 28 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.3-1%{?dist}.ngx
  310. - 1.15.3
  311. * Tue Jul 24 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.2-1%{?dist}.ngx
  312. - 1.15.2
  313. * Tue Jul 3 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.1-1%{?dist}.ngx
  314. - 1.15.1
  315. * Tue Jun 5 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.0-1%{?dist}.ngx
  316. - 1.15.0
  317. * Mon Apr 9 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.12-1%{?dist}.ngx
  318. - 1.13.12
  319. * Tue Apr 3 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.11-1%{?dist}.ngx
  320. - 1.13.11
  321. * Tue Mar 20 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.10-1%{?dist}.ngx
  322. - 1.13.10
  323. * Tue Feb 20 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.9-1%{?dist}.ngx
  324. - 1.13.9
  325. * Tue Dec 26 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.8-1%{?dist}.ngx
  326. - 1.13.8
  327. * Tue Nov 21 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.7-1%{?dist}.ngx
  328. - 1.13.7
  329. * Thu Sep 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.6-1%{?dist}.ngx
  330. - 1.13.6
  331. - Bugfix: in systemd service support
  332. (https://trac.nginx.org/nginx/ticket/1380).
  333. * Thu Sep 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.5-1%{?dist}.ngx
  334. - 1.13.5
  335. * Tue Aug 8 2017 Sergey Budnevitch <sb@nginx.com> - 1.13.4-1%{?dist}.ngx
  336. - 1.13.4
  337. * Tue Jul 11 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.3-1%{?dist}.ngx
  338. - 1.13.3
  339. - Security: fixes CVE-2017-7529.
  340. * Tue Jun 27 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.2-1%{?dist}.ngx
  341. - 1.13.2
  342. * Tue May 30 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.1-1%{?dist}.ngx
  343. - 1.13.1
  344. * Tue Apr 25 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.0-1%{?dist}.ngx
  345. - 1.13.0
  346. * Tue Apr 4 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.13-1%{?dist}.ngx
  347. - 1.11.13
  348. - Made upgrade loops/timeouts configurable via /etc/defaults/nginx.
  349. * Fri Mar 24 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.12-1%{?dist}.ngx
  350. - 1.11.12
  351. * Tue Mar 21 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.11-1%{?dist}.ngx
  352. - 1.11.11
  353. * Tue Feb 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.10-1%{?dist}.ngx
  354. - 1.11.10
  355. * Tue Jan 24 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.9-1%{?dist}.ngx
  356. - 1.11.9
  357. - Extended hardening build flags.
  358. - Added check-reload target to init script / systemd service.
  359. * Tue Dec 27 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.8-1%{?dist}.ngx
  360. - 1.11.8
  361. * Tue Dec 13 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.7-1%{?dist}.ngx
  362. - 1.11.7
  363. * Fri Nov 25 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.6-1%{?dist}.ngx
  364. - 1.11.6
  365. * Mon Oct 10 2016 Andrei Belov <defan@nginx.com> - 1.11.5-1%{?dist}.ngx
  366. - 1.11.5
  367. * Tue Sep 13 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.4-1%{?dist}.ngx
  368. - 1.11.4
  369. - njs updated to 0.1.2.
  370. * Tue Jul 26 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.3-1%{?dist}.ngx
  371. - 1.11.3
  372. - njs updated to 0.1.0.
  373. - njs stream dynamic module added to nginx-module-njs package.
  374. - geoip stream dynamic module added to nginx-module-geoip package.
  375. * Tue Jul 5 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.2-1%{?dist}.ngx
  376. - 1.11.2
  377. - njs updated to ef2b708510b1.
  378. * Tue May 31 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.1-1%{?dist}.ngx
  379. - 1.11.1
  380. * Tue May 24 2016 Sergey Budnevitch <sb@nginx.com> - 1.11.0-1%{?dist}.ngx
  381. - 1.11.0
  382. - Bugfix: fixed logrotate error if nginx is not running.
  383. * Tue Apr 19 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.15-1%{?dist}.ngx
  384. - 1.9.15
  385. - njs updated to 1c50334fbea6.
  386. * Tue Apr 5 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.14-1%{?dist}.ngx
  387. - 1.9.14
  388. * Tue Mar 29 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.13-1%{?dist}.ngx
  389. - 1.9.13
  390. - Fixed modules path
  391. - Added perl and njs dynamic modules subpackages
  392. * Wed Feb 24 2016 Sergey Budnevitch <sb@nginx.com> - 1.9.12-1%{?dist}.ngx
  393. - 1.9.12
  394. - common configure args are now in variable
  395. - xslt, image-filter and geoip dynamic modules added
  396. * Tue Feb 9 2016 Sergey Budnevitch <sb@nginx.com> - 1.9.11-1%{?dist}.ngx
  397. - 1.9.11
  398. - dynamic modules path and symlink in /etc/nginx added
  399. * Tue Jan 26 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.10-1%{?dist}.ngx
  400. - 1.9.10
  401. * Wed Dec 9 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.9-1%{?dist}.ngx
  402. - 1.9.9
  403. * Tue Dec 8 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.8-1%{?dist}.ngx
  404. - 1.9.8
  405. - http_slice module enabled
  406. * Tue Nov 17 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.7-1%{?dist}.ngx
  407. - 1.9.7
  408. * Tue Oct 27 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.6-1%{?dist}.ngx
  409. - 1.9.6
  410. * Tue Sep 22 2015 Andrei Belov <defan@nginx.com> - 1.9.5-1%{?dist}.ngx
  411. - 1.9.5
  412. - http_spdy module replaced with http_v2 module
  413. * Tue Aug 18 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.4-1%{?dist}.ngx
  414. - 1.9.4
  415. * Tue Jul 14 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.3-1%{?dist}.ngx
  416. - 1.9.3
  417. * Tue Jun 16 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.2-1%{?dist}.ngx
  418. - 1.9.2
  419. * Tue May 26 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.1-1%{?dist}.ngx
  420. - 1.9.1
  421. * Tue Apr 28 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.0-1%{?dist}.ngx
  422. - 1.9.0
  423. - thread pool support added
  424. - stream module added
  425. - example_ssl.conf removed
  426. * Tue Apr 7 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.12-1%{?dist}.ngx
  427. - 1.7.12
  428. * Tue Mar 24 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.11-1%{?dist}.ngx
  429. - 1.7.11
  430. * Tue Feb 10 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.10-1%{?dist}.ngx
  431. - 1.7.10
  432. * Tue Dec 23 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.9-1%{?dist}.ngx
  433. - 1.7.9
  434. - init-script now sends signal only to the PID derived from pidfile
  435. * Tue Dec 2 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.8-1%{?dist}.ngx
  436. - 1.7.8
  437. - package with debug symbols added
  438. * Tue Oct 28 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.7-1%{?dist}.ngx
  439. - 1.7.7
  440. * Tue Sep 30 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.6-1%{?dist}.ngx
  441. - 1.7.6
  442. * Tue Sep 16 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.5-1%{?dist}.ngx
  443. - 1.7.5
  444. * Tue Aug 5 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.4-1%{?dist}.ngx
  445. - 1.7.4
  446. - init-script now returns 0 on stop command if nginx is not running
  447. * Tue Jul 8 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.3-1%{?dist}.ngx
  448. - 1.7.3
  449. * Tue Jun 17 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.2-1%{?dist}.ngx
  450. - 1.7.2
  451. * Tue May 27 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.1-1%{?dist}.ngx
  452. - 1.7.1
  453. * Thu Apr 24 2014 Konstantin Pavlov <thresh@nginx.com> - 1.7.0-1%{?dist}.ngx
  454. - 1.7.0
  455. * Tue Apr 8 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.13-1%{?dist}.ngx
  456. - 1.5.13
  457. * Tue Mar 18 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.12-1%{?dist}.ngx
  458. - 1.5.12
  459. - warning added when binary upgrade returns non-zero exit code
  460. * Tue Mar 4 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.11-1%{?dist}.ngx
  461. - 1.5.11
  462. * Tue Feb 4 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.10-1%{?dist}.ngx
  463. - 1.5.10
  464. * Wed Jan 22 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.9-1%{?dist}.ngx
  465. - 1.5.9
  466. * Tue Dec 17 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.8-1%{?dist}.ngx
  467. - 1.5.8
  468. * Fri Nov 29 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.7-1%{?dist}.ngx
  469. - 1.5.7
  470. - init script now honours additional options sourced from /etc/default/nginx
  471. * Tue Oct 1 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.6-1%{?dist}.ngx
  472. - 1.5.6
  473. * Tue Sep 17 2013 Andrei Belov <defan@nginx.com> - 1.5.5-1%{?dist}.ngx
  474. - 1.5.5
  475. * Tue Aug 27 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.4-1%{?dist}.ngx
  476. - 1.5.4
  477. - auth request module added
  478. * Tue Jul 30 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.3-1%{?dist}.ngx
  479. - 1.5.3
  480. * Tue Jul 2 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.2-1%{?dist}.ngx
  481. - 1.5.2
  482. * Tue Jun 4 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.1-1%{?dist}.ngx
  483. - 1.5.1
  484. - dpkg-buildflags options now passed by --with-{cc,ld}-opt
  485. * Mon May 6 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.0-1%{?dist}.ngx
  486. - 1.5.0
  487. - fixed openssl version detection with dash as /bin/sh
  488. * Tue Apr 16 2013 Sergey Budnevitch <sb@nginx.com> - 1.3.16-1%{?dist}.ngx
  489. - 1.3.16
  490. * Tue Mar 26 2013 Sergey Budnevitch <sb@nginx.com> - 1.3.15-1%{?dist}.ngx
  491. - 1.3.15
  492. - gunzip module added
  493. - spdy module added if openssl version >= 1.0.1
  494. - set permissions on default log files at installation