nginx.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728
  1. #
  2. %define nginx_home %{_localstatedir}/cache/nginx
  3. %define nginx_user nginx
  4. %define nginx_group nginx
  5. %define nginx_loggroup adm
  6. BuildRequires: systemd
  7. Requires(post): systemd
  8. Requires(preun): systemd
  9. Requires(postun): systemd
  10. %if 0%{?rhel}
  11. %define _group System Environment/Daemons
  12. %endif
  13. %if (0%{?rhel} == 7) && (0%{?amzn} == 0)
  14. %define epoch 1
  15. Epoch: %{epoch}
  16. Requires(pre): shadow-utils
  17. Requires: openssl >= 1.0.2
  18. Requires: procps-ng
  19. BuildRequires: openssl-devel >= 1.0.2
  20. BuildRequires: perl-IPC-Cmd
  21. %define dist .el7
  22. %endif
  23. %if (0%{?rhel} == 7) && (0%{?amzn} == 2)
  24. %define epoch 1
  25. Epoch: %{epoch}
  26. Requires(pre): shadow-utils
  27. Requires: openssl11 >= 1.1.1
  28. Requires: procps-ng
  29. BuildRequires: openssl11-devel >= 1.1.1
  30. %endif
  31. %if 0%{?rhel} == 8
  32. %define epoch 1
  33. Epoch: %{epoch}
  34. Requires(pre): shadow-utils
  35. Requires: procps-ng
  36. BuildRequires: openssl-devel >= 1.1.1
  37. %define _debugsource_template %{nil}
  38. %endif
  39. %if 0%{?rhel} == 9
  40. %define epoch 1
  41. Epoch: %{epoch}
  42. Requires(pre): shadow-utils
  43. Requires: procps-ng
  44. BuildRequires: openssl-devel
  45. BuildRequires: gcc
  46. %define _debugsource_template %{nil}
  47. %endif
  48. %if 0%{?suse_version} >= 1315
  49. %define _group Productivity/Networking/Web/Servers
  50. %define nginx_loggroup trusted
  51. Requires(pre): shadow
  52. Requires: procps
  53. BuildRequires: libopenssl-devel
  54. %define _debugsource_template %{nil}
  55. %endif
  56. # This also applies to Amazon Linux 2023
  57. %if 0%{?fedora}
  58. %define _debugsource_template %{nil}
  59. %global _hardened_build 1
  60. %define _group System Environment/Daemons
  61. Requires: procps-ng
  62. BuildRequires: openssl-devel
  63. Requires(pre): shadow-utils
  64. %endif
  65. # end of distribution specific definitions
  66. %define openssl_version 3.0.10-quic1
  67. %define base_version 1.25.3
  68. %define base_release 1%{?dist}.ngx
  69. %define bdir %{_builddir}/%{name}-%{base_version}
  70. %define WITH_CC_OPT $(echo %{optflags} $(pcre2-config --cflags)) -fPIC
  71. %define WITH_LD_OPT -Wl,-z,relro -Wl,-z,now -pie
  72. %define BASE_CONFIGURE_ARGS $(echo "--prefix=%{_sysconfdir}/nginx --sbin-path=%{_sbindir}/nginx --modules-path=%{_libdir}/nginx/modules --conf-path=%{_sysconfdir}/nginx/nginx.conf --error-log-path=%{_localstatedir}/log/nginx/error.log --http-log-path=%{_localstatedir}/log/nginx/access.log --pid-path=%{_localstatedir}/run/nginx.pid --lock-path=%{_localstatedir}/run/nginx.lock --http-client-body-temp-path=%{_localstatedir}/cache/nginx/client_temp --http-proxy-temp-path=%{_localstatedir}/cache/nginx/proxy_temp --http-fastcgi-temp-path=%{_localstatedir}/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=%{_localstatedir}/cache/nginx/uwsgi_temp --http-scgi-temp-path=%{_localstatedir}/cache/nginx/scgi_temp --user=%{nginx_user} --group=%{nginx_group} --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module $( if [ 0%{?rhel} -eq 7 ] || [ 0%{?suse_version} -eq 1315 ]; then continue; else echo "--with-http_v3_module"; fi; ) --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module")
  73. Summary: High performance web server
  74. Name: nginx
  75. Version: %{base_version}
  76. Release: %{base_release}
  77. Vendor: NGINX Packaging <nginx-packaging@f5.com>
  78. URL: https://nginx.org/
  79. Group: %{_group}
  80. Source0: https://nginx.org/download/%{name}-%{version}.tar.gz
  81. Source1: logrotate
  82. Source2: nginx.conf
  83. Source3: nginx.default.conf
  84. Source4: nginx.service
  85. Source5: nginx.upgrade.sh
  86. Source6: nginx.suse.logrotate
  87. Source7: nginx-debug.service
  88. Source8: nginx.copyright
  89. Source9: nginx.check-reload.sh
  90. Source10: https://github.com/quictls/openssl/archive/refs/tags/openssl-%{openssl_version}.tar.gz
  91. License: 2-clause BSD-like license
  92. BuildRoot: %{_tmppath}/%{name}-%{base_version}-%{base_release}-root
  93. BuildRequires: zlib-devel
  94. BuildRequires: pcre2-devel
  95. BuildRequires: perl
  96. Provides: webserver
  97. Provides: nginx-r%{base_version}
  98. %if !(0%{?rhel} == 7)
  99. Recommends: logrotate
  100. %endif
  101. %description
  102. nginx [engine x] is an HTTP and reverse proxy server, as well as
  103. a mail proxy server.
  104. %if 0%{?suse_version} >= 1315
  105. %debug_package
  106. %endif
  107. %prep
  108. %autosetup -p1
  109. tar -zxf %{SOURCE10}
  110. %build
  111. ./configure %{BASE_CONFIGURE_ARGS} \
  112. --with-openssl=./openssl-openssl-%{openssl_version}/ \
  113. --with-cc-opt="%{WITH_CC_OPT}" \
  114. --with-ld-opt="%{WITH_LD_OPT}" \
  115. --with-debug
  116. make %{?_smp_mflags}
  117. %{__mv} %{bdir}/objs/nginx \
  118. %{bdir}/objs/nginx-debug
  119. ./configure %{BASE_CONFIGURE_ARGS} \
  120. --with-openssl=./openssl-openssl-%{openssl_version}/ \
  121. --with-cc-opt="%{WITH_CC_OPT}" \
  122. --with-ld-opt="%{WITH_LD_OPT}"
  123. make %{?_smp_mflags}
  124. %install
  125. %{__rm} -rf $RPM_BUILD_ROOT
  126. %{__make} DESTDIR=$RPM_BUILD_ROOT INSTALLDIRS=vendor install
  127. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/nginx
  128. %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/html $RPM_BUILD_ROOT%{_datadir}/nginx/
  129. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/*.default
  130. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/fastcgi.conf
  131. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/log/nginx
  132. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/run/nginx
  133. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/cache/nginx
  134. %{__mkdir} -p $RPM_BUILD_ROOT%{_libdir}/nginx/modules
  135. cd $RPM_BUILD_ROOT%{_sysconfdir}/nginx && \
  136. %{__ln_s} ../..%{_libdir}/nginx/modules modules && cd -
  137. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{base_version}
  138. %{__install} -m 644 -p %{SOURCE8} \
  139. $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{base_version}/COPYRIGHT
  140. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d
  141. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  142. %{__install} -m 644 -p %{SOURCE2} \
  143. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  144. %{__install} -m 644 -p %{SOURCE3} \
  145. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d/default.conf
  146. %{__install} -p -D -m 0644 %{bdir}/objs/nginx.8 \
  147. $RPM_BUILD_ROOT%{_mandir}/man8/nginx.8
  148. %{__mkdir} -p $RPM_BUILD_ROOT%{_unitdir}
  149. %{__install} -m644 %SOURCE4 \
  150. $RPM_BUILD_ROOT%{_unitdir}/nginx.service
  151. %{__install} -m644 %SOURCE7 \
  152. $RPM_BUILD_ROOT%{_unitdir}/nginx-debug.service
  153. %{__mkdir} -p $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx
  154. %{__install} -m755 %SOURCE5 \
  155. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/upgrade
  156. %{__install} -m755 %SOURCE9 \
  157. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/check-reload
  158. # install log rotation stuff
  159. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
  160. %if 0%{?suse_version}
  161. %{__install} -m 644 -p %{SOURCE6} \
  162. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  163. %else
  164. %{__install} -m 644 -p %{SOURCE1} \
  165. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  166. %endif
  167. %{__install} -m755 %{bdir}/objs/nginx-debug \
  168. $RPM_BUILD_ROOT%{_sbindir}/nginx-debug
  169. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/koi-utf
  170. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/koi-win
  171. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/win-utf
  172. %check
  173. %{__rm} -rf $RPM_BUILD_ROOT/usr/src
  174. cd %{bdir}
  175. grep -v 'usr/src' debugfiles.list > debugfiles.list.new && mv debugfiles.list.new debugfiles.list
  176. cat /dev/null > debugsources.list
  177. %if 0%{?suse_version} >= 1500
  178. cat /dev/null > debugsourcefiles.list
  179. %endif
  180. %clean
  181. %{__rm} -rf $RPM_BUILD_ROOT
  182. %files
  183. %defattr(-,root,root)
  184. %{_sbindir}/nginx
  185. %{_sbindir}/nginx-debug
  186. %dir %{_sysconfdir}/nginx
  187. %dir %{_sysconfdir}/nginx/conf.d
  188. %{_sysconfdir}/nginx/modules
  189. %config(noreplace) %{_sysconfdir}/nginx/nginx.conf
  190. %config(noreplace) %{_sysconfdir}/nginx/conf.d/default.conf
  191. %config(noreplace) %{_sysconfdir}/nginx/mime.types
  192. %config(noreplace) %{_sysconfdir}/nginx/fastcgi_params
  193. %config(noreplace) %{_sysconfdir}/nginx/scgi_params
  194. %config(noreplace) %{_sysconfdir}/nginx/uwsgi_params
  195. %config(noreplace) %{_sysconfdir}/logrotate.d/nginx
  196. %{_unitdir}/nginx.service
  197. %{_unitdir}/nginx-debug.service
  198. %dir %{_libexecdir}/initscripts/legacy-actions/nginx
  199. %{_libexecdir}/initscripts/legacy-actions/nginx/*
  200. %attr(0755,root,root) %dir %{_libdir}/nginx
  201. %attr(0755,root,root) %dir %{_libdir}/nginx/modules
  202. %dir %{_datadir}/nginx
  203. %dir %{_datadir}/nginx/html
  204. %{_datadir}/nginx/html/*
  205. %attr(0755,root,root) %dir %{_localstatedir}/cache/nginx
  206. %attr(0755,root,root) %dir %{_localstatedir}/log/nginx
  207. %dir %{_datadir}/doc/%{name}-%{base_version}
  208. %doc %{_datadir}/doc/%{name}-%{base_version}/COPYRIGHT
  209. %{_mandir}/man8/nginx.8*
  210. %pre
  211. # Add the "nginx" user
  212. getent group %{nginx_group} >/dev/null || groupadd -r %{nginx_group}
  213. getent passwd %{nginx_user} >/dev/null || \
  214. useradd -r -g %{nginx_group} -s /sbin/nologin \
  215. -d %{nginx_home} -c "nginx user" %{nginx_user}
  216. exit 0
  217. %post
  218. # Register the nginx service
  219. if [ $1 -eq 1 ]; then
  220. /usr/bin/systemctl preset nginx.service >/dev/null 2>&1 ||:
  221. /usr/bin/systemctl preset nginx-debug.service >/dev/null 2>&1 ||:
  222. # print site info
  223. cat <<BANNER
  224. ----------------------------------------------------------------------
  225. Thanks for using nginx!
  226. Please find the official documentation for nginx here:
  227. * https://nginx.org/en/docs/
  228. Please subscribe to nginx-announce mailing list to get
  229. the most important news about nginx:
  230. * https://nginx.org/en/support.html
  231. Commercial subscriptions for nginx are available on:
  232. * https://nginx.com/products/
  233. ----------------------------------------------------------------------
  234. BANNER
  235. # Touch and set permisions on default log files on installation
  236. if [ -d %{_localstatedir}/log/nginx ]; then
  237. if [ ! -e %{_localstatedir}/log/nginx/access.log ]; then
  238. touch %{_localstatedir}/log/nginx/access.log
  239. %{__chmod} 640 %{_localstatedir}/log/nginx/access.log
  240. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/access.log
  241. fi
  242. if [ ! -e %{_localstatedir}/log/nginx/error.log ]; then
  243. touch %{_localstatedir}/log/nginx/error.log
  244. %{__chmod} 640 %{_localstatedir}/log/nginx/error.log
  245. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/error.log
  246. fi
  247. fi
  248. fi
  249. %preun
  250. if [ $1 -eq 0 ]; then
  251. /usr/bin/systemctl --no-reload disable nginx.service >/dev/null 2>&1 ||:
  252. /usr/bin/systemctl stop nginx.service >/dev/null 2>&1 ||:
  253. fi
  254. %postun
  255. /usr/bin/systemctl daemon-reload >/dev/null 2>&1 ||:
  256. if [ $1 -ge 1 ]; then
  257. /sbin/service nginx status >/dev/null 2>&1 || exit 0
  258. /sbin/service nginx upgrade >/dev/null 2>&1 || echo \
  259. "Binary upgrade failed, please check nginx's error.log"
  260. fi
  261. %changelog
  262. * Tue Oct 24 2023 Nginx Packaging <nginx-packaging@f5.com> - 1.25.3-1%{?dist}.ngx
  263. - 1.25.3-1
  264. * Tue Aug 15 2023 Nginx Packaging <nginx-packaging@f5.com> - 1.25.2-1%{?dist}.ngx
  265. - 1.25.2-1
  266. * Tue Jun 13 2023 Nginx Packaging <nginx-packaging@f5.com> - 1.25.1-1%{?dist}.ngx
  267. - 1.25.1-1
  268. * Tue May 23 2023 Nginx Packaging <nginx-packaging@f5.com> - 1.25.0-1%{?dist}.ngx
  269. - 1.25.0-1
  270. * Tue Mar 28 2023 Nginx Packaging <nginx-packaging@f5.com> - 1.23.4-1%{?dist}.ngx
  271. - 1.23.4-1
  272. * Tue Dec 13 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.3-1%{?dist}.ngx
  273. - 1.23.3-1
  274. * Wed Oct 19 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.2-1%{?dist}.ngx
  275. - 1.23.2-1
  276. * Tue Jul 19 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.1-1%{?dist}.ngx
  277. - 1.23.1-1
  278. * Tue Jun 21 2022 Nginx Packaging <nginx-packaging@f5.com> - 1.23.0-1%{?dist}.ngx
  279. - 1.23.0-1
  280. * Tue Jan 25 2022 Mikhail Isachenkov <mikhail.isachenkov@nginx.com> - 1.21.6-1%{?dist}.ngx
  281. - 1.21.6-1
  282. * Tue Dec 28 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.5-1%{?dist}.ngx
  283. - 1.21.5-1
  284. - built with PCRE2
  285. * Tue Nov 2 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.4-1%{?dist}.ngx
  286. - 1.21.4-1
  287. * Tue Sep 7 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.3-1%{?dist}.ngx
  288. - 1.21.3-1
  289. * Tue Aug 31 2021 Andrei Belov <defan@nginx.com> - 1.21.2-1%{?dist}.ngx
  290. - 1.21.2-1
  291. * Tue Jul 6 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.1-1%{?dist}.ngx
  292. - 1.21.1-1
  293. * Tue May 25 2021 Konstantin Pavlov <thresh@nginx.com> - 1.21.0-1%{?dist}.ngx
  294. - 1.21.0-1
  295. * Tue Apr 13 2021 Andrei Belov <defan@nginx.com> - 1.19.10-1%{?dist}.ngx
  296. - 1.19.10-1
  297. * Tue Mar 30 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.9-1%{?dist}.ngx
  298. - 1.19.9-1
  299. * Tue Mar 9 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.8-1%{?dist}.ngx
  300. - 1.19.8-1
  301. * Tue Feb 16 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.7-1%{?dist}.ngx
  302. - 1.19.7-1
  303. * Tue Dec 15 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.6-1%{?dist}.ngx
  304. - 1.19.6-1
  305. * Tue Nov 24 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.5-1%{?dist}.ngx
  306. - 1.19.5-1
  307. * Tue Oct 27 2020 Andrei Belov <defan@nginx.com> - 1.19.4-1%{?dist}.ngx
  308. - 1.19.4-1
  309. * Tue Sep 29 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.3-1%{?dist}.ngx
  310. - 1.19.3
  311. * Tue Aug 11 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.2-1%{?dist}.ngx
  312. - 1.19.2
  313. * Tue Jul 7 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.1-1%{?dist}.ngx
  314. - 1.19.1
  315. * Tue May 26 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.0-1%{?dist}.ngx
  316. - 1.19.0
  317. * Tue Apr 14 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.10-1%{?dist}.ngx
  318. - 1.17.10
  319. * Tue Mar 3 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.9-1%{?dist}.ngx
  320. - 1.17.9
  321. * Tue Jan 21 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.8-1%{?dist}.ngx
  322. - 1.17.8
  323. * Tue Dec 24 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.7-1%{?dist}.ngx
  324. - 1.17.7
  325. * Tue Nov 19 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.6-1%{?dist}.ngx
  326. - 1.17.6
  327. * Tue Oct 22 2019 Andrei Belov <defan@nginx.com> - 1.17.5-1%{?dist}.ngx
  328. - 1.17.5
  329. * Tue Sep 24 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.4-1%{?dist}.ngx
  330. - 1.17.4
  331. * Tue Aug 13 2019 Andrei Belov <defan@nginx.com> - 1.17.3-1%{?dist}.ngx
  332. - 1.17.3
  333. * Tue Jul 23 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.2-1%{?dist}.ngx
  334. - 1.17.2
  335. * Tue Jun 25 2019 Andrei Belov <defan@nginx.com> - 1.17.1-1%{?dist}.ngx
  336. - 1.17.1
  337. * Tue May 21 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.0-1%{?dist}.ngx
  338. - 1.17.0
  339. * Tue Apr 16 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.12-1%{?dist}.ngx
  340. - 1.15.12
  341. * Tue Apr 9 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.11-1%{?dist}.ngx
  342. - 1.15.11
  343. * Tue Mar 26 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.10-1%{?dist}.ngx
  344. - 1.15.10
  345. * Tue Feb 26 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.9-1%{?dist}.ngx
  346. - 1.15.9
  347. * Tue Dec 25 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.8-1%{?dist}.ngx
  348. - 1.15.8
  349. * Tue Nov 27 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.7-1%{?dist}.ngx
  350. - 1.15.7
  351. * Tue Nov 6 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.6-1%{?dist}.ngx
  352. - 1.15.6
  353. - Security: fixes CVE-2018-16843.
  354. - Security: fixes CVE-2018-16844.
  355. - Security: fixes CVE-2018-16845.
  356. * Tue Oct 2 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.5-1%{?dist}.ngx
  357. - 1.15.5
  358. * Tue Sep 25 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.4-1%{?dist}.ngx
  359. - 1.15.4
  360. * Tue Aug 28 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.3-1%{?dist}.ngx
  361. - 1.15.3
  362. * Tue Jul 24 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.2-1%{?dist}.ngx
  363. - 1.15.2
  364. * Tue Jul 3 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.1-1%{?dist}.ngx
  365. - 1.15.1
  366. * Tue Jun 5 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.0-1%{?dist}.ngx
  367. - 1.15.0
  368. * Mon Apr 9 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.12-1%{?dist}.ngx
  369. - 1.13.12
  370. * Tue Apr 3 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.11-1%{?dist}.ngx
  371. - 1.13.11
  372. * Tue Mar 20 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.10-1%{?dist}.ngx
  373. - 1.13.10
  374. * Tue Feb 20 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.9-1%{?dist}.ngx
  375. - 1.13.9
  376. * Tue Dec 26 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.8-1%{?dist}.ngx
  377. - 1.13.8
  378. * Tue Nov 21 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.7-1%{?dist}.ngx
  379. - 1.13.7
  380. * Thu Sep 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.6-1%{?dist}.ngx
  381. - 1.13.6
  382. - Bugfix: in systemd service support
  383. (https://trac.nginx.org/nginx/ticket/1380).
  384. * Thu Sep 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.5-1%{?dist}.ngx
  385. - 1.13.5
  386. * Tue Aug 8 2017 Sergey Budnevitch <sb@nginx.com> - 1.13.4-1%{?dist}.ngx
  387. - 1.13.4
  388. * Tue Jul 11 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.3-1%{?dist}.ngx
  389. - 1.13.3
  390. - Security: fixes CVE-2017-7529.
  391. * Tue Jun 27 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.2-1%{?dist}.ngx
  392. - 1.13.2
  393. * Tue May 30 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.1-1%{?dist}.ngx
  394. - 1.13.1
  395. * Tue Apr 25 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.0-1%{?dist}.ngx
  396. - 1.13.0
  397. * Tue Apr 4 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.13-1%{?dist}.ngx
  398. - 1.11.13
  399. - Made upgrade loops/timeouts configurable via /etc/defaults/nginx.
  400. * Fri Mar 24 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.12-1%{?dist}.ngx
  401. - 1.11.12
  402. * Tue Mar 21 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.11-1%{?dist}.ngx
  403. - 1.11.11
  404. * Tue Feb 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.10-1%{?dist}.ngx
  405. - 1.11.10
  406. * Tue Jan 24 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.9-1%{?dist}.ngx
  407. - 1.11.9
  408. - Extended hardening build flags.
  409. - Added check-reload target to init script / systemd service.
  410. * Tue Dec 27 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.8-1%{?dist}.ngx
  411. - 1.11.8
  412. * Tue Dec 13 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.7-1%{?dist}.ngx
  413. - 1.11.7
  414. * Fri Nov 25 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.6-1%{?dist}.ngx
  415. - 1.11.6
  416. * Mon Oct 10 2016 Andrei Belov <defan@nginx.com> - 1.11.5-1%{?dist}.ngx
  417. - 1.11.5
  418. * Tue Sep 13 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.4-1%{?dist}.ngx
  419. - 1.11.4
  420. - njs updated to 0.1.2.
  421. * Tue Jul 26 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.3-1%{?dist}.ngx
  422. - 1.11.3
  423. - njs updated to 0.1.0.
  424. - njs stream dynamic module added to nginx-module-njs package.
  425. - geoip stream dynamic module added to nginx-module-geoip package.
  426. * Tue Jul 5 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.2-1%{?dist}.ngx
  427. - 1.11.2
  428. - njs updated to ef2b708510b1.
  429. * Tue May 31 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.1-1%{?dist}.ngx
  430. - 1.11.1
  431. * Tue May 24 2016 Sergey Budnevitch <sb@nginx.com> - 1.11.0-1%{?dist}.ngx
  432. - 1.11.0
  433. - Bugfix: fixed logrotate error if nginx is not running.
  434. * Tue Apr 19 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.15-1%{?dist}.ngx
  435. - 1.9.15
  436. - njs updated to 1c50334fbea6.
  437. * Tue Apr 5 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.14-1%{?dist}.ngx
  438. - 1.9.14
  439. * Tue Mar 29 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.13-1%{?dist}.ngx
  440. - 1.9.13
  441. - Fixed modules path
  442. - Added perl and njs dynamic modules subpackages
  443. * Wed Feb 24 2016 Sergey Budnevitch <sb@nginx.com> - 1.9.12-1%{?dist}.ngx
  444. - 1.9.12
  445. - common configure args are now in variable
  446. - xslt, image-filter and geoip dynamic modules added
  447. * Tue Feb 9 2016 Sergey Budnevitch <sb@nginx.com> - 1.9.11-1%{?dist}.ngx
  448. - 1.9.11
  449. - dynamic modules path and symlink in /etc/nginx added
  450. * Tue Jan 26 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.10-1%{?dist}.ngx
  451. - 1.9.10
  452. * Wed Dec 9 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.9-1%{?dist}.ngx
  453. - 1.9.9
  454. * Tue Dec 8 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.8-1%{?dist}.ngx
  455. - 1.9.8
  456. - http_slice module enabled
  457. * Tue Nov 17 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.7-1%{?dist}.ngx
  458. - 1.9.7
  459. * Tue Oct 27 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.6-1%{?dist}.ngx
  460. - 1.9.6
  461. * Tue Sep 22 2015 Andrei Belov <defan@nginx.com> - 1.9.5-1%{?dist}.ngx
  462. - 1.9.5
  463. - http_spdy module replaced with http_v2 module
  464. * Tue Aug 18 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.4-1%{?dist}.ngx
  465. - 1.9.4
  466. * Tue Jul 14 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.3-1%{?dist}.ngx
  467. - 1.9.3
  468. * Tue Jun 16 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.2-1%{?dist}.ngx
  469. - 1.9.2
  470. * Tue May 26 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.1-1%{?dist}.ngx
  471. - 1.9.1
  472. * Tue Apr 28 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.0-1%{?dist}.ngx
  473. - 1.9.0
  474. - thread pool support added
  475. - stream module added
  476. - example_ssl.conf removed
  477. * Tue Apr 7 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.12-1%{?dist}.ngx
  478. - 1.7.12
  479. * Tue Mar 24 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.11-1%{?dist}.ngx
  480. - 1.7.11
  481. * Tue Feb 10 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.10-1%{?dist}.ngx
  482. - 1.7.10
  483. * Tue Dec 23 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.9-1%{?dist}.ngx
  484. - 1.7.9
  485. - init-script now sends signal only to the PID derived from pidfile
  486. * Tue Dec 2 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.8-1%{?dist}.ngx
  487. - 1.7.8
  488. - package with debug symbols added
  489. * Tue Oct 28 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.7-1%{?dist}.ngx
  490. - 1.7.7
  491. * Tue Sep 30 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.6-1%{?dist}.ngx
  492. - 1.7.6
  493. * Tue Sep 16 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.5-1%{?dist}.ngx
  494. - 1.7.5
  495. * Tue Aug 5 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.4-1%{?dist}.ngx
  496. - 1.7.4
  497. - init-script now returns 0 on stop command if nginx is not running
  498. * Tue Jul 8 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.3-1%{?dist}.ngx
  499. - 1.7.3
  500. * Tue Jun 17 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.2-1%{?dist}.ngx
  501. - 1.7.2
  502. * Tue May 27 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.1-1%{?dist}.ngx
  503. - 1.7.1
  504. * Thu Apr 24 2014 Konstantin Pavlov <thresh@nginx.com> - 1.7.0-1%{?dist}.ngx
  505. - 1.7.0
  506. * Tue Apr 8 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.13-1%{?dist}.ngx
  507. - 1.5.13
  508. * Tue Mar 18 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.12-1%{?dist}.ngx
  509. - 1.5.12
  510. - warning added when binary upgrade returns non-zero exit code
  511. * Tue Mar 4 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.11-1%{?dist}.ngx
  512. - 1.5.11
  513. * Tue Feb 4 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.10-1%{?dist}.ngx
  514. - 1.5.10
  515. * Wed Jan 22 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.9-1%{?dist}.ngx
  516. - 1.5.9
  517. * Tue Dec 17 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.8-1%{?dist}.ngx
  518. - 1.5.8
  519. * Fri Nov 29 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.7-1%{?dist}.ngx
  520. - 1.5.7
  521. - init script now honours additional options sourced from /etc/default/nginx
  522. * Tue Oct 1 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.6-1%{?dist}.ngx
  523. - 1.5.6
  524. * Tue Sep 17 2013 Andrei Belov <defan@nginx.com> - 1.5.5-1%{?dist}.ngx
  525. - 1.5.5
  526. * Tue Aug 27 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.4-1%{?dist}.ngx
  527. - 1.5.4
  528. - auth request module added
  529. * Tue Jul 30 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.3-1%{?dist}.ngx
  530. - 1.5.3
  531. * Tue Jul 2 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.2-1%{?dist}.ngx
  532. - 1.5.2
  533. * Tue Jun 4 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.1-1%{?dist}.ngx
  534. - 1.5.1
  535. - dpkg-buildflags options now passed by --with-{cc,ld}-opt
  536. * Mon May 6 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.0-1%{?dist}.ngx
  537. - 1.5.0
  538. - fixed openssl version detection with dash as /bin/sh
  539. * Tue Apr 16 2013 Sergey Budnevitch <sb@nginx.com> - 1.3.16-1%{?dist}.ngx
  540. - 1.3.16
  541. * Tue Mar 26 2013 Sergey Budnevitch <sb@nginx.com> - 1.3.15-1%{?dist}.ngx
  542. - 1.3.15
  543. - gunzip module added
  544. - spdy module added if openssl version >= 1.0.1
  545. - set permissions on default log files at installation