nginx.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703
  1. #
  2. %define nginx_home %{_localstatedir}/cache/nginx
  3. %define nginx_user nginx
  4. %define nginx_group nginx
  5. %define nginx_loggroup adm
  6. # distribution specific definitions
  7. %define use_systemd (0%{?rhel} >= 7 || 0%{?fedora} >= 19 || 0%{?suse_version} >= 1315 || 0%{?amzn} >= 2)
  8. %if %{use_systemd}
  9. BuildRequires: systemd
  10. Requires(post): systemd
  11. Requires(preun): systemd
  12. Requires(postun): systemd
  13. %endif
  14. %if 0%{?rhel}
  15. %define _group System Environment/Daemons
  16. %endif
  17. %if 0%{?rhel} == 6
  18. Requires(pre): shadow-utils
  19. Requires: initscripts >= 8.36
  20. Requires(post): chkconfig
  21. Requires: openssl >= 1.0.1
  22. BuildRequires: openssl-devel >= 1.0.1
  23. %endif
  24. %if 0%{?rhel} == 7
  25. %define epoch 1
  26. Epoch: %{epoch}
  27. Requires(pre): shadow-utils
  28. Requires: openssl >= 1.0.2
  29. BuildRequires: openssl-devel >= 1.0.2
  30. %define dist .el7
  31. %endif
  32. %if 0%{?rhel} == 8
  33. %define epoch 1
  34. Epoch: %{epoch}
  35. Requires(pre): shadow-utils
  36. BuildRequires: openssl-devel >= 1.1.1
  37. %define _debugsource_template %{nil}
  38. %endif
  39. %if 0%{?suse_version} >= 1315
  40. %define _group Productivity/Networking/Web/Servers
  41. %define nginx_loggroup trusted
  42. Requires(pre): shadow
  43. BuildRequires: libopenssl-devel
  44. %define _debugsource_template %{nil}
  45. %endif
  46. %if 0%{?fedora}
  47. %define _debugsource_template %{nil}
  48. %global _hardened_build 1
  49. %define _group System Environment/Daemons
  50. BuildRequires: openssl-devel
  51. Requires(pre): shadow-utils
  52. %endif
  53. # end of distribution specific definitions
  54. %define openssl_version 1.1.1k
  55. %define base_version 1.19.10
  56. %define base_release 1%{?dist}.ngx
  57. %define bdir %{_builddir}/%{name}-%{base_version}
  58. %define WITH_CC_OPT $(echo %{optflags} $(pcre-config --cflags)) -fPIC
  59. %define WITH_LD_OPT -Wl,-z,relro -Wl,-z,now -pie
  60. %define BASE_CONFIGURE_ARGS $(echo "--prefix=%{_sysconfdir}/nginx --sbin-path=%{_sbindir}/nginx --modules-path=%{_libdir}/nginx/modules --conf-path=%{_sysconfdir}/nginx/nginx.conf --error-log-path=%{_localstatedir}/log/nginx/error.log --http-log-path=%{_localstatedir}/log/nginx/access.log --pid-path=%{_localstatedir}/run/nginx.pid --lock-path=%{_localstatedir}/run/nginx.lock --http-client-body-temp-path=%{_localstatedir}/cache/nginx/client_temp --http-proxy-temp-path=%{_localstatedir}/cache/nginx/proxy_temp --http-fastcgi-temp-path=%{_localstatedir}/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=%{_localstatedir}/cache/nginx/uwsgi_temp --http-scgi-temp-path=%{_localstatedir}/cache/nginx/scgi_temp --user=%{nginx_user} --group=%{nginx_group} --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module")
  61. Summary: High performance web server
  62. Name: nginx
  63. Version: %{base_version}
  64. Release: %{base_release}
  65. Vendor: Nginx, Inc.
  66. URL: https://nginx.org/
  67. Group: %{_group}
  68. Source0: https://nginx.org/download/%{name}-%{version}.tar.gz
  69. Source1: logrotate
  70. Source2: nginx.init.in
  71. Source3: nginx.sysconf
  72. Source4: nginx.conf
  73. Source5: nginx.default.conf
  74. Source7: nginx-debug.sysconf
  75. Source8: nginx.service
  76. Source9: nginx.upgrade.sh
  77. Source10: nginx.suse.logrotate
  78. Source11: nginx-debug.service
  79. Source12: nginx.copyright
  80. Source13: nginx.check-reload.sh
  81. Source14: https://www.openssl.org/source/openssl-%{openssl_version}.tar.gz
  82. License: 2-clause BSD-like license
  83. BuildRoot: %{_tmppath}/%{name}-%{base_version}-%{base_release}-root
  84. BuildRequires: zlib-devel
  85. BuildRequires: pcre-devel
  86. Provides: webserver
  87. Provides: nginx-r%{base_version}
  88. %description
  89. nginx [engine x] is an HTTP and reverse proxy server, as well as
  90. a mail proxy server.
  91. %if 0%{?suse_version} >= 1315
  92. %debug_package
  93. %endif
  94. %prep
  95. %autosetup -p1
  96. cp %{SOURCE2} .
  97. sed -e 's|%%DEFAULTSTART%%|2 3 4 5|g' -e 's|%%DEFAULTSTOP%%|0 1 6|g' \
  98. -e 's|%%PROVIDES%%|nginx|g' < %{SOURCE2} > nginx.init
  99. sed -e 's|%%DEFAULTSTART%%||g' -e 's|%%DEFAULTSTOP%%|0 1 2 3 4 5 6|g' \
  100. -e 's|%%PROVIDES%%|nginx-debug|g' < %{SOURCE2} > nginx-debug.init
  101. tar -zxf %{SOURCE14}
  102. %build
  103. ./configure %{BASE_CONFIGURE_ARGS} \
  104. --with-openssl=./openssl-%{openssl_version}/ \
  105. --with-cc-opt="%{WITH_CC_OPT}" \
  106. --with-ld-opt="%{WITH_LD_OPT}" \
  107. --with-debug
  108. make %{?_smp_mflags}
  109. %{__mv} %{bdir}/objs/nginx \
  110. %{bdir}/objs/nginx-debug
  111. ./configure %{BASE_CONFIGURE_ARGS} \
  112. --with-openssl=./openssl-%{openssl_version}/ \
  113. --with-cc-opt="%{WITH_CC_OPT}" \
  114. --with-ld-opt="%{WITH_LD_OPT}"
  115. make %{?_smp_mflags}
  116. %install
  117. %{__rm} -rf $RPM_BUILD_ROOT
  118. %{__make} DESTDIR=$RPM_BUILD_ROOT INSTALLDIRS=vendor install
  119. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/nginx
  120. %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/html $RPM_BUILD_ROOT%{_datadir}/nginx/
  121. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/*.default
  122. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/fastcgi.conf
  123. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/log/nginx
  124. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/run/nginx
  125. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/cache/nginx
  126. %{__mkdir} -p $RPM_BUILD_ROOT%{_libdir}/nginx/modules
  127. cd $RPM_BUILD_ROOT%{_sysconfdir}/nginx && \
  128. %{__ln_s} ../..%{_libdir}/nginx/modules modules && cd -
  129. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{base_version}
  130. %{__install} -m 644 -p %{SOURCE12} \
  131. $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{base_version}/COPYRIGHT
  132. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d
  133. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  134. %{__install} -m 644 -p %{SOURCE4} \
  135. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  136. %{__install} -m 644 -p %{SOURCE5} \
  137. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d/default.conf
  138. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  139. %{__install} -m 644 -p %{SOURCE3} \
  140. $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/nginx
  141. %{__install} -m 644 -p %{SOURCE7} \
  142. $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/nginx-debug
  143. %{__install} -p -D -m 0644 %{bdir}/objs/nginx.8 \
  144. $RPM_BUILD_ROOT%{_mandir}/man8/nginx.8
  145. %if %{use_systemd}
  146. # install systemd-specific files
  147. %{__mkdir} -p $RPM_BUILD_ROOT%{_unitdir}
  148. %{__install} -m644 %SOURCE8 \
  149. $RPM_BUILD_ROOT%{_unitdir}/nginx.service
  150. %{__install} -m644 %SOURCE11 \
  151. $RPM_BUILD_ROOT%{_unitdir}/nginx-debug.service
  152. %{__mkdir} -p $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx
  153. %{__install} -m755 %SOURCE9 \
  154. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/upgrade
  155. %{__install} -m755 %SOURCE13 \
  156. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/check-reload
  157. %else
  158. # install SYSV init stuff
  159. %{__mkdir} -p $RPM_BUILD_ROOT%{_initrddir}
  160. %{__install} -m755 nginx.init $RPM_BUILD_ROOT%{_initrddir}/nginx
  161. %{__install} -m755 nginx-debug.init $RPM_BUILD_ROOT%{_initrddir}/nginx-debug
  162. %endif
  163. # install log rotation stuff
  164. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
  165. %if 0%{?suse_version}
  166. %{__install} -m 644 -p %{SOURCE10} \
  167. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  168. %else
  169. %{__install} -m 644 -p %{SOURCE1} \
  170. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  171. %endif
  172. %{__install} -m755 %{bdir}/objs/nginx-debug \
  173. $RPM_BUILD_ROOT%{_sbindir}/nginx-debug
  174. %check
  175. %{__rm} -rf $RPM_BUILD_ROOT/usr/src
  176. cd %{bdir}
  177. grep -v 'usr/src' debugfiles.list > debugfiles.list.new && mv debugfiles.list.new debugfiles.list
  178. cat /dev/null > debugsources.list
  179. %if 0%{?suse_version} >= 1500
  180. cat /dev/null > debugsourcefiles.list
  181. %endif
  182. %clean
  183. %{__rm} -rf $RPM_BUILD_ROOT
  184. %files
  185. %defattr(-,root,root)
  186. %{_sbindir}/nginx
  187. %{_sbindir}/nginx-debug
  188. %dir %{_sysconfdir}/nginx
  189. %dir %{_sysconfdir}/nginx/conf.d
  190. %{_sysconfdir}/nginx/modules
  191. %config(noreplace) %{_sysconfdir}/nginx/nginx.conf
  192. %config(noreplace) %{_sysconfdir}/nginx/conf.d/default.conf
  193. %config(noreplace) %{_sysconfdir}/nginx/mime.types
  194. %config(noreplace) %{_sysconfdir}/nginx/fastcgi_params
  195. %config(noreplace) %{_sysconfdir}/nginx/scgi_params
  196. %config(noreplace) %{_sysconfdir}/nginx/uwsgi_params
  197. %config(noreplace) %{_sysconfdir}/nginx/koi-utf
  198. %config(noreplace) %{_sysconfdir}/nginx/koi-win
  199. %config(noreplace) %{_sysconfdir}/nginx/win-utf
  200. %config(noreplace) %{_sysconfdir}/logrotate.d/nginx
  201. %config(noreplace) %{_sysconfdir}/sysconfig/nginx
  202. %config(noreplace) %{_sysconfdir}/sysconfig/nginx-debug
  203. %if %{use_systemd}
  204. %{_unitdir}/nginx.service
  205. %{_unitdir}/nginx-debug.service
  206. %dir %{_libexecdir}/initscripts/legacy-actions/nginx
  207. %{_libexecdir}/initscripts/legacy-actions/nginx/*
  208. %else
  209. %{_initrddir}/nginx
  210. %{_initrddir}/nginx-debug
  211. %endif
  212. %attr(0755,root,root) %dir %{_libdir}/nginx
  213. %attr(0755,root,root) %dir %{_libdir}/nginx/modules
  214. %dir %{_datadir}/nginx
  215. %dir %{_datadir}/nginx/html
  216. %{_datadir}/nginx/html/*
  217. %attr(0755,root,root) %dir %{_localstatedir}/cache/nginx
  218. %attr(0755,root,root) %dir %{_localstatedir}/log/nginx
  219. %dir %{_datadir}/doc/%{name}-%{base_version}
  220. %doc %{_datadir}/doc/%{name}-%{base_version}/COPYRIGHT
  221. %{_mandir}/man8/nginx.8*
  222. %pre
  223. # Add the "nginx" user
  224. getent group %{nginx_group} >/dev/null || groupadd -r %{nginx_group}
  225. getent passwd %{nginx_user} >/dev/null || \
  226. useradd -r -g %{nginx_group} -s /sbin/nologin \
  227. -d %{nginx_home} -c "nginx user" %{nginx_user}
  228. exit 0
  229. %post
  230. # Register the nginx service
  231. if [ $1 -eq 1 ]; then
  232. %if %{use_systemd}
  233. /usr/bin/systemctl preset nginx.service >/dev/null 2>&1 ||:
  234. /usr/bin/systemctl preset nginx-debug.service >/dev/null 2>&1 ||:
  235. %else
  236. /sbin/chkconfig --add nginx
  237. /sbin/chkconfig --add nginx-debug
  238. %endif
  239. # print site info
  240. cat <<BANNER
  241. ----------------------------------------------------------------------
  242. Thanks for using nginx!
  243. Please find the official documentation for nginx here:
  244. * https://nginx.org/en/docs/
  245. Please subscribe to nginx-announce mailing list to get
  246. the most important news about nginx:
  247. * https://nginx.org/en/support.html
  248. Commercial subscriptions for nginx are available on:
  249. * https://nginx.com/products/
  250. ----------------------------------------------------------------------
  251. BANNER
  252. # Touch and set permisions on default log files on installation
  253. if [ -d %{_localstatedir}/log/nginx ]; then
  254. if [ ! -e %{_localstatedir}/log/nginx/access.log ]; then
  255. touch %{_localstatedir}/log/nginx/access.log
  256. %{__chmod} 640 %{_localstatedir}/log/nginx/access.log
  257. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/access.log
  258. fi
  259. if [ ! -e %{_localstatedir}/log/nginx/error.log ]; then
  260. touch %{_localstatedir}/log/nginx/error.log
  261. %{__chmod} 640 %{_localstatedir}/log/nginx/error.log
  262. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/error.log
  263. fi
  264. fi
  265. fi
  266. %preun
  267. if [ $1 -eq 0 ]; then
  268. %if %use_systemd
  269. /usr/bin/systemctl --no-reload disable nginx.service >/dev/null 2>&1 ||:
  270. /usr/bin/systemctl stop nginx.service >/dev/null 2>&1 ||:
  271. %else
  272. /sbin/service nginx stop > /dev/null 2>&1
  273. /sbin/chkconfig --del nginx
  274. /sbin/chkconfig --del nginx-debug
  275. %endif
  276. fi
  277. %postun
  278. %if %use_systemd
  279. /usr/bin/systemctl daemon-reload >/dev/null 2>&1 ||:
  280. %endif
  281. if [ $1 -ge 1 ]; then
  282. /sbin/service nginx status >/dev/null 2>&1 || exit 0
  283. /sbin/service nginx upgrade >/dev/null 2>&1 || echo \
  284. "Binary upgrade failed, please check nginx's error.log"
  285. fi
  286. %changelog
  287. * Tue Apr 13 2021 Andrei Belov <defan@nginx.com> - 1.19.10-1%{?dist}.ngx
  288. - 1.19.10-1
  289. * Tue Mar 30 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.9-1%{?dist}.ngx
  290. - 1.19.9-1
  291. * Tue Mar 9 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.8-1%{?dist}.ngx
  292. - 1.19.8-1
  293. * Tue Feb 16 2021 Konstantin Pavlov <thresh@nginx.com> - 1.19.7-1%{?dist}.ngx
  294. - 1.19.7-1
  295. * Tue Dec 15 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.6-1%{?dist}.ngx
  296. - 1.19.6-1
  297. * Tue Nov 24 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.5-1%{?dist}.ngx
  298. - 1.19.5-1
  299. * Tue Oct 27 2020 Andrei Belov <defan@nginx.com> - 1.19.4-1%{?dist}.ngx
  300. - 1.19.4-1
  301. * Tue Sep 29 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.3-1%{?dist}.ngx
  302. - 1.19.3
  303. * Tue Aug 11 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.2-1%{?dist}.ngx
  304. - 1.19.2
  305. * Tue Jul 7 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.1-1%{?dist}.ngx
  306. - 1.19.1
  307. * Tue May 26 2020 Konstantin Pavlov <thresh@nginx.com> - 1.19.0-1%{?dist}.ngx
  308. - 1.19.0
  309. * Tue Apr 14 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.10-1%{?dist}.ngx
  310. - 1.17.10
  311. * Tue Mar 3 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.9-1%{?dist}.ngx
  312. - 1.17.9
  313. * Tue Jan 21 2020 Konstantin Pavlov <thresh@nginx.com> - 1.17.8-1%{?dist}.ngx
  314. - 1.17.8
  315. * Tue Dec 24 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.7-1%{?dist}.ngx
  316. - 1.17.7
  317. * Tue Nov 19 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.6-1%{?dist}.ngx
  318. - 1.17.6
  319. * Tue Oct 22 2019 Andrei Belov <defan@nginx.com> - 1.17.5-1%{?dist}.ngx
  320. - 1.17.5
  321. * Tue Sep 24 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.4-1%{?dist}.ngx
  322. - 1.17.4
  323. * Tue Aug 13 2019 Andrei Belov <defan@nginx.com> - 1.17.3-1%{?dist}.ngx
  324. - 1.17.3
  325. * Tue Jul 23 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.2-1%{?dist}.ngx
  326. - 1.17.2
  327. * Tue Jun 25 2019 Andrei Belov <defan@nginx.com> - 1.17.1-1%{?dist}.ngx
  328. - 1.17.1
  329. * Tue May 21 2019 Konstantin Pavlov <thresh@nginx.com> - 1.17.0-1%{?dist}.ngx
  330. - 1.17.0
  331. * Tue Apr 16 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.12-1%{?dist}.ngx
  332. - 1.15.12
  333. * Tue Apr 9 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.11-1%{?dist}.ngx
  334. - 1.15.11
  335. * Tue Mar 26 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.10-1%{?dist}.ngx
  336. - 1.15.10
  337. * Tue Feb 26 2019 Konstantin Pavlov <thresh@nginx.com> - 1.15.9-1%{?dist}.ngx
  338. - 1.15.9
  339. * Tue Dec 25 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.8-1%{?dist}.ngx
  340. - 1.15.8
  341. * Tue Nov 27 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.7-1%{?dist}.ngx
  342. - 1.15.7
  343. * Tue Nov 6 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.6-1%{?dist}.ngx
  344. - 1.15.6
  345. - Security: fixes CVE-2018-16843.
  346. - Security: fixes CVE-2018-16844.
  347. - Security: fixes CVE-2018-16845.
  348. * Tue Oct 2 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.5-1%{?dist}.ngx
  349. - 1.15.5
  350. * Tue Sep 25 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.4-1%{?dist}.ngx
  351. - 1.15.4
  352. * Tue Aug 28 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.3-1%{?dist}.ngx
  353. - 1.15.3
  354. * Tue Jul 24 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.2-1%{?dist}.ngx
  355. - 1.15.2
  356. * Tue Jul 3 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.1-1%{?dist}.ngx
  357. - 1.15.1
  358. * Tue Jun 5 2018 Konstantin Pavlov <thresh@nginx.com> - 1.15.0-1%{?dist}.ngx
  359. - 1.15.0
  360. * Mon Apr 9 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.12-1%{?dist}.ngx
  361. - 1.13.12
  362. * Tue Apr 3 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.11-1%{?dist}.ngx
  363. - 1.13.11
  364. * Tue Mar 20 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.10-1%{?dist}.ngx
  365. - 1.13.10
  366. * Tue Feb 20 2018 Konstantin Pavlov <thresh@nginx.com> - 1.13.9-1%{?dist}.ngx
  367. - 1.13.9
  368. * Tue Dec 26 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.8-1%{?dist}.ngx
  369. - 1.13.8
  370. * Tue Nov 21 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.7-1%{?dist}.ngx
  371. - 1.13.7
  372. * Thu Sep 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.6-1%{?dist}.ngx
  373. - 1.13.6
  374. - Bugfix: in systemd service support
  375. (https://trac.nginx.org/nginx/ticket/1380).
  376. * Thu Sep 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.5-1%{?dist}.ngx
  377. - 1.13.5
  378. * Tue Aug 8 2017 Sergey Budnevitch <sb@nginx.com> - 1.13.4-1%{?dist}.ngx
  379. - 1.13.4
  380. * Tue Jul 11 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.3-1%{?dist}.ngx
  381. - 1.13.3
  382. - Security: fixes CVE-2017-7529.
  383. * Tue Jun 27 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.2-1%{?dist}.ngx
  384. - 1.13.2
  385. * Tue May 30 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.1-1%{?dist}.ngx
  386. - 1.13.1
  387. * Tue Apr 25 2017 Konstantin Pavlov <thresh@nginx.com> - 1.13.0-1%{?dist}.ngx
  388. - 1.13.0
  389. * Tue Apr 4 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.13-1%{?dist}.ngx
  390. - 1.11.13
  391. - Made upgrade loops/timeouts configurable via /etc/defaults/nginx.
  392. * Fri Mar 24 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.12-1%{?dist}.ngx
  393. - 1.11.12
  394. * Tue Mar 21 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.11-1%{?dist}.ngx
  395. - 1.11.11
  396. * Tue Feb 14 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.10-1%{?dist}.ngx
  397. - 1.11.10
  398. * Tue Jan 24 2017 Konstantin Pavlov <thresh@nginx.com> - 1.11.9-1%{?dist}.ngx
  399. - 1.11.9
  400. - Extended hardening build flags.
  401. - Added check-reload target to init script / systemd service.
  402. * Tue Dec 27 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.8-1%{?dist}.ngx
  403. - 1.11.8
  404. * Tue Dec 13 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.7-1%{?dist}.ngx
  405. - 1.11.7
  406. * Fri Nov 25 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.6-1%{?dist}.ngx
  407. - 1.11.6
  408. * Mon Oct 10 2016 Andrei Belov <defan@nginx.com> - 1.11.5-1%{?dist}.ngx
  409. - 1.11.5
  410. * Tue Sep 13 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.4-1%{?dist}.ngx
  411. - 1.11.4
  412. - njs updated to 0.1.2.
  413. * Tue Jul 26 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.3-1%{?dist}.ngx
  414. - 1.11.3
  415. - njs updated to 0.1.0.
  416. - njs stream dynamic module added to nginx-module-njs package.
  417. - geoip stream dynamic module added to nginx-module-geoip package.
  418. * Tue Jul 5 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.2-1%{?dist}.ngx
  419. - 1.11.2
  420. - njs updated to ef2b708510b1.
  421. * Tue May 31 2016 Konstantin Pavlov <thresh@nginx.com> - 1.11.1-1%{?dist}.ngx
  422. - 1.11.1
  423. * Tue May 24 2016 Sergey Budnevitch <sb@nginx.com> - 1.11.0-1%{?dist}.ngx
  424. - 1.11.0
  425. - Bugfix: fixed logrotate error if nginx is not running.
  426. * Tue Apr 19 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.15-1%{?dist}.ngx
  427. - 1.9.15
  428. - njs updated to 1c50334fbea6.
  429. * Tue Apr 5 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.14-1%{?dist}.ngx
  430. - 1.9.14
  431. * Tue Mar 29 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.13-1%{?dist}.ngx
  432. - 1.9.13
  433. - Fixed modules path
  434. - Added perl and njs dynamic modules subpackages
  435. * Wed Feb 24 2016 Sergey Budnevitch <sb@nginx.com> - 1.9.12-1%{?dist}.ngx
  436. - 1.9.12
  437. - common configure args are now in variable
  438. - xslt, image-filter and geoip dynamic modules added
  439. * Tue Feb 9 2016 Sergey Budnevitch <sb@nginx.com> - 1.9.11-1%{?dist}.ngx
  440. - 1.9.11
  441. - dynamic modules path and symlink in /etc/nginx added
  442. * Tue Jan 26 2016 Konstantin Pavlov <thresh@nginx.com> - 1.9.10-1%{?dist}.ngx
  443. - 1.9.10
  444. * Wed Dec 9 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.9-1%{?dist}.ngx
  445. - 1.9.9
  446. * Tue Dec 8 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.8-1%{?dist}.ngx
  447. - 1.9.8
  448. - http_slice module enabled
  449. * Tue Nov 17 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.7-1%{?dist}.ngx
  450. - 1.9.7
  451. * Tue Oct 27 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.6-1%{?dist}.ngx
  452. - 1.9.6
  453. * Tue Sep 22 2015 Andrei Belov <defan@nginx.com> - 1.9.5-1%{?dist}.ngx
  454. - 1.9.5
  455. - http_spdy module replaced with http_v2 module
  456. * Tue Aug 18 2015 Konstantin Pavlov <thresh@nginx.com> - 1.9.4-1%{?dist}.ngx
  457. - 1.9.4
  458. * Tue Jul 14 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.3-1%{?dist}.ngx
  459. - 1.9.3
  460. * Tue Jun 16 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.2-1%{?dist}.ngx
  461. - 1.9.2
  462. * Tue May 26 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.1-1%{?dist}.ngx
  463. - 1.9.1
  464. * Tue Apr 28 2015 Sergey Budnevitch <sb@nginx.com> - 1.9.0-1%{?dist}.ngx
  465. - 1.9.0
  466. - thread pool support added
  467. - stream module added
  468. - example_ssl.conf removed
  469. * Tue Apr 7 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.12-1%{?dist}.ngx
  470. - 1.7.12
  471. * Tue Mar 24 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.11-1%{?dist}.ngx
  472. - 1.7.11
  473. * Tue Feb 10 2015 Sergey Budnevitch <sb@nginx.com> - 1.7.10-1%{?dist}.ngx
  474. - 1.7.10
  475. * Tue Dec 23 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.9-1%{?dist}.ngx
  476. - 1.7.9
  477. - init-script now sends signal only to the PID derived from pidfile
  478. * Tue Dec 2 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.8-1%{?dist}.ngx
  479. - 1.7.8
  480. - package with debug symbols added
  481. * Tue Oct 28 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.7-1%{?dist}.ngx
  482. - 1.7.7
  483. * Tue Sep 30 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.6-1%{?dist}.ngx
  484. - 1.7.6
  485. * Tue Sep 16 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.5-1%{?dist}.ngx
  486. - 1.7.5
  487. * Tue Aug 5 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.4-1%{?dist}.ngx
  488. - 1.7.4
  489. - init-script now returns 0 on stop command if nginx is not running
  490. * Tue Jul 8 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.3-1%{?dist}.ngx
  491. - 1.7.3
  492. * Tue Jun 17 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.2-1%{?dist}.ngx
  493. - 1.7.2
  494. * Tue May 27 2014 Sergey Budnevitch <sb@nginx.com> - 1.7.1-1%{?dist}.ngx
  495. - 1.7.1
  496. * Thu Apr 24 2014 Konstantin Pavlov <thresh@nginx.com> - 1.7.0-1%{?dist}.ngx
  497. - 1.7.0
  498. * Tue Apr 8 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.13-1%{?dist}.ngx
  499. - 1.5.13
  500. * Tue Mar 18 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.12-1%{?dist}.ngx
  501. - 1.5.12
  502. - warning added when binary upgrade returns non-zero exit code
  503. * Tue Mar 4 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.11-1%{?dist}.ngx
  504. - 1.5.11
  505. * Tue Feb 4 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.10-1%{?dist}.ngx
  506. - 1.5.10
  507. * Wed Jan 22 2014 Sergey Budnevitch <sb@nginx.com> - 1.5.9-1%{?dist}.ngx
  508. - 1.5.9
  509. * Tue Dec 17 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.8-1%{?dist}.ngx
  510. - 1.5.8
  511. * Fri Nov 29 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.7-1%{?dist}.ngx
  512. - 1.5.7
  513. - init script now honours additional options sourced from /etc/default/nginx
  514. * Tue Oct 1 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.6-1%{?dist}.ngx
  515. - 1.5.6
  516. * Tue Sep 17 2013 Andrei Belov <defan@nginx.com> - 1.5.5-1%{?dist}.ngx
  517. - 1.5.5
  518. * Tue Aug 27 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.4-1%{?dist}.ngx
  519. - 1.5.4
  520. - auth request module added
  521. * Tue Jul 30 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.3-1%{?dist}.ngx
  522. - 1.5.3
  523. * Tue Jul 2 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.2-1%{?dist}.ngx
  524. - 1.5.2
  525. * Tue Jun 4 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.1-1%{?dist}.ngx
  526. - 1.5.1
  527. - dpkg-buildflags options now passed by --with-{cc,ld}-opt
  528. * Mon May 6 2013 Sergey Budnevitch <sb@nginx.com> - 1.5.0-1%{?dist}.ngx
  529. - 1.5.0
  530. - fixed openssl version detection with dash as /bin/sh
  531. * Tue Apr 16 2013 Sergey Budnevitch <sb@nginx.com> - 1.3.16-1%{?dist}.ngx
  532. - 1.3.16
  533. * Tue Mar 26 2013 Sergey Budnevitch <sb@nginx.com> - 1.3.15-1%{?dist}.ngx
  534. - 1.3.15
  535. - gunzip module added
  536. - spdy module added if openssl version >= 1.0.1
  537. - set permissions on default log files at installation