nginx.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742
  1. #
  2. %define nginx_home %{_localstatedir}/cache/nginx
  3. %define nginx_user nginx
  4. %define nginx_group nginx
  5. %define nginx_loggroup adm
  6. # distribution specific definitions
  7. %define use_systemd (0%{?rhel} >= 7 || 0%{?fedora} >= 19 || 0%{?suse_version} >= 1315 || 0%{?amzn} >= 2)
  8. %if %{use_systemd}
  9. BuildRequires: systemd
  10. Requires(post): systemd
  11. Requires(preun): systemd
  12. Requires(postun): systemd
  13. %endif
  14. %if 0%{?rhel}
  15. %define _group System Environment/Daemons
  16. %endif
  17. %if 0%{?rhel} == 6
  18. Requires(pre): shadow-utils
  19. Requires: initscripts >= 8.36
  20. Requires(post): chkconfig
  21. Requires: openssl >= 1.0.1
  22. BuildRequires: openssl-devel >= 1.0.1
  23. %endif
  24. %if 0%{?rhel} == 7
  25. %define epoch 1
  26. Epoch: %{epoch}
  27. Requires(pre): shadow-utils
  28. Requires: openssl >= 1.0.2
  29. BuildRequires: openssl-devel >= 1.0.2
  30. %define dist .el7
  31. %endif
  32. %if 0%{?rhel} == 8
  33. %define epoch 1
  34. Epoch: %{epoch}
  35. Requires(pre): shadow-utils
  36. BuildRequires: openssl-devel >= 1.1.1
  37. %define _debugsource_template %{nil}
  38. %endif
  39. %if 0%{?suse_version} >= 1315
  40. %define _group Productivity/Networking/Web/Servers
  41. %define nginx_loggroup trusted
  42. Requires(pre): shadow
  43. BuildRequires: libopenssl-devel
  44. %define _debugsource_template %{nil}
  45. %endif
  46. %if 0%{?fedora}
  47. %define _debugsource_template %{nil}
  48. %global _hardened_build 1
  49. %define _group System Environment/Daemons
  50. BuildRequires: openssl-devel
  51. Requires(pre): shadow-utils
  52. %endif
  53. # end of distribution specific definitions
  54. %define openssl_version 1.1.1g
  55. %define main_version 1.19.2
  56. %define main_release 1%{?dist}.ngx
  57. %define bdir %{_builddir}/%{name}-%{main_version}
  58. %define WITH_CC_OPT $(echo %{optflags} $(pcre-config --cflags)) -fPIC
  59. %define WITH_LD_OPT -Wl,-z,relro -Wl,-z,now -pie
  60. %define BASE_CONFIGURE_ARGS $(echo "--prefix=%{_sysconfdir}/nginx --sbin-path=%{_sbindir}/nginx --modules-path=%{_libdir}/nginx/modules --conf-path=%{_sysconfdir}/nginx/nginx.conf --error-log-path=%{_localstatedir}/log/nginx/error.log --http-log-path=%{_localstatedir}/log/nginx/access.log --pid-path=%{_localstatedir}/run/nginx.pid --lock-path=%{_localstatedir}/run/nginx.lock --http-client-body-temp-path=%{_localstatedir}/cache/nginx/client_temp --http-proxy-temp-path=%{_localstatedir}/cache/nginx/proxy_temp --http-fastcgi-temp-path=%{_localstatedir}/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=%{_localstatedir}/cache/nginx/uwsgi_temp --http-scgi-temp-path=%{_localstatedir}/cache/nginx/scgi_temp --user=%{nginx_user} --group=%{nginx_group} --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module")
  61. Summary: High performance web server
  62. Name: nginx
  63. Version: %{main_version}
  64. Release: %{main_release}
  65. Vendor: Nginx, Inc.
  66. URL: http://nginx.org/
  67. Group: %{_group}
  68. Source0: https://nginx.org/download/%{name}-%{version}.tar.gz
  69. Source1: logrotate
  70. Source2: nginx.init.in
  71. Source3: nginx.sysconf
  72. Source4: nginx.conf
  73. Source5: nginx.vh.default.conf
  74. Source7: nginx-debug.sysconf
  75. Source8: nginx.service
  76. Source9: nginx.upgrade.sh
  77. Source10: nginx.suse.logrotate
  78. Source11: nginx-debug.service
  79. Source12: COPYRIGHT
  80. Source13: nginx.check-reload.sh
  81. Source14: https://www.openssl.org/source/openssl-%{openssl_version}.tar.gz
  82. License: 2-clause BSD-like license
  83. BuildRoot: %{_tmppath}/%{name}-%{main_version}-%{main_release}-root
  84. BuildRequires: zlib-devel
  85. BuildRequires: pcre-devel
  86. Provides: webserver
  87. %description
  88. nginx [engine x] is an HTTP and reverse proxy server, as well as
  89. a mail proxy server.
  90. %if 0%{?suse_version} >= 1315
  91. %debug_package
  92. %endif
  93. %prep
  94. %setup -q
  95. cp %{SOURCE2} .
  96. sed -e 's|%%DEFAULTSTART%%|2 3 4 5|g' -e 's|%%DEFAULTSTOP%%|0 1 6|g' \
  97. -e 's|%%PROVIDES%%|nginx|g' < %{SOURCE2} > nginx.init
  98. sed -e 's|%%DEFAULTSTART%%||g' -e 's|%%DEFAULTSTOP%%|0 1 2 3 4 5 6|g' \
  99. -e 's|%%PROVIDES%%|nginx-debug|g' < %{SOURCE2} > nginx-debug.init
  100. tar -zxf %{SOURCE14}
  101. %build
  102. ./configure %{BASE_CONFIGURE_ARGS} \
  103. --with-openssl=./openssl-%{openssl_version}/ \
  104. --with-cc-opt="%{WITH_CC_OPT}" \
  105. --with-ld-opt="%{WITH_LD_OPT}" \
  106. --with-debug
  107. make %{?_smp_mflags}
  108. %{__mv} %{bdir}/objs/nginx \
  109. %{bdir}/objs/nginx-debug
  110. ./configure %{BASE_CONFIGURE_ARGS} \
  111. --with-openssl=./openssl-%{openssl_version}/ \
  112. --with-cc-opt="%{WITH_CC_OPT}" \
  113. --with-ld-opt="%{WITH_LD_OPT}"
  114. make %{?_smp_mflags}
  115. %install
  116. %{__rm} -rf $RPM_BUILD_ROOT
  117. %{__make} DESTDIR=$RPM_BUILD_ROOT INSTALLDIRS=vendor install
  118. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/nginx
  119. %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/html $RPM_BUILD_ROOT%{_datadir}/nginx/
  120. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/*.default
  121. %{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/nginx/fastcgi.conf
  122. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/log/nginx
  123. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/run/nginx
  124. %{__mkdir} -p $RPM_BUILD_ROOT%{_localstatedir}/cache/nginx
  125. %{__mkdir} -p $RPM_BUILD_ROOT%{_libdir}/nginx/modules
  126. cd $RPM_BUILD_ROOT%{_sysconfdir}/nginx && \
  127. %{__ln_s} ../..%{_libdir}/nginx/modules modules && cd -
  128. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{main_version}
  129. %{__install} -m 644 -p %{SOURCE12} \
  130. $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{main_version}/
  131. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d
  132. %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  133. %{__install} -m 644 -p %{SOURCE4} \
  134. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/nginx.conf
  135. %{__install} -m 644 -p %{SOURCE5} \
  136. $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d/default.conf
  137. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  138. %{__install} -m 644 -p %{SOURCE3} \
  139. $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/nginx
  140. %{__install} -m 644 -p %{SOURCE7} \
  141. $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/nginx-debug
  142. %{__install} -p -D -m 0644 %{bdir}/objs/nginx.8 \
  143. $RPM_BUILD_ROOT%{_mandir}/man8/nginx.8
  144. %if %{use_systemd}
  145. # install systemd-specific files
  146. %{__mkdir} -p $RPM_BUILD_ROOT%{_unitdir}
  147. %{__install} -m644 %SOURCE8 \
  148. $RPM_BUILD_ROOT%{_unitdir}/nginx.service
  149. %{__install} -m644 %SOURCE11 \
  150. $RPM_BUILD_ROOT%{_unitdir}/nginx-debug.service
  151. %{__mkdir} -p $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx
  152. %{__install} -m755 %SOURCE9 \
  153. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/upgrade
  154. %{__install} -m755 %SOURCE13 \
  155. $RPM_BUILD_ROOT%{_libexecdir}/initscripts/legacy-actions/nginx/check-reload
  156. %else
  157. # install SYSV init stuff
  158. %{__mkdir} -p $RPM_BUILD_ROOT%{_initrddir}
  159. %{__install} -m755 nginx.init $RPM_BUILD_ROOT%{_initrddir}/nginx
  160. %{__install} -m755 nginx-debug.init $RPM_BUILD_ROOT%{_initrddir}/nginx-debug
  161. %endif
  162. # install log rotation stuff
  163. %{__mkdir} -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
  164. %if 0%{?suse_version}
  165. %{__install} -m 644 -p %{SOURCE10} \
  166. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  167. %else
  168. %{__install} -m 644 -p %{SOURCE1} \
  169. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/nginx
  170. %endif
  171. %{__install} -m755 %{bdir}/objs/nginx-debug \
  172. $RPM_BUILD_ROOT%{_sbindir}/nginx-debug
  173. %check
  174. %{__rm} -rf $RPM_BUILD_ROOT/usr/src
  175. cd %{bdir}
  176. grep -v 'usr/src' debugfiles.list > debugfiles.list.new && mv debugfiles.list.new debugfiles.list
  177. cat /dev/null > debugsources.list
  178. %if 0%{?suse_version} >= 1500
  179. cat /dev/null > debugsourcefiles.list
  180. %endif
  181. %clean
  182. %{__rm} -rf $RPM_BUILD_ROOT
  183. %files
  184. %defattr(-,root,root)
  185. %{_sbindir}/nginx
  186. %{_sbindir}/nginx-debug
  187. %dir %{_sysconfdir}/nginx
  188. %dir %{_sysconfdir}/nginx/conf.d
  189. %{_sysconfdir}/nginx/modules
  190. %config(noreplace) %{_sysconfdir}/nginx/nginx.conf
  191. %config(noreplace) %{_sysconfdir}/nginx/conf.d/default.conf
  192. %config(noreplace) %{_sysconfdir}/nginx/mime.types
  193. %config(noreplace) %{_sysconfdir}/nginx/fastcgi_params
  194. %config(noreplace) %{_sysconfdir}/nginx/scgi_params
  195. %config(noreplace) %{_sysconfdir}/nginx/uwsgi_params
  196. %config(noreplace) %{_sysconfdir}/nginx/koi-utf
  197. %config(noreplace) %{_sysconfdir}/nginx/koi-win
  198. %config(noreplace) %{_sysconfdir}/nginx/win-utf
  199. %config(noreplace) %{_sysconfdir}/logrotate.d/nginx
  200. %config(noreplace) %{_sysconfdir}/sysconfig/nginx
  201. %config(noreplace) %{_sysconfdir}/sysconfig/nginx-debug
  202. %if %{use_systemd}
  203. %{_unitdir}/nginx.service
  204. %{_unitdir}/nginx-debug.service
  205. %dir %{_libexecdir}/initscripts/legacy-actions/nginx
  206. %{_libexecdir}/initscripts/legacy-actions/nginx/*
  207. %else
  208. %{_initrddir}/nginx
  209. %{_initrddir}/nginx-debug
  210. %endif
  211. %attr(0755,root,root) %dir %{_libdir}/nginx
  212. %attr(0755,root,root) %dir %{_libdir}/nginx/modules
  213. %dir %{_datadir}/nginx
  214. %dir %{_datadir}/nginx/html
  215. %{_datadir}/nginx/html/*
  216. %attr(0755,root,root) %dir %{_localstatedir}/cache/nginx
  217. %attr(0755,root,root) %dir %{_localstatedir}/log/nginx
  218. %dir %{_datadir}/doc/%{name}-%{main_version}
  219. %doc %{_datadir}/doc/%{name}-%{main_version}/COPYRIGHT
  220. %{_mandir}/man8/nginx.8*
  221. %pre
  222. # Add the "nginx" user
  223. getent group %{nginx_group} >/dev/null || groupadd -r %{nginx_group}
  224. getent passwd %{nginx_user} >/dev/null || \
  225. useradd -r -g %{nginx_group} -s /sbin/nologin \
  226. -d %{nginx_home} -c "nginx user" %{nginx_user}
  227. exit 0
  228. %post
  229. # Register the nginx service
  230. if [ $1 -eq 1 ]; then
  231. %if %{use_systemd}
  232. /usr/bin/systemctl preset nginx.service >/dev/null 2>&1 ||:
  233. /usr/bin/systemctl preset nginx-debug.service >/dev/null 2>&1 ||:
  234. %else
  235. /sbin/chkconfig --add nginx
  236. /sbin/chkconfig --add nginx-debug
  237. %endif
  238. # print site info
  239. cat <<BANNER
  240. ----------------------------------------------------------------------
  241. Thanks for using nginx!
  242. Please find the official documentation for nginx here:
  243. * http://nginx.org/en/docs/
  244. Please subscribe to nginx-announce mailing list to get
  245. the most important news about nginx:
  246. * http://nginx.org/en/support.html
  247. Commercial subscriptions for nginx are available on:
  248. * http://nginx.com/products/
  249. ----------------------------------------------------------------------
  250. BANNER
  251. # Touch and set permisions on default log files on installation
  252. if [ -d %{_localstatedir}/log/nginx ]; then
  253. if [ ! -e %{_localstatedir}/log/nginx/access.log ]; then
  254. touch %{_localstatedir}/log/nginx/access.log
  255. %{__chmod} 640 %{_localstatedir}/log/nginx/access.log
  256. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/access.log
  257. fi
  258. if [ ! -e %{_localstatedir}/log/nginx/error.log ]; then
  259. touch %{_localstatedir}/log/nginx/error.log
  260. %{__chmod} 640 %{_localstatedir}/log/nginx/error.log
  261. %{__chown} nginx:%{nginx_loggroup} %{_localstatedir}/log/nginx/error.log
  262. fi
  263. fi
  264. fi
  265. %preun
  266. if [ $1 -eq 0 ]; then
  267. %if %use_systemd
  268. /usr/bin/systemctl --no-reload disable nginx.service >/dev/null 2>&1 ||:
  269. /usr/bin/systemctl stop nginx.service >/dev/null 2>&1 ||:
  270. %else
  271. /sbin/service nginx stop > /dev/null 2>&1
  272. /sbin/chkconfig --del nginx
  273. /sbin/chkconfig --del nginx-debug
  274. %endif
  275. fi
  276. %postun
  277. %if %use_systemd
  278. /usr/bin/systemctl daemon-reload >/dev/null 2>&1 ||:
  279. %endif
  280. if [ $1 -ge 1 ]; then
  281. /sbin/service nginx status >/dev/null 2>&1 || exit 0
  282. /sbin/service nginx upgrade >/dev/null 2>&1 || echo \
  283. "Binary upgrade failed, please check nginx's error.log"
  284. fi
  285. %changelog
  286. * Tue Aug 11 2020 Konstantin Pavlov <thresh@nginx.com>
  287. - 1.19.2
  288. * Tue Jul 07 2020 Konstantin Pavlov <thresh@nginx.com>
  289. - 1.19.1
  290. * Tue May 26 2020 Konstantin Pavlov <thresh@nginx.com>
  291. - 1.19.0
  292. * Tue Apr 14 2020 Konstantin Pavlov <thresh@nginx.com>
  293. - 1.17.10
  294. * Tue Mar 03 2020 Konstantin Pavlov <thresh@nginx.com>
  295. - 1.17.9
  296. * Tue Jan 21 2020 Konstantin Pavlov <thresh@nginx.com>
  297. - 1.17.8
  298. * Tue Dec 24 2019 Konstantin Pavlov <thresh@nginx.com>
  299. - 1.17.7
  300. * Tue Nov 19 2019 Konstantin Pavlov <thresh@nginx.com>
  301. - 1.17.6
  302. * Tue Oct 22 2019 Andrei Belov <defan@nginx.com>
  303. - 1.17.5
  304. * Tue Sep 24 2019 Konstantin Pavlov <thresh@nginx.com>
  305. - 1.17.4
  306. * Tue Aug 13 2019 Andrei Belov <defan@nginx.com>
  307. - 1.17.3
  308. * Tue Jul 23 2019 Konstantin Pavlov <thresh@nginx.com>
  309. - 1.17.2
  310. * Tue Jun 25 2019 Andrei Belov <defan@nginx.com>
  311. - 1.17.1
  312. * Tue May 21 2019 Konstantin Pavlov <thresh@nginx.com>
  313. - 1.17.0
  314. * Tue Apr 16 2019 Konstantin Pavlov <thresh@nginx.com>
  315. - 1.15.12
  316. * Tue Apr 09 2019 Konstantin Pavlov <thresh@nginx.com>
  317. - 1.15.11
  318. * Tue Mar 26 2019 Konstantin Pavlov <thresh@nginx.com>
  319. - 1.15.10
  320. * Tue Feb 26 2019 Konstantin Pavlov <thresh@nginx.com>
  321. - 1.15.9
  322. * Tue Dec 25 2018 Konstantin Pavlov <thresh@nginx.com>
  323. - 1.15.8
  324. * Tue Nov 27 2018 Konstantin Pavlov <thresh@nginx.com>
  325. - 1.15.7
  326. * Tue Nov 06 2018 Konstantin Pavlov <thresh@nginx.com>
  327. - 1.15.6
  328. - Fixes CVE-2018-16843
  329. - Fixes CVE-2018-16844
  330. - Fixes CVE-2018-16845
  331. * Tue Oct 02 2018 Konstantin Pavlov <thresh@nginx.com>
  332. - 1.15.5
  333. * Tue Sep 25 2018 Konstantin Pavlov <thresh@nginx.com>
  334. - 1.15.4
  335. * Tue Aug 28 2018 Konstantin Pavlov <thresh@nginx.com>
  336. - 1.15.3
  337. * Tue Jul 24 2018 Konstantin Pavlov <thresh@nginx.com>
  338. - 1.15.2
  339. * Tue Jul 03 2018 Konstantin Pavlov <thresh@nginx.com>
  340. - 1.15.1
  341. * Tue Jun 05 2018 Konstantin Pavlov <thresh@nginx.com>
  342. - 1.15.0
  343. * Mon Apr 09 2018 Konstantin Pavlov <thresh@nginx.com>
  344. - 1.13.12
  345. * Tue Apr 03 2018 Konstantin Pavlov <thresh@nginx.com>
  346. - 1.13.11
  347. * Tue Mar 20 2018 Konstantin Pavlov <thresh@nginx.com>
  348. - 1.13.10
  349. * Tue Feb 20 2018 Konstantin Pavlov <thresh@nginx.com>
  350. - 1.13.9
  351. * Tue Dec 26 2017 Konstantin Pavlov <thresh@nginx.com>
  352. - 1.13.8
  353. * Tue Nov 21 2017 Konstantin Pavlov <thresh@nginx.com>
  354. - 1.13.7
  355. * Tue Oct 10 2017 Konstantin Pavlov <thresh@nginx.com>
  356. - 1.13.6
  357. * Tue Sep 5 2017 Konstantin Pavlov <thresh@nginx.com>
  358. - 1.13.5
  359. * Tue Aug 8 2017 Sergey Budnevitch <sb@nginx.com>
  360. - 1.13.4
  361. * Tue Jul 11 2017 Konstantin Pavlov <thresh@nginx.com>
  362. - 1.13.3
  363. - Fixes CVE-2017-7529
  364. * Tue Jun 27 2017 Konstantin Pavlov <thresh@nginx.com>
  365. - 1.13.2
  366. * Tue May 30 2017 Konstantin Pavlov <thresh@nginx.com>
  367. - 1.13.1
  368. * Tue Apr 25 2017 Konstantin Pavlov <thresh@nginx.com>
  369. - 1.13.0
  370. * Tue Apr 4 2017 Konstantin Pavlov <thresh@nginx.com>
  371. - 1.11.13
  372. - CentOS7/RHEL7: made upgrade loops/timeouts configurable via
  373. /etc/sysconfig/nginx.
  374. - Bumped upgrade defaults to five loops one second each.
  375. * Fri Mar 24 2017 Konstantin Pavlov <thresh@nginx.com>
  376. - 1.11.12
  377. * Tue Mar 21 2017 Konstantin Pavlov <thresh@nginx.com>
  378. - 1.11.11
  379. * Tue Feb 14 2017 Konstantin Pavlov <thresh@nginx.com>
  380. - 1.11.10
  381. * Tue Jan 24 2017 Konstantin Pavlov <thresh@nginx.com>
  382. - 1.11.9
  383. - Extended hardening build flags.
  384. - Added check-reload target to init script / systemd service.
  385. * Tue Dec 27 2016 Konstantin Pavlov <thresh@nginx.com>
  386. - 1.11.8
  387. * Tue Dec 13 2016 Konstantin Pavlov <thresh@nginx.com>
  388. - 1.11.7
  389. * Tue Nov 15 2016 Konstantin Pavlov <thresh@nginx.com>
  390. - 1.11.6
  391. * Mon Oct 10 2016 Andrei Belov <defan@nginx.com>
  392. - 1.11.5
  393. * Tue Sep 13 2016 Konstantin Pavlov <thresh@nginx.com>
  394. - 1.11.4.
  395. - njs updated to 0.1.2.
  396. * Tue Jul 26 2016 Konstantin Pavlov <thresh@nginx.com>
  397. - 1.11.3.
  398. - njs updated to 0.1.0.
  399. - njs stream dynamic module added to nginx-module-njs package.
  400. - geoip stream dynamic module added to nginx-module-geoip package.
  401. * Tue Jul 5 2016 Konstantin Pavlov <thresh@nginx.com>
  402. - 1.11.2
  403. - njs updated to ef2b708510b1.
  404. * Tue May 31 2016 Konstantin Pavlov <thresh@nginx.com>
  405. - 1.11.1
  406. * Tue May 24 2016 Sergey Budnevitch <sb@nginx.com>
  407. - Fixed logrotate error if nginx is not running
  408. - 1.11.0
  409. * Tue Apr 19 2016 Konstantin Pavlov <thresh@nginx.com>
  410. - 1.9.15
  411. - njs updated to 1c50334fbea6.
  412. * Tue Apr 5 2016 Konstantin Pavlov <thresh@nginx.com>
  413. - 1.9.14
  414. * Tue Mar 29 2016 Konstantin Pavlov <thresh@nginx.com>
  415. - 1.9.13
  416. - Added perl and njs dynamic modules
  417. - Fixed Requires section for dynamic modules on CentOS7/RHEL7
  418. * Wed Feb 24 2016 Sergey Budnevitch <sb@nginx.com>
  419. - common configure args are now in macros
  420. - xslt, image-filter and geoip dynamic modules added
  421. - 1.9.12
  422. * Tue Feb 9 2016 Sergey Budnevitch <sb@nginx.com>
  423. - dynamic modules path and symlink in %{_sysconfdir}/nginx added
  424. - 1.9.11
  425. * Tue Jan 26 2016 Konstantin Pavlov <thresh@nginx.com>
  426. - 1.9.10
  427. * Wed Dec 9 2015 Konstantin Pavlov <thresh@nginx.com>
  428. - 1.9.9
  429. * Tue Dec 8 2015 Konstantin Pavlov <thresh@nginx.com>
  430. - 1.9.8
  431. - http_slice module enabled
  432. * Tue Nov 17 2015 Konstantin Pavlov <thresh@nginx.com>
  433. - 1.9.7
  434. * Tue Oct 27 2015 Sergey Budnevitch <sb@nginx.com>
  435. - 1.9.6
  436. * Tue Sep 22 2015 Andrei Belov <defan@nginx.com>
  437. - 1.9.5
  438. - http_spdy module replaced with http_v2 module
  439. * Tue Aug 18 2015 Konstantin Pavlov <thresh@nginx.com>
  440. - 1.9.4
  441. * Tue Jul 14 2015 Sergey Budnevitch <sb@nginx.com>
  442. - 1.9.3
  443. * Tue May 26 2015 Sergey Budnevitch <sb@nginx.com>
  444. - 1.9.1
  445. * Tue Apr 28 2015 Sergey Budnevitch <sb@nginx.com>
  446. - 1.9.0
  447. - thread pool support added
  448. - stream module added
  449. - example_ssl.conf removed
  450. * Tue Apr 7 2015 Sergey Budnevitch <sb@nginx.com>
  451. - 1.7.12
  452. * Tue Mar 24 2015 Sergey Budnevitch <sb@nginx.com>
  453. - 1.7.11
  454. * Tue Feb 10 2015 Sergey Budnevitch <sb@nginx.com>
  455. - 1.7.10
  456. * Tue Dec 23 2014 Sergey Budnevitch <sb@nginx.com>
  457. - 1.7.9
  458. * Tue Dec 2 2014 Sergey Budnevitch <sb@nginx.com>
  459. - 1.7.8
  460. * Tue Sep 30 2014 Sergey Budnevitch <sb@nginx.com>
  461. - 1.7.6
  462. * Tue Sep 16 2014 Sergey Budnevitch <sb@nginx.com>
  463. - epoch added to the EPEL7/CentOS7 spec to override EPEL one
  464. - 1.7.5
  465. * Tue Aug 5 2014 Sergey Budnevitch <sb@nginx.com>
  466. - 1.7.4
  467. * Tue Jul 8 2014 Sergey Budnevitch <sb@nginx.com>
  468. - 1.7.3
  469. * Tue Jun 17 2014 Sergey Budnevitch <sb@nginx.com>
  470. - 1.7.2
  471. * Tue May 27 2014 Sergey Budnevitch <sb@nginx.com>
  472. - 1.7.1
  473. - incorrect sysconfig filename finding in the initscript fixed
  474. * Thu Apr 24 2014 Konstantin Pavlov <thresh@nginx.com>
  475. - 1.7.0
  476. * Tue Apr 8 2014 Sergey Budnevitch <sb@nginx.com>
  477. - 1.5.13
  478. - built spdy module on rhel/centos 6
  479. * Tue Mar 18 2014 Sergey Budnevitch <sb@nginx.com>
  480. - 1.5.12
  481. - spec cleanup
  482. - openssl version dependence added
  483. - upgrade() function in the init script improved
  484. - warning added when binary upgrade returns non-zero exit code
  485. * Tue Mar 4 2014 Sergey Budnevitch <sb@nginx.com>
  486. - 1.5.11
  487. * Tue Feb 4 2014 Sergey Budnevitch <sb@nginx.com>
  488. - 1.5.10
  489. * Wed Jan 22 2014 Sergey Budnevitch <sb@nginx.com>
  490. - 1.5.9
  491. * Tue Dec 17 2013 Sergey Budnevitch <sb@nginx.com>
  492. - 1.5.8
  493. - fixed invalid week days in the changelog
  494. * Tue Nov 19 2013 Sergey Budnevitch <sb@nginx.com>
  495. - 1.5.7
  496. * Tue Oct 1 2013 Sergey Budnevitch <sb@nginx.com>
  497. - 1.5.6
  498. * Tue Sep 17 2013 Andrei Belov <defan@nginx.com>
  499. - 1.5.5
  500. * Tue Aug 27 2013 Sergey Budnevitch <sb@nginx.com>
  501. - 1.5.4
  502. - auth request module added
  503. * Tue Jul 30 2013 Sergey Budnevitch <sb@nginx.com>
  504. - 1.5.3
  505. * Tue Jul 2 2013 Sergey Budnevitch <sb@nginx.com>
  506. - 1.5.2
  507. * Tue Jun 4 2013 Sergey Budnevitch <sb@nginx.com>
  508. - 1.5.1
  509. * Mon May 6 2013 Sergey Budnevitch <sb@nginx.com>
  510. - 1.5.0
  511. * Tue Apr 16 2013 Sergey Budnevitch <sb@nginx.com>
  512. - 1.3.16
  513. * Tue Mar 26 2013 Sergey Budnevitch <sb@nginx.com>
  514. - 1.3.15
  515. - gunzip module added
  516. - set permissions on default log files at installation
  517. * Tue Feb 12 2013 Sergey Budnevitch <sb@nginx.com>
  518. - excess slash removed from --prefix
  519. - 1.2.7
  520. * Tue Dec 11 2012 Sergey Budnevitch <sb@nginx.com>
  521. - 1.2.6
  522. * Tue Nov 13 2012 Sergey Budnevitch <sb@nginx.com>
  523. - 1.2.5
  524. * Tue Sep 25 2012 Sergey Budnevitch <sb@nginx.com>
  525. - 1.2.4
  526. * Tue Aug 7 2012 Sergey Budnevitch <sb@nginx.com>
  527. - 1.2.3
  528. - nginx-debug package now actually contains non stripped binary
  529. * Tue Jul 3 2012 Sergey Budnevitch <sb@nginx.com>
  530. - 1.2.2
  531. * Tue Jun 5 2012 Sergey Budnevitch <sb@nginx.com>
  532. - 1.2.1
  533. * Mon Apr 23 2012 Sergey Budnevitch <sb@nginx.com>
  534. - 1.2.0
  535. * Thu Apr 12 2012 Sergey Budnevitch <sb@nginx.com>
  536. - 1.0.15
  537. * Thu Mar 15 2012 Sergey Budnevitch <sb@nginx.com>
  538. - 1.0.14
  539. - OpenSUSE init script and SuSE specific changes to spec file added
  540. * Mon Mar 5 2012 Sergey Budnevitch <sb@nginx.com>
  541. - 1.0.13
  542. * Mon Feb 6 2012 Sergey Budnevitch <sb@nginx.com>
  543. - 1.0.12
  544. - banner added to install script
  545. * Thu Dec 15 2011 Sergey Budnevitch <sb@nginx.com>
  546. - 1.0.11
  547. - init script enhancements (thanks to Gena Makhomed)
  548. - one second sleep during upgrade replaced with 0.1 sec usleep
  549. * Tue Nov 15 2011 Sergey Budnevitch <sb@nginx.com>
  550. - 1.0.10
  551. * Tue Nov 1 2011 Sergey Budnevitch <sb@nginx.com>
  552. - 1.0.9
  553. - nginx-debug package added
  554. * Tue Oct 11 2011 Sergey Budnevitch <sb@nginx.com>
  555. - spec file cleanup (thanks to Yury V. Zaytsev)
  556. - log dir permitions fixed
  557. - logrotate creates new logfiles with nginx owner
  558. - "upgrade" argument to init-script added (based on fedora one)
  559. * Sat Oct 1 2011 Sergey Budnevitch <sb@nginx.com>
  560. - 1.0.8
  561. - built with mp4 module
  562. * Fri Sep 30 2011 Sergey Budnevitch <sb@nginx.com>
  563. - 1.0.7
  564. * Tue Aug 30 2011 Sergey Budnevitch <sb@nginx.com>
  565. - 1.0.6
  566. - replace "conf.d/*" config include with "conf.d/*.conf" in default nginx.conf
  567. * Wed Aug 10 2011 Sergey Budnevitch
  568. - Initial release