123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288 |
- %define commit0 a71f931
- %define commit1 ed738e8
- #
- %define nginx_user nginx
- %define nginx_group nginx
- %define __arch_install_post /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot
- %if 0%{?rhel} || 0%{?amzn} || 0%{?fedora}
- %define _group System Environment/Daemons
- %if 0%{?amzn} == 2
- BuildRequires: openssl11-devel
- %else
- BuildRequires: openssl-devel
- %endif
- %endif
- %if 0%{?suse_version} >= 1315
- %define _group Productivity/Networking/Web/Servers
- BuildRequires: libopenssl-devel
- %define _debugsource_template %{nil}
- %endif
- %if (0%{?rhel} == 7) && (0%{?amzn} == 0)
- %define epoch 1
- Epoch: %{epoch}
- %define dist .el7
- %endif
- %if (0%{?rhel} == 7) && (0%{?amzn} == 2)
- %define epoch 1
- Epoch: %{epoch}
- %endif
- %if 0%{?rhel} == 8
- %define epoch 1
- Epoch: %{epoch}
- %define _debugsource_template %{nil}
- %endif
- %if 0%{?rhel} == 9
- %define epoch 1
- Epoch: %{epoch}
- BuildRequires: gcc
- %define _debugsource_template %{nil}
- %endif
- %if 0%{?fedora}
- %define _debugsource_template %{nil}
- %global _hardened_build 1
- %endif
- BuildRequires: git
- BuildRequires: cmake
- %define mod_version 1.0.0rc+git9.g%{commit0}
- %define base_version 1.25.3
- %define base_release 1%{?dist}.ngx
- %define bdir %{_builddir}/%{name}-%{base_version}
- Summary: nginx Brotli dynamic modules
- Name: nginx-module-brotli
- Version: %{mod_version}
- Release: %{base_release}
- Vendor: Eugene Wu <kuretru@gmail.com>
- URL: https://github.com/kuretru/nginx-module-brotli
- Group: %{_group}
- #!RemoteAsset: sha256:64c5b975ca287939e828303fa857d22f142b251f17808dfe41733512d9cded86
- Source0: https://nginx.org/download/nginx-%{base_version}.tar.gz
- Source1: COPYRIGHT
- #!RemoteAsset: sha256:1d21be34f3b7b6d05a8142945e59b3a47665edcdfe0f3ee3d3dbef121f90c08c
- Source2: https://github.com/google/ngx_brotli/archive/%{commit0}.tar.gz
- #!RemoteAsset: sha256:aaa739962a45b508b2e783b915e6b2b57ed3b12bd4b0feac73acfb144dffa54f
- Source3: https://github.com/google/brotli/archive/%{commit1}.tar.gz
- License: 2-clause BSD-like license
- BuildRoot: %{_tmppath}/%{name}-%{base_version}-%{base_release}-root
- BuildRequires: zlib-devel
- BuildRequires: pcre2-devel
- BuildRequires: nginx-r%{base_version}
- Requires: nginx-r%{base_version}
- Provides: %{name}-r%{base_version}
- %description
- nginx Brotli dynamic modules.
- %if 0%{?suse_version}
- %debug_package
- %endif
- %define WITH_CC_OPT $(echo %{optflags} $(pcre2-config --cflags))
- %define WITH_LD_OPT -Wl,-z,relro -Wl,-z,now
- %define BASE_CONFIGURE_ARGS $(echo "--prefix=%{_sysconfdir}/nginx --sbin-path=%{_sbindir}/nginx --modules-path=%{_libdir}/nginx/modules --conf-path=%{_sysconfdir}/nginx/nginx.conf --error-log-path=%{_localstatedir}/log/nginx/error.log --http-log-path=%{_localstatedir}/log/nginx/access.log --pid-path=%{_localstatedir}/run/nginx.pid --lock-path=%{_localstatedir}/run/nginx.lock --http-client-body-temp-path=%{_localstatedir}/cache/nginx/client_temp --http-proxy-temp-path=%{_localstatedir}/cache/nginx/proxy_temp --http-fastcgi-temp-path=%{_localstatedir}/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=%{_localstatedir}/cache/nginx/uwsgi_temp --http-scgi-temp-path=%{_localstatedir}/cache/nginx/scgi_temp --user=%{nginx_user} --group=%{nginx_group} --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module $( if [ 0%{?rhel} -eq 7 ] || [ 0%{?suse_version} -eq 1315 ]; then continue; else echo "--with-http_v3_module"; fi; ) --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module")
- %define MODULE_CONFIGURE_ARGS $(echo "--add-dynamic-module=./ngx_brotli/")
- %prep
- %setup -qcTn %{name}-%{base_version}
- tar --strip-components=1 -zxf %{SOURCE0}
- mkdir ngx_brotli
- tar --strip-components=1 -zxf %{SOURCE2} -C ngx_brotli
- cd ngx_brotli/deps/brotli/
- tar --strip-components=1 -zxf %{SOURCE3}
- mkdir out && cd out/
- cmake -DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS=OFF -DCMAKE_C_FLAGS="-Ofast -m64 -march=native -mtune=native -flto -funroll-loops -ffunction-sections -fdata-sections -Wl,--gc-sections" -DCMAKE_CXX_FLAGS="-Ofast -m64 -march=native -mtune=native -flto -funroll-loops -ffunction-sections -fdata-sections -Wl,--gc-sections" -DCMAKE_C_COMPILER_WORKS=ON -DCMAKE_INSTALL_PREFIX=./installed ..
- cmake --build . --config Release --target brotlienc
- cd ../../../../
- %build
- cd %{bdir}
- ./configure %{BASE_CONFIGURE_ARGS} %{MODULE_CONFIGURE_ARGS} \
- --with-cc-opt="%{WITH_CC_OPT} " \
- --with-ld-opt="%{WITH_LD_OPT} " \
- --with-debug
- make %{?_smp_mflags} modules
- for so in `find %{bdir}/objs/ -type f -name "*.so"`; do
- debugso=`echo $so | sed -e 's|\.so$|-debug.so|'`
- mv $so $debugso
- done
- ./configure %{BASE_CONFIGURE_ARGS} %{MODULE_CONFIGURE_ARGS} \
- --with-cc-opt="%{WITH_CC_OPT} " \
- --with-ld-opt="%{WITH_LD_OPT} "
- make %{?_smp_mflags} modules
- %install
- cd %{bdir}
- %{__rm} -rf $RPM_BUILD_ROOT
- %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/doc/nginx-module-brotli
- %{__install} -m 644 -p %{SOURCE1} \
- $RPM_BUILD_ROOT%{_datadir}/doc/nginx-module-brotli/
- %{__mkdir} -p $RPM_BUILD_ROOT%{_libdir}/nginx/modules
- for so in `find %{bdir}/objs/ -maxdepth 1 -type f -name "*.so"`; do
- %{__install} -m755 $so \
- $RPM_BUILD_ROOT%{_libdir}/nginx/modules/
- done
- %check
- %{__rm} -rf $RPM_BUILD_ROOT/usr/src
- cd %{bdir}
- grep -v 'usr/src' debugfiles.list > debugfiles.list.new && mv debugfiles.list.new debugfiles.list
- cat /dev/null > debugsources.list
- %if 0%{?suse_version} >= 1500
- cat /dev/null > debugsourcefiles.list
- %endif
- %clean
- %{__rm} -rf $RPM_BUILD_ROOT
- %files
- %defattr(-,root,root)
- %{_libdir}/nginx/modules/*
- %dir %{_datadir}/doc/nginx-module-brotli
- %{_datadir}/doc/nginx-module-brotli/*
- %post
- if [ $1 -eq 1 ]; then
- cat <<BANNER
- ----------------------------------------------------------------------
- The Brotli dynamic module for nginx has been installed.
- To enable this module, add the following to /etc/nginx/nginx.conf
- and reload nginx:
- load_module modules/ngx_http_brotli_filter_module.so;
- load_module modules/ngx_http_brotli_static_module.so;
- Please refer to the module documentation for further details:
- https://github.com/google/ngx_brotli
- https://github.com/google/brotli
- ----------------------------------------------------------------------
- BANNER
- fi
- %changelog
- * Sun Oct 29 2023 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.25.3
- * Mon Aug 7 2023 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.25.2
- * Thu Jul 13 2023 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.25.1
- * Fri May 26 2023 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.25.0
- * Wed Mar 29 2023 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.23.4
- * Sun Jan 1 2023 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.23.3
- * Fri Oct 21 2022 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.23.2
- * Sat Jul 23 2022 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.23.1
- * Wed Jun 22 2022 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.23.0
- * Thu Jan 27 2022 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.21.6
- * Mon Jan 3 2022 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.21.5
- * Tue Nov 9 2021 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.21.4
- * Fri Sep 10 2021 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.21.3
- * Thu Sep 2 2021 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.21.2
- * Wed Jul 7 2021 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.21.1
- * Thu May 27 2021 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.21.0
- * Thu Apr 15 2021 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.19.10
- * Wed Mar 31 2021 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.19.9
- * Thu Mar 11 2021 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.19.8
- * Thu Feb 18 2021 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.19.7
- * Tue Dec 22 2020 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.19.6
- * Wed Nov 25 2020 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.19.5
- * Fri Oct 30 2020 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.19.4
- * Thu Oct 1 2020 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.19.3
- * Wed Aug 12 2020 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.19.2
- * Wed Jul 8 2020 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.19.1
- * Wed May 27 2020 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.19.0
- * Sat Apr 18 2020 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.17.10
- * Thu Mar 5 2020 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.17.9
- * Thu Jan 23 2020 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.17.8
- * Sat Dec 28 2019 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.17.7
- * Mon Nov 25 2019 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.17.6
- * Wed Oct 23 2019 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.17.5
- * Sun Oct 13 2019 Eugene Wu <kuretru@gmail.com>
- - base version updated to 1.17.4
|