nginx-module-brotli.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268
  1. #
  2. %define nginx_user nginx
  3. %define nginx_group nginx
  4. %define __arch_install_post /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot
  5. %if 0%{?rhel} || 0%{?amzn} || 0%{?fedora}
  6. %define _group System Environment/Daemons
  7. %if 0%{?amzn} == 2
  8. BuildRequires: openssl11-devel
  9. %else
  10. BuildRequires: openssl-devel
  11. %endif
  12. %endif
  13. %if 0%{?suse_version} >= 1315
  14. %define _group Productivity/Networking/Web/Servers
  15. BuildRequires: libopenssl-devel
  16. %define _debugsource_template %{nil}
  17. %endif
  18. %if (0%{?rhel} == 7) && (0%{?amzn} == 0)
  19. %define epoch 1
  20. Epoch: %{epoch}
  21. %define dist .el7
  22. %endif
  23. %if (0%{?rhel} == 7) && (0%{?amzn} == 2)
  24. %define epoch 1
  25. Epoch: %{epoch}
  26. %endif
  27. %if 0%{?rhel} == 8
  28. %define epoch 1
  29. Epoch: %{epoch}
  30. %define _debugsource_template %{nil}
  31. %endif
  32. %if 0%{?rhel} == 9
  33. %define epoch 1
  34. Epoch: %{epoch}
  35. BuildRequires: gcc
  36. %define _debugsource_template %{nil}
  37. %endif
  38. %if 0%{?fedora}
  39. %define _debugsource_template %{nil}
  40. %global _hardened_build 1
  41. %endif
  42. BuildRequires: git
  43. %define base_version 1.25.2
  44. %define base_release 1%{?dist}.ngx
  45. %define bdir %{_builddir}/%{name}-%{base_version}
  46. Summary: nginx Brotli dynamic modules
  47. Name: nginx-module-brotli
  48. Version: %{base_version}
  49. Release: %{base_release}
  50. Vendor: Eugene Wu <kuretru@gmail.com>
  51. URL: https://github.com/kuretru/nginx-module-brotli
  52. Group: %{_group}
  53. Source0: https://nginx.org/download/nginx-%{base_version}.tar.gz
  54. Source1: COPYRIGHT
  55. License: 2-clause BSD-like license
  56. BuildRoot: %{_tmppath}/%{name}-%{base_version}-%{base_release}-root
  57. BuildRequires: zlib-devel
  58. BuildRequires: pcre2-devel
  59. Requires: nginx-r%{base_version}
  60. Provides: %{name}-r%{base_version}
  61. %description
  62. nginx Brotli dynamic modules.
  63. %if 0%{?suse_version}
  64. %debug_package
  65. %endif
  66. %define WITH_CC_OPT $(echo %{optflags} $(pcre2-config --cflags))
  67. %define WITH_LD_OPT -Wl,-z,relro -Wl,-z,now
  68. %define BASE_CONFIGURE_ARGS $(echo "--prefix=%{_sysconfdir}/nginx --sbin-path=%{_sbindir}/nginx --modules-path=%{_libdir}/nginx/modules --conf-path=%{_sysconfdir}/nginx/nginx.conf --error-log-path=%{_localstatedir}/log/nginx/error.log --http-log-path=%{_localstatedir}/log/nginx/access.log --pid-path=%{_localstatedir}/run/nginx.pid --lock-path=%{_localstatedir}/run/nginx.lock --http-client-body-temp-path=%{_localstatedir}/cache/nginx/client_temp --http-proxy-temp-path=%{_localstatedir}/cache/nginx/proxy_temp --http-fastcgi-temp-path=%{_localstatedir}/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=%{_localstatedir}/cache/nginx/uwsgi_temp --http-scgi-temp-path=%{_localstatedir}/cache/nginx/scgi_temp --user=%{nginx_user} --group=%{nginx_group} --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module $( if [ 0%{?rhel} -eq 7 ] || [ 0%{?suse_version} -eq 1315 ]; then continue; else echo "--with-http_v3_module"; fi; ) --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module")
  69. %define MODULE_CONFIGURE_ARGS $(echo "--add-dynamic-module=./ngx_brotli/")
  70. %prep
  71. %setup -qcTn %{name}-%{base_version}
  72. tar --strip-components=1 -zxf %{SOURCE0}
  73. git clone --recursive https://github.com/google/ngx_brotli.git
  74. %build
  75. cd %{bdir}
  76. ./configure %{BASE_CONFIGURE_ARGS} %{MODULE_CONFIGURE_ARGS} \
  77. --with-cc-opt="%{WITH_CC_OPT} " \
  78. --with-ld-opt="%{WITH_LD_OPT} " \
  79. --with-debug
  80. make %{?_smp_mflags} modules
  81. for so in `find %{bdir}/objs/ -type f -name "*.so"`; do
  82. debugso=`echo $so | sed -e 's|\.so$|-debug.so|'`
  83. mv $so $debugso
  84. done
  85. ./configure %{BASE_CONFIGURE_ARGS} %{MODULE_CONFIGURE_ARGS} \
  86. --with-cc-opt="%{WITH_CC_OPT} " \
  87. --with-ld-opt="%{WITH_LD_OPT} "
  88. make %{?_smp_mflags} modules
  89. %install
  90. cd %{bdir}
  91. %{__rm} -rf $RPM_BUILD_ROOT
  92. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/doc/nginx-module-brotli
  93. %{__install} -m 644 -p %{SOURCE1} \
  94. $RPM_BUILD_ROOT%{_datadir}/doc/nginx-module-brotli/
  95. %{__mkdir} -p $RPM_BUILD_ROOT%{_libdir}/nginx/modules
  96. for so in `find %{bdir}/objs/ -maxdepth 1 -type f -name "*.so"`; do
  97. %{__install} -m755 $so \
  98. $RPM_BUILD_ROOT%{_libdir}/nginx/modules/
  99. done
  100. %check
  101. %{__rm} -rf $RPM_BUILD_ROOT/usr/src
  102. cd %{bdir}
  103. grep -v 'usr/src' debugfiles.list > debugfiles.list.new && mv debugfiles.list.new debugfiles.list
  104. cat /dev/null > debugsources.list
  105. %if 0%{?suse_version} >= 1500
  106. cat /dev/null > debugsourcefiles.list
  107. %endif
  108. %clean
  109. %{__rm} -rf $RPM_BUILD_ROOT
  110. %files
  111. %defattr(-,root,root)
  112. %{_libdir}/nginx/modules/*
  113. %dir %{_datadir}/doc/nginx-module-brotli
  114. %{_datadir}/doc/nginx-module-brotli/*
  115. %post
  116. if [ $1 -eq 1 ]; then
  117. cat <<BANNER
  118. ----------------------------------------------------------------------
  119. The Brotli dynamic module for nginx has been installed.
  120. To enable this module, add the following to /etc/nginx/nginx.conf
  121. and reload nginx:
  122. load_module modules/ngx_http_brotli_filter_module.so;
  123. load_module modules/ngx_http_brotli_static_module.so;
  124. Please refer to the module documentation for further details:
  125. https://github.com/google/ngx_brotli
  126. https://github.com/google/brotli
  127. ----------------------------------------------------------------------
  128. BANNER
  129. fi
  130. %changelog
  131. * Thu Aug 7 2023 Eugene Wu <kuretru@gmail.com>
  132. - base version updated to 1.25.2
  133. * Thu Jul 13 2023 Eugene Wu <kuretru@gmail.com>
  134. - base version updated to 1.25.1
  135. * Fri May 26 2023 Eugene Wu <kuretru@gmail.com>
  136. - base version updated to 1.25.0
  137. * Wed Mar 29 2023 Eugene Wu <kuretru@gmail.com>
  138. - base version updated to 1.23.4
  139. * Sun Jan 1 2023 Eugene Wu <kuretru@gmail.com>
  140. - base version updated to 1.23.3
  141. * Fri Oct 21 2022 Eugene Wu <kuretru@gmail.com>
  142. - base version updated to 1.23.2
  143. * Sat Jul 23 2022 Eugene Wu <kuretru@gmail.com>
  144. - base version updated to 1.23.1
  145. * Wed Jun 22 2022 Eugene Wu <kuretru@gmail.com>
  146. - base version updated to 1.23.0
  147. * Thu Jan 27 2022 Eugene Wu <kuretru@gmail.com>
  148. - base version updated to 1.21.6
  149. * Mon Jan 3 2022 Eugene Wu <kuretru@gmail.com>
  150. - base version updated to 1.21.5
  151. * Tue Nov 9 2021 Eugene Wu <kuretru@gmail.com>
  152. - base version updated to 1.21.4
  153. * Fri Sep 10 2021 Eugene Wu <kuretru@gmail.com>
  154. - base version updated to 1.21.3
  155. * Thu Sep 2 2021 Eugene Wu <kuretru@gmail.com>
  156. - base version updated to 1.21.2
  157. * Wed Jul 7 2021 Eugene Wu <kuretru@gmail.com>
  158. - base version updated to 1.21.1
  159. * Thu May 27 2021 Eugene Wu <kuretru@gmail.com>
  160. - base version updated to 1.21.0
  161. * Thu Apr 15 2021 Eugene Wu <kuretru@gmail.com>
  162. - base version updated to 1.19.10
  163. * Wed Mar 31 2021 Eugene Wu <kuretru@gmail.com>
  164. - base version updated to 1.19.9
  165. * Thu Mar 11 2021 Eugene Wu <kuretru@gmail.com>
  166. - base version updated to 1.19.8
  167. * Thu Feb 18 2021 Eugene Wu <kuretru@gmail.com>
  168. - base version updated to 1.19.7
  169. * Tue Dec 22 2020 Eugene Wu <kuretru@gmail.com>
  170. - base version updated to 1.19.6
  171. * Wed Nov 25 2020 Eugene Wu <kuretru@gmail.com>
  172. - base version updated to 1.19.5
  173. * Fri Oct 30 2020 Eugene Wu <kuretru@gmail.com>
  174. - base version updated to 1.19.4
  175. * Thu Oct 1 2020 Eugene Wu <kuretru@gmail.com>
  176. - base version updated to 1.19.3
  177. * Wed Aug 12 2020 Eugene Wu <kuretru@gmail.com>
  178. - base version updated to 1.19.2
  179. * Wed Jul 8 2020 Eugene Wu <kuretru@gmail.com>
  180. - base version updated to 1.19.1
  181. * Wed May 27 2020 Eugene Wu <kuretru@gmail.com>
  182. - base version updated to 1.19.0
  183. * Sat Apr 18 2020 Eugene Wu <kuretru@gmail.com>
  184. - base version updated to 1.17.10
  185. * Thu Mar 5 2020 Eugene Wu <kuretru@gmail.com>
  186. - base version updated to 1.17.9
  187. * Thu Jan 23 2020 Eugene Wu <kuretru@gmail.com>
  188. - base version updated to 1.17.8
  189. * Sat Dec 28 2019 Eugene Wu <kuretru@gmail.com>
  190. - base version updated to 1.17.7
  191. * Mon Nov 25 2019 Eugene Wu <kuretru@gmail.com>
  192. - base version updated to 1.17.6
  193. * Wed Oct 23 2019 Eugene Wu <kuretru@gmail.com>
  194. - base version updated to 1.17.5
  195. * Sun Oct 13 2019 Eugene Wu <kuretru@gmail.com>
  196. - base version updated to 1.17.4