nginx-module-brotli.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287
  1. %define commit0 a71f931
  2. %define commit1 ed738e8
  3. #
  4. %define nginx_user nginx
  5. %define nginx_group nginx
  6. %define __arch_install_post /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot
  7. %if 0%{?rhel} || 0%{?amzn} || 0%{?fedora}
  8. %define _group System Environment/Daemons
  9. %if 0%{?amzn} == 2
  10. BuildRequires: openssl11-devel
  11. %else
  12. BuildRequires: openssl-devel
  13. %endif
  14. %endif
  15. %if 0%{?suse_version} >= 1315
  16. %define _group Productivity/Networking/Web/Servers
  17. BuildRequires: libopenssl-devel
  18. %define _debugsource_template %{nil}
  19. %endif
  20. %if (0%{?rhel} == 7) && (0%{?amzn} == 0)
  21. %define epoch 1
  22. Epoch: %{epoch}
  23. %define dist .el7
  24. %endif
  25. %if (0%{?rhel} == 7) && (0%{?amzn} == 2)
  26. %define epoch 1
  27. Epoch: %{epoch}
  28. %endif
  29. %if 0%{?rhel} == 8
  30. %define epoch 1
  31. Epoch: %{epoch}
  32. %define _debugsource_template %{nil}
  33. %endif
  34. %if 0%{?rhel} == 9
  35. %define epoch 1
  36. Epoch: %{epoch}
  37. BuildRequires: gcc
  38. %define _debugsource_template %{nil}
  39. %endif
  40. %if 0%{?fedora}
  41. %define _debugsource_template %{nil}
  42. %global _hardened_build 1
  43. %endif
  44. BuildRequires: git
  45. BuildRequires: cmake
  46. %define ngx_version 1.25.3
  47. %define base_version 1.0.0rc+git9.g%{commit0}
  48. %define base_release 1%{?dist}.ngx
  49. %define bdir %{_builddir}/%{name}-%{base_version}
  50. Summary: nginx Brotli dynamic modules
  51. Name: nginx-module-brotli
  52. Version: %{base_version}
  53. Release: %{base_release}
  54. Vendor: Eugene Wu <kuretru@gmail.com>
  55. URL: https://github.com/kuretru/nginx-module-brotli
  56. Group: %{_group}
  57. #!RemoteAsset: sha256:64c5b975ca287939e828303fa857d22f142b251f17808dfe41733512d9cded86
  58. Source0: https://nginx.org/download/nginx-%{ngx_version}.tar.gz
  59. Source1: COPYRIGHT
  60. #!RemoteAsset: sha256:1d21be34f3b7b6d05a8142945e59b3a47665edcdfe0f3ee3d3dbef121f90c08c
  61. Source2: https://github.com/google/ngx_brotli/archive/%{commit0}.tar.gz
  62. #!RemoteAsset: sha256:aaa739962a45b508b2e783b915e6b2b57ed3b12bd4b0feac73acfb144dffa54f
  63. Source3: https://github.com/google/brotli/archive/%{commit1}.tar.gz
  64. License: 2-clause BSD-like license
  65. BuildRoot: %{_tmppath}/%{name}-%{base_version}-%{base_release}-root
  66. BuildRequires: zlib-devel
  67. BuildRequires: pcre2-devel
  68. Requires: nginx-r%{base_version}
  69. Provides: %{name}-r%{base_version}
  70. %description
  71. nginx Brotli dynamic modules.
  72. %if 0%{?suse_version}
  73. %debug_package
  74. %endif
  75. %define WITH_CC_OPT $(echo %{optflags} $(pcre2-config --cflags))
  76. %define WITH_LD_OPT -Wl,-z,relro -Wl,-z,now
  77. %define BASE_CONFIGURE_ARGS $(echo "--prefix=%{_sysconfdir}/nginx --sbin-path=%{_sbindir}/nginx --modules-path=%{_libdir}/nginx/modules --conf-path=%{_sysconfdir}/nginx/nginx.conf --error-log-path=%{_localstatedir}/log/nginx/error.log --http-log-path=%{_localstatedir}/log/nginx/access.log --pid-path=%{_localstatedir}/run/nginx.pid --lock-path=%{_localstatedir}/run/nginx.lock --http-client-body-temp-path=%{_localstatedir}/cache/nginx/client_temp --http-proxy-temp-path=%{_localstatedir}/cache/nginx/proxy_temp --http-fastcgi-temp-path=%{_localstatedir}/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=%{_localstatedir}/cache/nginx/uwsgi_temp --http-scgi-temp-path=%{_localstatedir}/cache/nginx/scgi_temp --user=%{nginx_user} --group=%{nginx_group} --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module $( if [ 0%{?rhel} -eq 7 ] || [ 0%{?suse_version} -eq 1315 ]; then continue; else echo "--with-http_v3_module"; fi; ) --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module")
  78. %define MODULE_CONFIGURE_ARGS $(echo "--add-dynamic-module=./ngx_brotli/")
  79. %prep
  80. %setup -qcTn %{name}-%{base_version}
  81. tar --strip-components=1 -zxf %{SOURCE0}
  82. mkdir ngx_brotli
  83. tar --strip-components=1 -zxf %{SOURCE2} -C ngx_brotli
  84. cd ngx_brotli/deps/brotli/
  85. tar --strip-components=1 -zxf %{SOURCE3}
  86. mkdir out && cd out/
  87. cmake -DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS=OFF -DCMAKE_C_FLAGS="-Ofast -m64 -march=native -mtune=native -flto -funroll-loops -ffunction-sections -fdata-sections -Wl,--gc-sections" -DCMAKE_CXX_FLAGS="-Ofast -m64 -march=native -mtune=native -flto -funroll-loops -ffunction-sections -fdata-sections -Wl,--gc-sections" -DCMAKE_C_COMPILER_WORKS=ON -DCMAKE_INSTALL_PREFIX=./installed ..
  88. cmake --build . --config Release --target brotlienc
  89. cd ../../../../
  90. %build
  91. cd %{bdir}
  92. ./configure %{BASE_CONFIGURE_ARGS} %{MODULE_CONFIGURE_ARGS} \
  93. --with-cc-opt="%{WITH_CC_OPT} " \
  94. --with-ld-opt="%{WITH_LD_OPT} " \
  95. --with-debug
  96. make %{?_smp_mflags} modules
  97. for so in `find %{bdir}/objs/ -type f -name "*.so"`; do
  98. debugso=`echo $so | sed -e 's|\.so$|-debug.so|'`
  99. mv $so $debugso
  100. done
  101. ./configure %{BASE_CONFIGURE_ARGS} %{MODULE_CONFIGURE_ARGS} \
  102. --with-cc-opt="%{WITH_CC_OPT} " \
  103. --with-ld-opt="%{WITH_LD_OPT} "
  104. make %{?_smp_mflags} modules
  105. %install
  106. cd %{bdir}
  107. %{__rm} -rf $RPM_BUILD_ROOT
  108. %{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/doc/nginx-module-brotli
  109. %{__install} -m 644 -p %{SOURCE1} \
  110. $RPM_BUILD_ROOT%{_datadir}/doc/nginx-module-brotli/
  111. %{__mkdir} -p $RPM_BUILD_ROOT%{_libdir}/nginx/modules
  112. for so in `find %{bdir}/objs/ -maxdepth 1 -type f -name "*.so"`; do
  113. %{__install} -m755 $so \
  114. $RPM_BUILD_ROOT%{_libdir}/nginx/modules/
  115. done
  116. %check
  117. %{__rm} -rf $RPM_BUILD_ROOT/usr/src
  118. cd %{bdir}
  119. grep -v 'usr/src' debugfiles.list > debugfiles.list.new && mv debugfiles.list.new debugfiles.list
  120. cat /dev/null > debugsources.list
  121. %if 0%{?suse_version} >= 1500
  122. cat /dev/null > debugsourcefiles.list
  123. %endif
  124. %clean
  125. %{__rm} -rf $RPM_BUILD_ROOT
  126. %files
  127. %defattr(-,root,root)
  128. %{_libdir}/nginx/modules/*
  129. %dir %{_datadir}/doc/nginx-module-brotli
  130. %{_datadir}/doc/nginx-module-brotli/*
  131. %post
  132. if [ $1 -eq 1 ]; then
  133. cat <<BANNER
  134. ----------------------------------------------------------------------
  135. The Brotli dynamic module for nginx has been installed.
  136. To enable this module, add the following to /etc/nginx/nginx.conf
  137. and reload nginx:
  138. load_module modules/ngx_http_brotli_filter_module.so;
  139. load_module modules/ngx_http_brotli_static_module.so;
  140. Please refer to the module documentation for further details:
  141. https://github.com/google/ngx_brotli
  142. https://github.com/google/brotli
  143. ----------------------------------------------------------------------
  144. BANNER
  145. fi
  146. %changelog
  147. * Sun Oct 29 2023 Eugene Wu <kuretru@gmail.com>
  148. - base version updated to 1.25.3
  149. * Mon Aug 7 2023 Eugene Wu <kuretru@gmail.com>
  150. - base version updated to 1.25.2
  151. * Thu Jul 13 2023 Eugene Wu <kuretru@gmail.com>
  152. - base version updated to 1.25.1
  153. * Fri May 26 2023 Eugene Wu <kuretru@gmail.com>
  154. - base version updated to 1.25.0
  155. * Wed Mar 29 2023 Eugene Wu <kuretru@gmail.com>
  156. - base version updated to 1.23.4
  157. * Sun Jan 1 2023 Eugene Wu <kuretru@gmail.com>
  158. - base version updated to 1.23.3
  159. * Fri Oct 21 2022 Eugene Wu <kuretru@gmail.com>
  160. - base version updated to 1.23.2
  161. * Sat Jul 23 2022 Eugene Wu <kuretru@gmail.com>
  162. - base version updated to 1.23.1
  163. * Wed Jun 22 2022 Eugene Wu <kuretru@gmail.com>
  164. - base version updated to 1.23.0
  165. * Thu Jan 27 2022 Eugene Wu <kuretru@gmail.com>
  166. - base version updated to 1.21.6
  167. * Mon Jan 3 2022 Eugene Wu <kuretru@gmail.com>
  168. - base version updated to 1.21.5
  169. * Tue Nov 9 2021 Eugene Wu <kuretru@gmail.com>
  170. - base version updated to 1.21.4
  171. * Fri Sep 10 2021 Eugene Wu <kuretru@gmail.com>
  172. - base version updated to 1.21.3
  173. * Thu Sep 2 2021 Eugene Wu <kuretru@gmail.com>
  174. - base version updated to 1.21.2
  175. * Wed Jul 7 2021 Eugene Wu <kuretru@gmail.com>
  176. - base version updated to 1.21.1
  177. * Thu May 27 2021 Eugene Wu <kuretru@gmail.com>
  178. - base version updated to 1.21.0
  179. * Thu Apr 15 2021 Eugene Wu <kuretru@gmail.com>
  180. - base version updated to 1.19.10
  181. * Wed Mar 31 2021 Eugene Wu <kuretru@gmail.com>
  182. - base version updated to 1.19.9
  183. * Thu Mar 11 2021 Eugene Wu <kuretru@gmail.com>
  184. - base version updated to 1.19.8
  185. * Thu Feb 18 2021 Eugene Wu <kuretru@gmail.com>
  186. - base version updated to 1.19.7
  187. * Tue Dec 22 2020 Eugene Wu <kuretru@gmail.com>
  188. - base version updated to 1.19.6
  189. * Wed Nov 25 2020 Eugene Wu <kuretru@gmail.com>
  190. - base version updated to 1.19.5
  191. * Fri Oct 30 2020 Eugene Wu <kuretru@gmail.com>
  192. - base version updated to 1.19.4
  193. * Thu Oct 1 2020 Eugene Wu <kuretru@gmail.com>
  194. - base version updated to 1.19.3
  195. * Wed Aug 12 2020 Eugene Wu <kuretru@gmail.com>
  196. - base version updated to 1.19.2
  197. * Wed Jul 8 2020 Eugene Wu <kuretru@gmail.com>
  198. - base version updated to 1.19.1
  199. * Wed May 27 2020 Eugene Wu <kuretru@gmail.com>
  200. - base version updated to 1.19.0
  201. * Sat Apr 18 2020 Eugene Wu <kuretru@gmail.com>
  202. - base version updated to 1.17.10
  203. * Thu Mar 5 2020 Eugene Wu <kuretru@gmail.com>
  204. - base version updated to 1.17.9
  205. * Thu Jan 23 2020 Eugene Wu <kuretru@gmail.com>
  206. - base version updated to 1.17.8
  207. * Sat Dec 28 2019 Eugene Wu <kuretru@gmail.com>
  208. - base version updated to 1.17.7
  209. * Mon Nov 25 2019 Eugene Wu <kuretru@gmail.com>
  210. - base version updated to 1.17.6
  211. * Wed Oct 23 2019 Eugene Wu <kuretru@gmail.com>
  212. - base version updated to 1.17.5
  213. * Sun Oct 13 2019 Eugene Wu <kuretru@gmail.com>
  214. - base version updated to 1.17.4